Disabling command-I (capture input) as a Parallels hot key

Discussion in 'Parallels Desktop for Mac' started by far, Oct 4, 2006.

  1. far

    far

    Messages:
    10
    I need to use command-I for another purpose in a Windows XP application. Unfortunately, it appears that command-I is hard-wired into the VM menu, as shown in the attached screen capture. Parallels doesn't pass through the command-I to my application. Interestingly, Parallels *does* pass through command-L (which is fortunate, because I also need this). Beats me...

    I have the Parallels Tools fully installed (and they work beautifully, except for the occasionally munched final character in copy-paste operations between operating systems), so I don't need to worry about capturing and/or releasing the keyboard and mouse.

    How do I tell Parallels to ignore command-I? Or how can I specify another key combination for Parallels (if Parallels insists on having something defined for capturing input, even if you don't need/want to do so)?

    Thanks.
     

    Attached Files:

  2. constant

    constant

    Messages:
    1,010
    .
    Try holding down the function key, then do command-I. Hopefully you have at least three fingers.
    .
     
  3. far

    far

    Messages:
    10
    Thanks for the suggestion. On a MacBookPro, this simply sends command-5 (i.e., the key combination "function-I" simply MEANS "the number 5").

    The issue is to "motivate" Parallels Desktop to absolutely ignore and pass through the "command-I" key combination.
     
  4. joem

    joem

    Messages:
    1,247
    Since there is no command key in Windows, why do you need to pass command-anything to Windows? Why not just use the keys that Windows understands?

    If you are trying to use command instead of control to make Windows more Mac-like, well... Windows is not Mac and never will be.
     
  5. far

    far

    Messages:
    10
    Very perceptive. For client reasons (mainly the TrackPoint), I am constrained to using a ThinkPad USB keyboard with UltraNav.

    See http://www-131.ibm.com/webapp/wcs/s...=1000073&categoryId=2581898&productId=8581826

    I want the client to be able to START using the Mac from the comfort of his PC keyboard & mice/ThinkPad/TrackPoint (that's why I have installed the wonderful Parallels Tools with their transparent mouse & keyboard support ACROSS the various operating systems, including the host Mac OS X and several instances of Windows within the same Mac). There is no reason to use Parallel's "Capture Input" in this case.

    The ability to seamlessly move the pointer across operating systems so amazed my client that he now demonstrates it to his friends and family (and to anyone who will listen). You can't buy this kind of marketing for Mac OS X (and Parallels).

    Given that this particular keyboard does NOT have the Windows key (which maps nicely to the Mac's command key), I have mapped (via the Mac's Keyboard & Mouse preferences pane) the Alt/Option key to act as the command key, and the control key to act as the option key (my client does not need to use the control key at all, so I am willing to "eliminate" the control key from the picture as the price to be paid to be able to use my client's beloved ThinkPlus keyboard). Of course, I could map the CapsLock key to act as the control key, if this is ever needed.

    I mention this "background" material as a comment to your comment, even though both comments may be irrelevant to the technical question.

    My question still stands, independently of my motivation for wanting to do so: What does one need to do to "motivate" Parallels Desktop to absolutely ignore and pass through the "command-I" key combination?

    Parallels Desktop is welcome to interpret ANY other key combination of my own specification to Capture Input (such as option-command-I in my case, or anything else for somebody else who might use option-command-I for his/her own purpose). All I want is a choice instead of a hard-wired key combination.

    Parallels developers: Please make your "Capture Input" shortcut configurable (or please tell me HOW I can make it configurable by editing some obscure system file somewhere).

    Thanks.
     

Share This Page