Disappearing mouse cursor

Discussion in 'Installation and Configuration' started by Gasport, Jun 19, 2007.

  1. Gasport


    I have seen all types of problems on this subject, but none similiar to mine.

    I am running Vista under Parallels 3.0 and after some difficulties with the upgrade install, I though I had solved all the glitches. I left the iMac alone for a few hours and the message un the lower bar in the Parallls Desktop indicates "Virtual Machine is paused. Click Start to resume execution. At times the mouse cursor was missing and after some fooling around, using the middle button on the mouse brings it back, but as I try to move it to restart the VM, it disappears just before the border. I cannot get it to move into the OS X desktop as it disappears again as I try to drag it out of the Parallels Desktop.

    I tried pressing all different key combinations and finally was able to get the cursor functioning so that I can move it to the Mac OS X desktop. It is obvious that there are many different instances where people have experienced the disappearing mouse cursor. Has anyone had this particular mouse cursor problem and come up with a better solution to fix this problem?

    I hesitate to send this to support as they must be inundated with similar mouse cursor problems and hopefully working on a solution.

    This problem was not present prior to the upgrade and installation of the latest Parallels Tools.
  2. Ankou

    Ankou Guest

    Hello Gasport
    What build of Parallels are you running?
    I guess, you have problems with Parallels Tools. Try to reinstall it in safe mode (hold F8 or F8+fn for macbook during Windows loading)
  3. jkneen


    I have another issue like this whenever I type into a Windows app like Outlook messages my cursor vanishes. I've checked the settings in the Mouse panel etc but it's ok. I have to hit right mouse button to get it back!

  4. Gasport


    Hi Ankou,

    I am running Build 4128 and ran the Parallels tools that came with that version. I will try your suggestion and let you know what happens.

    Thanks for the quick reply

  5. Dondi


    I am running the latest 3.0 build and I am experiencing the EXACT problem. I do hope a new build will be distributed soon as Parallels performance has definitely been degraded by this update.

  6. Dondi



    I am running build 4128 with the exact problem. Just to clarify, are you suggesting:

    A. Reinstalling Parallels Tools by
    1. Starting Windows in Safe Mode. Then,
    2. Installing Parallels Tools


    B. Reinstalling Windows in Safe Mode ???

    I am not trying to be dense, but your instructions are not clear (to me) and I don't want to risk hosing things up even more.


  7. jwalthour


    I have been having the "disappearing mouse" problem since 3.0 GA came out (did not have these problems with any of the betas). I have tried reinstalling the Tools in Safe Mode (went into Safe Mode, uninstalled, reboot back into Safe Mode, reinstall, reboot into Normal Mode), but the problem remains. My VM is a new for 3.0 installation of Windows XP SP2. As I said, this was NOT a problem under any 3.0 beta or RC.
  8. fbronner


    I seem to remember one of the threads, when someone suggested making sure you are using the standard mouse driver in the windows session.

    I'll try to find the thread again and post a link here.


    There try this
    Last edited: Jun 20, 2007
  9. Ankou

    Ankou Guest

    Hello Dondi
    1. Start VM in safe mode
    2. Uninstall Parallels Tools
    3. Restart VM
    4. Install Parallels Tools in normal mode
  10. Dondi


    Thanks Ankou. I'll give it a shot.

Share This Page