Edge browser can't connect to sites

Discussion in 'Windows Guest OS Discussion' started by ChristopherR3, Apr 10, 2016.

  1. ChristopherR3

    ChristopherR3 Bit Poster

    I have just upgraded a Windows 7 VM to Windows 10, and the Edge browser in Windows 10 cannot connect to the Internet. The network connection is working; applications in Windows such as Dropbox or Windows Update have no trouble connecting to download what they need. It seems to be limited to the browser.

    No matter what web site I try, the Edge tab soon shows a (Not Responding) suffix, and then the Edge main window shows the message "Hmm, we can't reach this page." Has anyone else experienced this? Any suggestions?
  2. Sasti@Parallels

    Sasti@Parallels Parallels Support

    Hello ChristopherR3,
    I would suggest you to perform a system file check and see if it helps. To do this, follow the steps below:
    1. Search for 'cmd' on Windows search icon on the taskbar.
    2. Select Command Prompt (Admin) or right click Command Prompt and choose 'Run as Administrator'.
    3. In the Command Prompt window type the following:
    sfc /scannow
    Wait for the scan to complete. Restart the Virtual Machine and check for the issue.
    You could also try installing the Windows updates.
  3. CherylS2

    CherylS2 Bit Poster

    I also upgraded to Parallels 11 and Windows 10 last night and do not have internet connectivity in windows. The issues is exactly as described above. I checked that "shared" is still on after the upgrade. Since I upgraded windows last night, I am unclear why I would run updates? I ran the scan you suggested. My reason for utilizing this product is to have IE or Edge to access some client things that will not support safari. I upgraded because it seemed that parallels 10 was becoming unstable, little issues, lots of reboots. Now I am in a crisis situation with supporting my client who is trying to run a payroll and needs me to perform an activity, require internet and IE. My scan is complete and indicates windows resource protection did not find any integrity violations. As a follow up to, I can ping server successfully so something is there, I just cannot load my web pages so it appears I am not connected.
  4. ChristopherR3

    ChristopherR3 Bit Poster

    Searching Google I eventually found a solution that worked. It involves changing the DNS servers. FWIW, this appears to be a Windows 10 issue, not a Parallels issue. Anyway, here are the steps:
    1. Open the control panel
    2. Search for "view network connections"
    3. Go to view network connections
    4. Choose the network you are currently using
    5. Right click on it and select "Properties"
    6. Scroll down to "Internet protocol version 4 (TCP/IPv4)" and click on it to select it.
    7. Click the "Properties" button.
    8. Now choose "Use the following DNS Server addresses"
    9. Set the Preferred DNS Server to and Alternate DNS Server to
    (These are the addresses of Google's DNS Servers. They are free to use.)
    10. Hit ok
    11. Close all the tabs
    14. Now start Edge or the windows store to see it they connect. If they still aren't working restart your computer and check again.
    ChrisJ13 likes this.
  5. Raj@Parallels

    Raj@Parallels Guest

    Hi Christopher,
    Thanks for sharing the information.
  6. ChrisJ13

    ChrisJ13 Bit Poster

    Thanks for this, worked a treat for me after half the internet vanished from Chrome in my Win10 VM


Share This Page