Ejecting the CD

Discussion in 'Parallels Desktop for Mac' started by danamr, Apr 12, 2006.

  1. AtariAge


    Unfortunately this did not work for me. :(

  2. mmak


    Same problem with beta 3. Tried to eject a cd didn't work. Ejected on mac side, disk disppeared but the cd in the drive. eject button on MacBookPro, no success. opened disk utility, it said the cd is in use and cannot be ejected.

    Here is what worked:
    Right clik in windows and eject
    Connect CD drive in VM to a random disk image
    Opened disk utility on mac side, selected the mac drive, then hit eject. It worked.
    Hope this helps
  3. tomax7


    Eject the CD with the VM menu

    Thanks, got the CD to eject when I 'jump' out of Parallels (Cntl+alt) and click on VM on the menu, then eject CD.

    What is weird is when starting Parallels b3 it says the CDROM is not available and i have a red X over the CD in the lower right Parallels system tray, yet once XP starts it is available, but still shows the X over the CD.

    Keep up the good work guys!
  4. palter


    A minor nit. Please add Eject to the contextual menu on the CD icon at the bottom of the window in addition to having it in the VM menu. Thanks.
  5. AtariAge


    I was able to eject a CD during the Windows XP installation by pausing the VM, suspending, ejecting the disk (by pressing F12), then inserting another disk and reloading the VM. However, it doesn't appear that the Windows XP installer was able to read the CD, as it would simply tell me that it could not read the disc or that it was not a valid disk to upgrade against. I know the discs are fine, I tried one each of the following: Windows 2000 Pro, Windows 98, and Windows NT 4.0 Client, all of which can be used with the XP Upgrade (and these are original discs which mounted fine in OS X, and discs I've used before for this purpose). Makes me sad, as I'd really like to try out Parallels, but I can't get by this stumbling block. Nor can I install Windows 2000, as the VM crashes during the install.

    As an additional step, I tried rebooting the Mac Mini after inserting one of these earlier Windows CDs, but now Parallels won't start at all, displaying some type of device driver error. I'm not having very good luck with this at all. :(

  6. wesley


    Pitching in on 'what worked for me'.

    1. VM > Eject CD (although in most cases it doesn't do anything at all... then go to next step)
    2. Devices > CD/DVD-ROM 1 > Connect Image... > (connect a disk image... I use vmtools.iso)
    3. Make sure the contents of the disk image, not the disc, appears in Explorer
    4. Eject the disc from Finder or Desktop (i.e. eject the disc the OS X way)

    If you skip step 3, the icon will disappear when you do step 4 but the actual disc may not come out of the drive. This happens when the VM is still using the contents of the disc despite replacing it with a disk image, therefore making the disc 'in use' and preventing proper physical ejection.

    Evidently, I think PW's handling of physical disc is still a problem and needs to be fixed before hitting GA. Otherwise Parallels will have a mountain of complaints flooding in. The 'Eject CD' menu isn't quite working as intended because it's not properly 'disconnecting' the disc from the VM. Same with the Eject menu in Explorer in Windows inside the VM.

    I'm fairly confident that this can be fixed, though, given how many strides the betas have made in just a week since the first public beta.
  7. MicroDev


    Doesn't work for me either. Tried everything listed here and it refuses to eject the CD. Was attempting to install Oracle client using multiple disks and no luck.

    1) Eject from Finder did nothing.
    2) Eject from main menu dismounted the CD in Finder but disk would not eject.
    3) Trying to eject within Windows did nothing either before or after.

    MacBook Pro 2.16 - beta 3.
  8. zyprexa


    OK, so I've further evaluated what I am doing and:

    1. Hit eject button on mac os keyboard and eject icon appears but disc does NOT eject.
    2. Right click the cd drive and select "eject". First time does nothing, second time ejects the disc EVERY time.

    this should work folks. I've tried this on CD's and DVD's. I don't know what else to say.

  9. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Thanks for reporting! We are investigating all reported CD/DVD issues and working on it.

Share This Page