Error copying parallels disk image in finder

Discussion in 'Windows Guest OS Discussion' started by DougA, Sep 19, 2007.

  1. DougA

    DougA

    Messages:
    2
    When I attempt to copy a parallels .hdd disk image in the finder, I get the following error message after approximately 1 GB of copying:

    The Finder cannot complete the operation because some data in "WindozeDisk2.hdd.0 {5fbaabe3-6958-40ff-92a7-860e329aab41}.hds" could not be read or written.
    (Error code -36)

    I can boot this partition into Windows XP just fine. When I run chkdsk, it says nothing is wrong. When I work in Windows, there are no obvious problems.

    Any suggestions as to how to fix this problem, so I can easily archive a copy of my image?
     
  2. BenInBlack

    BenInBlack

    Messages:
    372
    maybe you can create a WindozeDisk3 and copy all from Disk2 to it and see if it happens to that one. this will tell you if it is corruptions on where the hdd sit on the Mac drive, or if there is issue in the hdd itself

    have you tried a defrag on Disk2
     
  3. johnv

    johnv Parallels Team Parallels Team

    Messages:
    181
    1. Please close Windows and Parallels before copying
    2. Run Mac OS X Disk utility and repair disk permissions
    3. Try the solution posted above

    Best regards,
    John
     
  4. DougA

    DougA

    Messages:
    2
    Thanks for the advice. I figured out that I had a disk error in my Mac file, and OS X would refuse to deal with reading the bad sector. The directory and permissions seemed to pass muster with the disk utility with no problem, but reading the file would always cause an error. However, the actual disk error didn't seem to be in a place that caused a problem for windows. I fixed the problem by booting the Mac into Firewire disk mode, and copying the .hdd file to another machine. Apparently the disk driver in the EFI firmware is less fussy about read errors than the regular OS. I deleted the troublesome file, and copied it back to the original machine, and now (modulo a potential underlying disk problem) everyone is happy.
     
  5. tkn

    tkn

    Messages:
    4
    still not working here

    I have the same problem (originally noticed when I tried to run a backup with Super Duper, but the simplest test case is that I cannot use the Finder to duplicate the .hdd file). I did close Windows and Parallels then repaired disk permissions. I also tried the solution in a KB article (http://kb.parallels.com/entry/64/527/) for showing the package contents, dragging the .hds out, renaming it to .hdd, and using Parallels to convert it. No luck. I'm not in a position to try the above poster's booting via Firewire, unfortunately.

    Re: #3 ("Try the solution posted above"), with what should I copy the contents of my original .hdd into the new .hdd? Windows Explorer?

    Thanks... frustrated here since July when I first noticed the problem.

     
    Last edited: Sep 25, 2007

Share This Page