Excesive processor usage when idle (build 3188)

Discussion in 'Parallels Desktop for Mac' started by ricardo, Mar 13, 2007.

  1. ricardo

    ricardo

    Messages:
    23
    Hi,

    I'm having this problem across the board - both Windows XP and CentOs 4.4. Even when idle on a command-line only installation, Parallels desktop consumes 44% processor usage on my Macbook Pro's Core 2 Duo. The same happens with Windows XP. This was a problem with the beta (build 3036), where processor usage on an idle CentOs 4.4 was usually around 15%, but it was nowhere near as bad as this.

    Was there a regression? Anybody have any pointers on how to fix this?
     
  2. ricardo

    ricardo

    Messages:
    23
  3. VTMac

    VTMac

    Messages:
    340
    Disable USB
     
  4. abanks

    abanks

    Messages:
    104
    Windows Vista - Full Screen

    With USB: 75% Idle
    Without USB: 22% Idle
     
    Last edited: Mar 13, 2007
  5. VTMac

    VTMac

    Messages:
    340
    The USB implementation has some serious limitations in it's current form.
     
  6. ricardo

    ricardo

    Messages:
    23
    Thanks for the suggestions. I've disabled USB - I'll use it for a while to see the change in behavior.
     
  7. ricardo

    ricardo

    Messages:
    23
    Skype - Parallels killer

    The suggestion about disabling USB helped, and I was able to lower CPU usage to "merely" 16% when idle. Thanks guys.

    I did notice one thing, that the Parallels team might want to look into: if Skype is loaded, that minimum CPU usage I get when idle is 60%. Rather large for a process that's using 1-2% of CPU time.
     

Share This Page