External USB Drive Used to Work

Discussion in 'Windows Guest OS Discussion' started by Davoud, Jun 18, 2007.

  1. Davoud

    Davoud Bit Poster

    Messages:
    5
    Parallels 3.0 Build 4128, XP Pro, all updates
    MB Pro, 2.2GHz Core 2 Duo / 3GB / 1500MB for Parallels.

    The drive is in Windows format and it is designated as a Parallels shared device. It used to work, but now when I plug it in I get the message "USB device you are trying to connect [sic] to the virtual machine is being used by another application. Close that application or unplug the device and plug it again [sic]. Then try to connect the device again.

    There is no other application, and disconnecting and re-connecting does nothing except cause the above message to appear repeatedly. The drive works when I boot into Windows.

    Thanks,

    David
     
  2. mrfish

    mrfish

    Messages:
    1
    Same here

    I am having the very same problem. No matter what external HDD i connect i get the message about being used by another application. If I can't connect an external HDD then i'm well and truly stuffed.
     
  3. dave_hill

    dave_hill

    Messages:
    4
    And me

    Same issue here too!
     
  4. jdw66

    jdw66

    Messages:
    1
    USB Stopped working after swapping machines

    My USB stick also seemed to stop working with the same error
    after I migrated from my Macbook to a Macbook Pro. I am unable
    to get it work again and reluctant to uninstall and reinstall Parallels
    until I get further info, but may have to do that. I am wondering
    why there is no post from Parallels about what to do.
     
  5. jobie

    jobie

    Messages:
    4
    It's been HOURS!!!

    I've been trying to solve the same problem for HOURS!! Has anyone had any luck????
     
  6. davetroup

    davetroup

    Messages:
    4
    Not just USB drives

    I am having the exact same problem when I plug in a different USB device (a GPS navigator.) I get the same message saying that it's in use by another application -- even though it's not.

    Clearly there are USB problems with the new 3.0 version. I hope they fix them soon.
     
  7. slag

    slag

    Messages:
    2
    This is ridiculous (EDITED)

    Sorry About The Angry Post.

    You Guys Had A Fix For Me Upgrading To 10.4.10 And I Didn't Find It Until After I Lost My Mind.

    My Bad.
     
    Last edited: Jun 29, 2007
  8. danison

    danison

    Messages:
    2
    think i know

    Have been dealing with t his too.. wanted to throw puter into street and smash it.. It appears to be caused by the update to mac 0sx.4.10 with the older build of PD. Supposedly, upgrading to build 3214 fixes it. I'm trying that now.

    I HOPE SO!!
     
  9. PT Fone Home

    PT Fone Home

    Messages:
    1
    Same Problem

    I'm having the same problem with USB, it says it's in use.. has anyone come up with a work around for this yet?
     
  10. w7ox

    w7ox

    Messages:
    152
    Davoud and all,

    I just connected my 120 GB FAT32 usb drive to this MacBook (early model, OS X 10.4.10, 2 GHz processor, 2 GB RAM, 120 GB HDD) running WinXP Pro under Parallels 3. After going though the expected "Found new hardware" song and dance, I was able to access the disk.

    So I'm not having this problem. In fact I'm having none of the problems reported here -- except for lack of an Image Tool to resize the hdd (and mine was set to 30 GB in PD 2, big enough).

    In this and other areas PD 3 is a real puzzle. Features that work for some users will not work for others; and no one is finding a systematic reason why in each case.

    Seems like something Parallels should have caught before release. Maybe the beta test program did not include enough testers and a large enough variety of configurations.

    Phil
     
    Last edited: Jun 30, 2007
  11. renochoi

    renochoi

    Messages:
    1
    MBP 2.0 CoreDuo / OSX 10.4.10 / Parallels Build 3212

    I have the same problem as above. In fact, all my USB stuffs don't work, i.e. MemoryStick, Ext HDD, Scanner, and you name it!

    Perhaps it's due to OS update, but surely there was no such hassle at all before. As I was thinking of buying Parallels v3.0 to fix it, it doesn't seem to be worth it.

    Does anyone shine me a light on this?
     
  12. USB not working at all with updates from Apple and Parallels

    I posted a thread on this in the General Questions before I saw this one. Apples' support groups aren't working today - figures. I even have a support ticket in and no call back from Parallels - real dissapointment.
     
  13. dkp

    dkp

    Messages:
    1,367
    Apple didn't release 10.4.10 until after PD 3 came out. Beta testers would not have had access to 104.10 to test.

    This has been discussed frequently in the last several days. If you are running Parallels 3.0 there is no fix for 10.4.10 nor is one needed according to Parallels. If you are running Parallels 2.5 with Apple's 10.4.10 update then you need to update Parallels to build 3214 using the Update option in the Parallels Help menu. Earlier versions of Parallels that 3214 do not work with OS X version 10.4.10 particularly in regards to USB. Apple did enough of a re-write of the USB code that it broke not only Parallels but also VMWare Fusion.
     
  14. tom27

    tom27

    Messages:
    28
    While I understand that you write in faviour of Parallels, there are a few things you are missing:

    1. Some USB devices have stopped working during Parallels 2.5. I have spent months trying to get my urgently required dongle to work again (it once worked! - that´s why I have purchased Parallels). No answer from support, no ideas, plain... nada! And that way way before 10.4.10...

    2. All software developers receive pre-releases of Apple operating systems if they are ADC members. Parallels is featured on my Apple sites and I don´t believe that communication was so bad that Parallels didn´t know anything.

    3. There are many-many posts of people who cannot use their USB devices. I haven´t seen one of them properly adressed by the support team. Parallels - as a company - grows for sure, but it seems customers have to pay the price for it. That´s pretty sad...

    Tom
     
  15. pooru

    pooru

    Messages:
    9
    Me too. They really need to get their finger out.


    P. (*_*)
     
  16. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
  17. tom27

    tom27

    Messages:
    28
    Hi Eru, thanks for pointing me to this thread. I´ll try that asap and post my results

    Greetings
    Tom
     
  18. ksrhee24

    ksrhee24

    Messages:
    2
    I had a same issue. Here is what I did to make this happen.

    Start Parallels. Eject the hard disk or flash drive from Mac so that Mac doesn't see it.

    Go to Parallels menu (devices/USB) and turn on the external drive or flash drive. Hopefully you will see your external disk within your VM.
     
  19. nanwat

    nanwat

    Messages:
    37
    Printer,thumb drive not working again/mouse not visible in VM

    I too am incredibly frusrtated as I had spent HOURS sorting through workarounds to get both working . THen for no apparent reason I could not get the printer or thumb drive to work and the mouse periodically gets "left behind" on the Mac OS. I then have to force quit my vm which I don't like doing & start all over again & hope like hell the mouse will appear on my VM's desktop.For some reason I ultimately ended up with the same printer showing twice http://www.flickr.com/photos/httpwwwflickrcomphotoswattos/. I deleted the one that wasn't working (have no idea what was going on or how that happened) but still no printer until I updated .
    I have just download a 51.5 mb upgrade Build 3214. It said it was for Parallels Version 2.5 but stated it would fix USB compatibility issues in OS 10.4.10 ?
    As I have Parallels V 3.0 installed I am still very confused and was worried I was installing an older version of Parallels,especially when I also got a message saying I could upgrade to Parallels V3.0. Only that I was absolutley DESPERATE to sort out all these USB problems that I continued with the installation. It seems to have worked but can anyone explain how V 2.5 comes AFTER V 3.0 ? Perplexed.....
     
  20. nanwat

    nanwat

    Messages:
    37
    Have just realized (seeing my signature) that my Mac OS has automatically upgraded to 10.4.10 so that explains perhaps why I suddenly had no mouse or printer but I"d stil like to know why I was downloading Parallels V 2.5 ?
     

Share This Page