F11 and F12 keys not working in Leopard

Discussion in 'Windows Guest OS Discussion' started by glenn.gilbert, Jan 27, 2008.

?

Are you having problems with F11 and F12 with Leopard?

  1. Yes

    2 vote(s)
    100.0%
  2. No

    0 vote(s)
    0.0%
  1. far

    far

    Messages:
    10
    I do NOT want to use ANY modifiers (such as fn) with f11 and f12. I want to be able to use f11 and f12 by themselves, from within the VM under Parallels, to accomplish the same tasks that I normally accomplish by using f11 and f12 while running Windows on a PC.

    Thank you
     
  2. leok7v

    leok7v

    Messages:
    3
    Re: you can use Fn+F11 shortcut for F11 (and others) key in VM

    Maxim,

    >you can use Fn+F11 shortcut for F11 (and others) key in VM

    I can also stand on my head and wiggle my toes. So what?

    Actually I cannot use Fn+F11 because I switched Fn to be used
    for Mac specific shortcuts and F<number> for programs. I treasure
    my keyboard shortcuts and do NOT want to waste them on Macintosh
    specific actions that I probably invoke as often as once a month.

    The fix for the issue will take LESS ENERGY than arguing and advising your customers.

    You are already losing people to VMWARE and you will lose more if you won't start listening and fixing thing. The feature request is simple:

    Make transparent translation of ALL keys an option in Parallels Preferences. That is all.

    Good luck pressing Fn+Alt+Ctrl+Shift+F12 on you Mac...

    Leo
     
  3. leok7v

    leok7v

    Messages:
    3
    On an afterthought

    Parallels,

    How about every time I want to press Alt+F12 (several dozens times a day) to find symbol definitions in MS Dev Studio or JetBrains IntelliJ Idea or Shift+F11 to exit a method in a debugger (several dozen times a day too) you ship me a customer support rep to hold `Fn` button for me... This will make my day. Don't forget all other software developers you sold Parallels too. Ship them a customer rep Fn hand holding person.

    Leo
     
  4. xm242mx

    xm242mx

    Messages:
    2
    Hi there,

    the only way to fix this function key problem is to switch to anohter VM-machine.
    I tried VM-ware Fusion and it the keys all work properly.
     
  5. Martin Mazur

    Martin Mazur

    Messages:
    4
    Any news?

    Has there been any updates on this BUG (yes i consider this a bug). I use my F-keys in Visual Studio all day and this is starting to bug me, really, really, really hard.

    Has anyone got this working?
     
  6. STim

    STim Super Moderator

    Messages:
    942
    If you are on Parallels Desktop 4, go to Parallels Desktop menu->Preferences->Keyboard&Mouse and uncheck the "Enable Mac OS X system shortcuts" checkbox.

    This will let Mac OS system shortcuts like F9-F12 go directly into VM without being intercepted by Mac OS itself.
     
    Last edited: Jan 15, 2009
  7. gjritter

    gjritter

    Messages:
    1
    Unfortunately, turning this option on prevents the use of Command-Tab to switch between windows applications and mac applications. I can now alt-tab through applications within windows, and command-tab between mac applications, but I can't command-tab to switch from a windows app to a mac app. (I'm running in full-screen mode.)
     
  8. NeveM

    NeveM

    Messages:
    1
    I did this but it makes no difference. I need my F12, I use it constantly in Dreamweaver and Flash. All I get is the volume turned up. How do I get it just to work, by pressing only F12? I found pressing fn control 12 works but it's really clumsy.

     
  9. andwi

    andwi

    Messages:
    10
    I have checked "Use all F1, F2..." in system preferences and when running parallels in full screen mode everything works the way I want (all F-keys recognized by Windows and command-tab working to switch to mac applications) with one exception: shift F11 will show the Mac desktop in slow motion. I have disabled all relevant system shortcuts that are available in system prefs. In my recollection this has been the behavior for several builds.
     

Share This Page