fedora 29 is not compatible with Parallels Desktop for Mac ( latest )

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by omegak, Nov 5, 2018.

  1. omegak

    omegak Bit Poster

    Messages:
    7
    Hello,
    Fedora 29 is out. But it's not compatible yet with Parallels Desktop for Mac.
    Would be good to support it.

    Thanks,

    Omega BK
     
    jhfenton, P26, HeikkiL and 5 others like this.
  2. AndreL1

    AndreL1 Bit Poster

    Messages:
    11
    +1 on this. Parallels should support it asap.
     
  3. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
    Works for me. I provided my own ISO, of course.
     
  4. omegak

    omegak Bit Poster

    Messages:
    7
    It's NOT compatible.
     
  5. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
    @omegak : You seem so sure of yourself. Check out this screenshot:
    [​IMG]
    @AndreL1 : FYI
     
    Last edited: Nov 30, 2018
  6. omegak

    omegak Bit Poster

    Messages:
    7
    what about parallels Tools ?
     
  7. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
    @omegak : No problem installing Parallels Tools:
    [​IMG]
     
    BenS11 likes this.
  8. omegak

    omegak Bit Poster

    Messages:
    7
    Oh, sounds great. so you just grab the full iso on fedora page and install it ?
     
  9. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
    I installed Fedora Server first with that iso, then installed workstation with: sudo dnf -y group install "Fedora Workstation"
     
  10. omegak

    omegak Bit Poster

    Messages:
    7
    I see. thanks for the tips. I'll do it
     
  11. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
  12. omegak

    omegak Bit Poster

    Messages:
    7
    you made my day!! thanks a lot!!!
     
    DavidW36 likes this.
  13. P26

    P26 Bit Poster

    Messages:
    4
    This did not work for me, as a result the Fedora 29 VM hangs when GDM should start up. Looks identical to the black screen coming up when you try to install the VM from the Fed 29 Workstation iso. Is this a known issue to the Parallels team?

    PS Mac OS 10.13.6, Parallels 14
     
  14. DavidW36

    DavidW36 Bit Poster

    Messages:
    9
    I think I figured out what the problem y'all might be having is, because I just bricked my Fedora 29 install. Basically, Parallels can't handle a graphical login with Fedora 29. However, if you do a command line login, then "startx", it's fine.

    So, the default for me initially with the server install (and then later installing the workstation) was a command line login, equivalent to:
    systemctl set-default multi-user.target

    However, once I did this, for a graphical login:
    systemctl set-default graphical.target
    , the boot screen hung black, effectively locking me out of the VM.

    I think that's what Parallels has to fix.
     
  15. P26

    P26 Bit Poster

    Messages:
    4
    any news or plan to upgrade the Fedora VM that can directly be downloaded from Parallels?

    Many thanks.
     
  16. BenS11

    BenS11 Bit Poster

    Messages:
    1
    Good job, I followed your method by setup the Fedora 29 server first.
    However, after Parallels Tools setup successfully, I can't enter coherence mode. Do you know how to fix this?
     
  17. IanH7

    IanH7 Bit Poster

    Messages:
    2
    Just tried the server iso install and it failed during the network setup phase - python error.

    I can't even try to debug, because the user id and password I created in Parallels at the start isn't being recognized by the server at the non-GUI login.

    I give up on getting Parallels and Fedora working. :mad::mad::mad:
     
  18. c0ns0le

    c0ns0le Bit Poster

    Messages:
    1
    ensure you have ssh or remote login enabled, else login via single and install the following packages.
    if NOT ROOT use sudo, else remove sudo in cmd below.
    #sudo yum install compiz-devel system-switch-displaymanager lightdm kdm
    #sudo system-switch-displaymanager lightdm
    mount the parallels tools iso
    #sudo mount /dev/cdrom /mnt
    #sudo ./mnt/install --instal --verbose

    Or if your tools cd image was mounted to /run/media/parallels/Paralells\ Tools/ then do below:
    #sudo /run/media/parallels/Parallels\ Tools/install-gui
    complete the install, and reboot
     
  19. AlexM18

    AlexM18 Bit Poster

    Messages:
    3
    Guys, it seems to depend on the kernel version. I have run Fedora29 with 4.14.XXX no problem, it won't boot with 4.20 and definitely not with kernel 5.0.x
    Anybody has has any luck booting these kernels ? (latest Parallels 14.1.3 (45385)
     
  20. AlexM18

    AlexM18 Bit Poster

    Messages:
    3
    Take it back. Minimal install boots 5.0.4 kernel, it is the graphics node is screwed up.. stand by ..
     

Share This Page