Fedora Core 6 video issues

Discussion in 'Parallels Desktop for Mac' started by iduff, Mar 1, 2007.

  1. iduff

    iduff Product Expert

    Messages:
    235
    Hi, I've installed Fedora Core 6 on build 3186 on my MacBook Pro, everything is cool except for video. I get a huge screen, something like 1600 by 1200. When I try to resize it, the video gets very weird, like the horizontal sync is hosed.

    I searched this forum for hints, tips, etc., and found some very explicit posts that seem to be quite useful to others, but so far have done me no good, such as the "run linux at any resolution" one. Another indicates installing with video explicitly selected, rather than allowing anaconda to pick what it wants. This led me to reinstalling, at which time I noticed a potential problem. Anaconda loaded, and then reported "Probing for video card: Unknown device aaaa:1131"

    I suspect if anaconda can't identify the video card, FC6 may have trouble with video drivers, no? How can I correct this for anaconda, or somehow get FC6 to recognize the video card? If I'm able to fix this video card error, might the other posts now be of some help to me?
     
  2. sidssp

    sidssp

    Messages:
    182
    Here is what you need to do.

    1. Boot FC-6 into single user mode. Right after you start the VM and before FC-6 start booting, there should be a couple of seconds delay. You need to hit a key, any key, to get into the GRUB menu. At the GRUB menu, select the kernel you want to boot then hit the 'a' key. It should show you a boot option line similar to this:
    Grub append> ro root=LABEL=/ rhgb quiet
    Now add the word single at the end
    Grub append> ro root=LABEL=/ rhgb quiet single
    Now hit the enter key to boot.

    2. Once in the single user mode you don't have the GUI interface and you are root so be careful.

    3. Edit (I use vi) the file /etc/X11/xorg.conf

    4. Locate the Screen section and add a Modes line at the end of the Display subsection. It should look like this:

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    5. Save the file, restart FC-6, and you should be ok.
     
  3. bobofthedeep

    bobofthedeep

    Messages:
    5
    Nice one

    This works beautifully.
     
  4. Nick13

    Nick13

    Messages:
    1
    Changing resolution for Fedora 6 on MacBook Pro

    Hi,

    I have been stuffing around with this resolution problem all morning. Finally solved it, and it turns out to be really simple.

    Step 1:

    In Fedora select from the menu system-administration-display

    Step 2:

    Click on the hardware tab and under Monitor Type click Configure
    THEN
    Click on the Show all available monitors checkbox
    THEN
    Click on Apple Aluminium PowerBook G4 and click OK

    Step 3:

    Check that the video card is set to default, it should be vesa - Generic VESA-compliant video cards

    Step 4:

    Click on the settings tab and under resolution select 1440x900 from the drop down box

    Step 5:

    Press OK and Reboot

    This should work

    Nick
     
    Last edited: May 9, 2007
  5. Tyland1200

    Tyland1200 Parallels Team

    Messages:
    33
    Hi all,

    In regards to Fd 6, there is a known issue with the resolution. There is currently no resolve on this as it came out right around the time 3186 and 3188 were released.

    We are aware of this and working on it but please consider using FD 5 or other linux options.

    Tyland1200
    Parallels Staff Memeber
     
  6. sidssp

    sidssp

    Messages:
    182
    I don't understand. Once I put in the mode line in xorg.conf FC6 has been working great. Why do you suggest using FC5 instead? Did I miss something?
     

Share This Page