Firefox 57 on Windows 10 64bit virtual machine

Discussion in 'Windows Guest OS Discussion' started by jorgemtds, Nov 15, 2017.

  1. AndyB9

    AndyB9 Bit Poster

    Messages:
    15
    Hey, I can relate to your frustration. After getting some very poor tech support (whereby new dudes would ask me to do what previous dudes had asked me to do already) I got really annoyed and emailed Parallels management to complain. They put level 2 guys on my case straight away and I am still dealing with them. Maybe email and complain about the level 1 support. Something really needs to improve in that department. I worked in Helpdesk management for years, and If any of my staff were performing that poorly, they would have been fired.
     
  2. Dr.U

    Dr.U Bit Poster

    Messages:
    7
    @alxg: Yes, we removed the profile (%appdata%\Mozilla\Firefox\Profiles) before installing FF57.
     
  3. alexg

    alexg Parallels Developers

    Messages:
    536
    Dr.U, could you please try to run FF57 and after that send me the technical report using Help menu of Parallels Desktop? Write the number here. Thank you. I'd like to see the difference between you and mine setup.
     
  4. Dr.U

    Dr.U Bit Poster

    Messages:
    7
    @alexg, we have sent the report (ID 226982035)
     
  5. RuedigerG1

    RuedigerG1 Bit Poster

    Messages:
    1
    I have the same problems since I have installed FF57 ...
     
  6. MarioB4

    MarioB4 Bit Poster

    Messages:
    4
    Hi,
    Same problem here.
    Report ID: 226751615

    Regards,
    Mario
     
  7. ThomasB16

    ThomasB16

    Messages:
    1
    Best Answer
    I was also experiencing the same FF57 startup flashing window problem on a Parallels Windows 10 Pro 64bit VM on a Mac Mini late 2012 with MacOS Sierra latest version but not on my Windows 7 or 8.1 VMs.
    I then created a new VM with a fresh Windows 10 install and a FF57 install and FF57 worked correctly. I then started to do my usual Windows 10 custom settings all at once and then FF57 started having the same startup flashing problem. Luckily I had taken a snapshot of the fresh install before customization that worked so I went back to that and then made each of my customization changes one at a time testing FF57 after each change.
    For me, I was able to identify that under Settings|Personalization|Colors if I had both a "Windows Colors" selected and show accent color in "Title Bar" selected it would produce the flashing windows on FF57 startup. If I either let "Windows automatically select an accent color" or unchecked the show accent color in "Title Bar" then it would correct the problem and FF57 ran correctly. If I then went back and reselected those two options FF57 would exhibit the startup flashing window problem.
    With further testing if I let "Windows automatically select an accent color" and left the show accent color in "Title Bar" selected and FF57 started correctly then I could close FF57 and then choose my own "Windows Color" again and FF57 would startup correctly until then next reboot and then FF57 would go back to the flashing window at startup again. I could once again correct the problem by making either one of the changes that I indicated above. I was able to reproduce this behavior multiple times.
    I then went back to my original Windows 10 VM that I first found the FF57 startup flashing windows problem and unchecked the show accent color in "Title Bars" and FF57 started up correctly.
    I hope this helps others and allows Parallels to reproduce the problem so they can find a solution.
     
  8. Dr.U

    Dr.U Bit Poster

    Messages:
    7
    I can confirm the effect of the settings ThomasB16 mentioned. It works exactly the same way on our W10 pro 32bit VM. Thanks a lot for helping! Really fine research.
     
  9. Dr.U

    Dr.U Bit Poster

    Messages:
    7
    I found a way to easy fix the problem (thanks again to ThomasB16).
    1 Settings|Personalization|Colors ->unchecked the show accent color in "Title Bar"
    2 Restart FF, it should work now.
    3 In FF, Click the menu button [​IMG] and choose [​IMG] Customize....
    4 In Themes change the Theme from "default" to any other and restart FF
    5 Settings|Personalization|Colors ->checked the show accent color in "Title Bar"
    That's it!
     
    TomS15 likes this.
  10. luke1970

    luke1970 Bit Poster

    Messages:
    5
    Hm, and how I can use "Settings->Personalization->Colors" in Firefox if I have the problem long ago?
     
  11. TerryV4

    TerryV4 Bit Poster

    Messages:
    2
    I can confirm that changing the Theme to anything except "default" works. Change it before you do the upgrade to 57.x and everything works. If you change it back to "default" after installing 57 you'll have the flashing problem again with no easy way to fix it except to roll back to a prior snapshot.
     
  12. Dr.U

    Dr.U Bit Poster

    Messages:
    7
  13. AlexN2

    AlexN2 Bit Poster

    Messages:
    4
    And, after @alexg's defensive rant against my earlier post describing the lack of technical expertise, support and QA for PD ("Hey, it works on _my_ machine; therefore we QA'ed it!), it turns out that, once again, it's Parallel's long-suffering users who have come up with a work around.
     
  14. JoseL1

    JoseL1 Bit Poster

    Messages:
    2
    You are the man, ThomasB16 ! Great research and very clear post. THANK YOU SO MUCH !!!
     
    Dmitry@Parallels likes this.
  15. BenoîtG

    BenoîtG Bit Poster

    Messages:
    2
    Thanks to ThomasB16, I checked the Personalize and Colors panels, and fixed it by that setting an automated highlight color based on the background. I could then select a custom color again without the glitch reoccuring anymore.
     
  16. JoseM22

    JoseM22 Bit Poster

    Messages:
    1
    Hello...I was having this same issue with my MacBook Pro (mid-2015) running Parallels Desktop 13 Pro, Windows 10 (version 1709), and Firefox Quantum (X64; version 59.0.2) for several days now. However, last night I changed the Graphics setting under the "Windows 10 Configuration" to Advance Settings/3D acceleration: DirectX 9. I also put a check mark on "Automatic graphics switching". Changing the setting to "DirectX 9" appeared to fix the issue with flickering in Firefox Quantum and the black search field and the address bar for me. Not sure if checking "Automatic graphics switching" was necessary. Hope this helps others.
    Screen Shot 2018-04-10 at 4.21.15 PM.png
     
    Dmitry@Parallels and Jean-MarcK1 like this.
  17. Jean-MarcK1

    Jean-MarcK1 Bit Poster

    Messages:
    1
    That works for me. If i switch back to DirectX 10 then the issue is back. Switch to DirectX 9 and all works as it should.
     
    JoseM22 likes this.
  18. MatteoG2

    MatteoG2 Bit Poster

    Messages:
    1
    I'm also running firefox quantum 59.0.2 but in my case the firefox window comes up with no borders and it looks weird. None of the options for the 3D acceleration (None, DirectX 9 and DirectX 10) fixes it.

    Screen Shot 2018-05-21 at 00.31.20.png
     
    Last edited: May 20, 2018
  19. OldNerdGuy

    OldNerdGuy Bit Poster

    Messages:
    4
    I had something, perhaps, similar. Black space in a window with whatever version of Firefox Quantum I tried. The solution was to turn off Hardware Acceleration in Firefox. Does that suggest a video driver issue? Windows 10 with Firefox 61.0.1 64 bit. I also had black tabs, but going to the Light Theme fixed most problems except the black space in some apps. Turn off Hardware Acceleration (Options/General/Performance, turn off "Use recommended performance settings" then uncheck "Use hardware acceleration when available").
     

Share This Page