FIX: Parallels Freezing or Beachball appearing with Windows

Discussion in 'Parallels Desktop for Mac' started by jkneen, Feb 28, 2007.

  1. jkneen

    jkneen

    Messages:
    49
    I've seen a lot of posts all over the place with this problem which I've had on and off myself.

    Windows appears to freeze periodically when using applications, this can manifest itself as either a pause in the function of Windows OR the spinning beachball/disc/ball will appear.

    SYMPTOMS

    You close a window in XP, either ALL windows or specific ones (I was getting it with Outlook 2007 yesterday - the only app affected) and as you close the window half closes (leaving some garbage/fragments on the screen) and after a second or so the spinning Mac OSX beachball appears. After anywhere between 5 and 15 seconds the remains of the window close normally.

    AFFECTS

    Either all windows are affected or specific applications. Minimising and Maximising Windows is fine, opening is fine - this just seems to affect closing Windows either ALL or specific applications.

    CAUSE

    Looking at various threads, this is something to do with Parallels tools and/or virtual memory allocation within Mac OSX although - there could be other related issues but Parallel tools is definitely at the centre of this somewhere. If you kill the Parallels tools process the problem is solved. You lose clipboard sync (no biggie) and Time sync (annoying but workable by updating your clock when you resume Windows.)

    RESOLUTION

    I found various fixes for this that worked for me including adjusting the swap space settings of Windows, rebooting Windows, rebooting MacOSX etc however the consistent fix I've found is turning ON "show applications in dock" in the Parallels preferences.

    I realise this information is now new to many people with this issue and I certainly didn't solve this myself - I just thought I'd put this up as I've seen multiple threads on different subjects where people describe this issue. Hopefully this will help!

    Jason
     
  2. eighteentee

    eighteentee

    Messages:
    10
    For me disabling the coherence mode in the Parallels tools fixed it for me. However, moving windows around the screen is sooooo sluggish. Feels like I'm running VirtualPC on a PPC!
     
  3. jkneen

    jkneen

    Messages:
    49
    That's weird, running in a Window for me is fine in terms of moving windows. It does go a little funning when moving - it's not smooth but it certainly doesn't make me think I'm using a VM

    Jason
     

Share This Page