[FIXED] "Quick Assist" on Windows 11/ARM64 release 22000.318 PD 7.1

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by Grey Shadow, Nov 18, 2021.

Tags:
  1. JordanC4

    JordanC4 Bit poster

    Messages:
    2
    Logged a ticket for this - I am not hopeful it will be resolved soon, but it's definitely a problem.
     
  2. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    Parallels Desktop 18.2 released - Still doesn't work
     
  3. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    And still no-go with Parallels 18.3
     
  4. JordanC6

    JordanC6 Bit poster

    Messages:
    1
    I put in a Parallels support incident for this back in Feb. and after a few emails back and forth they said this is a windows problem. I even referenced it working on VMware fusion and not Parallels and they would not help any further.

    Anyone tried using wire shark to capture network packets and see exactly where it's hanging?
     
  5. JordanC4

    JordanC4 Bit poster

    Messages:
    2
    I put in a Parallels support incident for this back in Feb. and after a few emails back and forth they said this is a windows problem. I even referenced it working on VMware fusion and not Parallels and they would not help any further.

    Anyone tried using wire shark to capture network packets and see exactly where it's hanging?
     
  6. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    It works on „bare metal" too (Windows/ARM on Snapdragon).
    So it's definitely a Parallels problem.
    My support case (I opened one too. A couple of months ago) is „escalated" but obviously „dead". No responses from Parallels since January.

    Time to move on. Away from Parallels.
     
  7. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    696
    Hey @Grey Shadow, my apologies for this investigation taking so long and for not following up with you on the support ticket. Please understand that while we strive to provide Mac users with a great PC experience (as close to a real PC as possible), we do not own everything that happens within the Windows machine. When testing in our lab, we couldn't make Quick Assist work between two Arm-based PC computers either, I see that many Windows PC users report the same issue as well: https://answers.microsoft.com/en-us...p-broken/6f510a12-2d7e-4c67-8fa3-c1690baac5d9

    Our Engineering team has reported this issue to Microsoft Feedback Hub. At this point, there is nothing else we can do about this situation, it appears to be unrelated to Parallels, plus all other Windows apps and the OS itself use the network just fine in the VM. I hope it makes sense to you and please let me know if you have any questions.
     
  8. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    @Dmitry@Parallels No. Sorry. Doesn't make sense to me, as it works on Windows/ARM(Snapdragon) and VMware Fusion/ARM.
    Microsoft indeed had some problem during the upgrade phase with older/newer QuickAssist versions (Windows version / Windows-Store version). Even on Windows/x64 <-> Windows /x64. These have settled.

    Currently I have to RDP into a "real" Windows/x64 machine and do Quick Assist from there.
     
  9. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    696
    @Grey Shadow, thanks so much for this feedback. When you say "it works", do you mean connecting "to" or "from", or likewise? I am trying to understand if network/location is the culprit. We will certainly do another try on this investigation, I understand how critical it is not to be able to connect to a remote machine. If you can add 5 cents about your use case and what you do with Parallels Desktop, I would be super grateful.
     
  10. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    Both directions. On VMware and/or bare metal(Snapdragon Windows/ARM)
    From and to Windows/x64. Every combination as long as no Parallels Windows/ARM is involved.
     
  11. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    696
    Best Answer
    Hey guys, @Grey Shadow, @JordanC4, @RickM16, @TomM31, @Ensoniq, @AndresM5, @SteveK14, the connectivity issue has been fixed in the recent Quick Assist app update v2.0.21.0 (check for updates in the MS Store library), works for me now and hopefully will work fine for you too.
    pic1.jpg
     
  12. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    Confirmed! Thanks for the info!

    Hurray!!!! Thanks a lot whoever made this finally happen!)

    NB: "Quick Assist" V2.0.21.0 is available since January 2022. I *think* it's the latest Parallels 18.3.1 that made it happen(?!)
     
    AdrianH10 and Dmitry@Parallels like this.
  13. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    696
    Great! Happy to hear it works for you now:)
    January 26, 2022 is the app release date. Please check this page for the app update history: https://support.microsoft.com/en-us...-history-ec4c2c86-134a-4f3e-9fe2-c0030a751bd9
     
    Grey Shadow likes this.
  14. Grey Shadow

    Grey Shadow Member

    Messages:
    29
    Ahhh. THX for the additional info!
    That makes sense! :)
     
    JordanC4 and Dmitry@Parallels like this.
  15. AdrianH10

    AdrianH10 Bit poster

    Messages:
    4

Share This Page