Forced File associations

Discussion in 'Windows Guest OS Discussion' started by pwith, Jun 17, 2007.

  1. pwith

    pwith

    Messages:
    52
    I have complained about this before but have not seen the isseu addressed by Parallels.

    After installing/upgrading (to) Parallels 3 I am encountering situations when I dbl click on files in OSX allof a sudden Parallels opens because the files have been associated with Windows applications - Word and Excel come to mind most frequently.

    Please - this in itself is a reason to ask for a refund - I don't want my files hijacked by Windows. If I want to run Windows I will do so but I am not interested in this cross-platform BS. If Parallels must include this feature don't turn it on by default.

    Please provide me with a solution as to how to REMOVE all the parallels/windows file associations in OSX. I don't want it.

    Thanks

    Peter
     
  2. brkirch

    brkirch Kilo Poster

    Messages:
    415
    To reset file associations in any Parallels VM, select "Reset Windows Applications" from the Applications menu while the VM is running. AFAIK the file associations only happen when the file doesn't have any OS X program to run with. Also you can avoid the associations being assigned in the first place if you chose not to show Windows applications in the Dock. The next Parallels update is supposed to provide an option to disable SmartSelect entirely so hopefully that will resolve this issue.
     
  3. Lew

    Lew

    Messages:
    24
    That's not the case. I have MS Office installed in both OSX and Windows and the first time I clicked on and Excel file, Parallels and Excel for Windows booted up.

    It's simple to change file associations, but it was kind of a surprise when it happened.

    Lew
     
  4. brkirch

    brkirch Kilo Poster

    Messages:
    415
    Then I stand corrected. I haven't noticed this kind of behavior myself, but then again I haven't been using that many programs that would create extension conflicts for OS X programs.

    There is also the option of specifying if documents should open in a particular Windows program by selecting SmartSelect from the Dock menu of the dock icon that program. Not very useful if you are looking to completely disable SmartSelect but good to know if you ever decide to use SmartSelect and want to customize file associations.
     
  5. sharkez

    sharkez

    Messages:
    27
    This is not working for me. I've tried setting a higher "security level" (med-high) and changing the smartselect pop-up on the dock icon--done this for all the MS programs--but it has not changed the behavior when double-clicking a doc in the mac OS. My smartselect shows that it is to "open in Mac finder" but it still opens using Internet Explorer in windows, then launches word. Even the icons have become generic.

    THis is a real pain. Anyone know how to reset this from the Mac side?
     
  6. mglish

    mglish

    Messages:
    18
    I had the same issue -- Word/Mac was installed as well as Word/Windows. SmartSelect not so smartly was opening .DOC files with the Windows version. I followed the directions to change the file association via the SmartSelect menu but Word/Mac didn't show up on the list.

    So I googled "change file associations macintosh" and got the answer:

    * Do a "Get Info" on a .DOC file on the Mac
    * Open the "Open with:" section
    * The current association will be with Word/Windows. Change it to Word/Mac
    * Click the "Change all..." button below that

    Done...

    If you change your mind, looks like you can go back to Word/Windows the same way

    Mike
     

Share This Page