FYI: macOS 10.13 Beta 4 (17A315) will not let PD12 run

Discussion in 'Installation and Configuration' started by MikhailT1, Jul 24, 2017.

  1. MikhailT1

    MikhailT1 Bit Poster

    Messages:
    21
    I don't know if this is a bug in macOS or they changed how kexts are permitted starting with macOS 10.13 B4.

    Here's the console log:


    service[8670]: Kext rejected due to insecure location: <OSKext 0x7fc14a518e50 [0x7fffb0590260]> { URL = "prl_hypervisor.kext/ -- file:///Applications/Parallels%20Desktop.app/Contents/Library/Extensions/10.9/", ID = "com.parallels.kext.hypervisor" }

    Rejecting invalid/inauthentic kext for bundle id com.parallels.kext.hypervisor at location prl_hypervisor.kext/ -- file:///Applications/Parallels%20Desktop.app/Contents/Library/Extensions/10.9/.

    /Applications/Parallels Desktop.app/Contents/Library/Extensions/10.9/prl_netbridge.kext - no compatible dependency found for com.parallels.kext.hypervisor.

    Rejecting invalid/inauthentic kext for bundle id com.parallels.kext.hypervisor at location prl_hypervisor.kext/ -- file:///Applications/Parallels%20Desktop.app/Contents/Library/Extensions/10.9/.

    /Library/StagedExtensions/Applications/Parallels Desktop.app/Contents/Library/Extensions/10.9/prl_netbridge.kext - no compatible dependency found for com.parallels.kext.hypervisor.

    Rejecting invalid/inauthentic kext for <...>​
     
  2. RickyI

    RickyI Bit Poster

    Messages:
    2
    I can second this (bug?). Not working here as well. I tried to uninstall and reinstall PD12, no luck...
     
  3. MikhailT1

    MikhailT1 Bit Poster

    Messages:
    21
    It is likely a bug in macOS 10.13 b4 (I've reported this to Apple) or Apple has changed the requirements for Kexts.

    For now, you can work around this by disabling SIP in macOS and Parallels will work.

    Note, other products like Parallels have the same issue, so this is not a bug in Parallels.
     
  4. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,719
    Yes MikhailT1, as macOS High Sierra is not officially released it is not supported by us. You are right, disabling System Integrity Protection might make Parallels Desktop work.
    Follow these steps to disable SIP:
    1. Restart your Mac.
    2. Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
    3. From the Utilities menu, select Terminal.
    4. At the prompt type exactly the following and then press Return: csrutil disable
    5. Terminal should display a message that SIP was disabled.
    6. From the menu, select Restart.
    You can re-enable SIP by following the above steps, but using csrutil enable instead.
     
  5. DannyP1

    DannyP1 Bit Poster

    Messages:
    1
    Thank you MikhailT1 for solution and Ajith for steps to implement. Parallels 12 was reporting Network cable unplugged, regardless of what I tried. Disabling SIP fixed the problem.
     
  6. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @DannyP1, you're welcome! Feel free to reach out anytime. We are here to help! Thanks!
     
  7. HenryJ2

    HenryJ2 Bit Poster

    Messages:
    2
    Will the instructions above help me if I can't seem to get past the "To run virtual machines, please allow the Parallels components to load on your Mac." The phrase about "Parallels, Inc" doesn't appear in Security & Privacy > General.
     

    Attached Files:

  8. KatiaF

    KatiaF Bit Poster

    Messages:
    4
    An easier and more secure solution is to revert to Parallels 12.2.0
     
  9. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @HenryJ2, have you tried this steps to resolve the issue? If not, please try and keep us posted the results.
     
  10. HenryJ2

    HenryJ2 Bit Poster

    Messages:
    2
    Thank you very much to MikhailT1 and Ajith. The solution that they suggested worked and I now have Parallels Version 12.2.1 (41615) installed on macOS 10.13 Beta (17A315i).
     
  11. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @HenryJ2, you're welcome! Feel free to reach out anytime. We are here to help! Thanks!
     
  12. HowardD2

    HowardD2 Bit Poster

    Messages:
    16
    Can kindly inform me from where I can download the earlier version you mention?
    Much appreciate your help.
     
  13. HowardD2

    HowardD2 Bit Poster

    Messages:
    16
  14. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
    We are always here to help you!
     
  15. HowardD2

    HowardD2 Bit Poster

    Messages:
    16
    That you have. May I ask if there is an ETA for update that takes into account the bug developed with 10.13 beta 4?
     
  16. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
    Hello @HowardD2 We do not have ETA. We are closely working with Apple on providing official support for High Sierra. We recommend you to wait for an update of Parallels Desktop 12 for Mac that will be available with High Sierra. Subscribe to http://kb.parallels.com/en/123948 to know when a new update is available.
     
  17. HowardD2

    HowardD2 Bit Poster

    Messages:
    16
    Noted with thanks.
     
  18. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
    You're Welcome! Thanks for your understanding.
     
  19. HowardD2

    HowardD2 Bit Poster

    Messages:
    16
    I can report that OS X 10.13 Beta (17A330h) works with Version 12.2.1 (41615) and there is no need for a roll back.
     

Share This Page