GalCiv 2 (Galactic Civilizations 2) under Parallels 3.0

Discussion in 'Windows Guest OS Discussion' started by david_mcmillen, Jun 5, 2008.

  1. david_mcmillen

    david_mcmillen

    Messages:
    4
    Hi, I'm starting a new GalCiv-specific thread because there seems to be a lot of interest in this particular game, and it seems like a prime candidate for a Parallels gaming success story: it's turn-based, so the graphical demands shouldn't break the bank, and it seems to *almost* work, at the moment.

    Using a Windows XP VM under Mac OS 10.5.2 (DirectX turned on), I was able to install GalCiv 2 using the Stardock Central application, and it starts up normally. Everything seems fine, but when I try to start an actual game, I get a wildly flickering mouse pointer, and bits of the screen are missing: parts of the interface, boxes in the tech tree, that sort of thing. It's unplayable in this state, but it's so tantalizingly close!

    Has anyone managed to tweak settings and get this to work properly? Any advice from the Parallels team? This is a well-loved game, and getting it to run under Parallels for Mac would be a coup for you folks. (And a boon for us.)
     
  2. david_mcmillen

    david_mcmillen

    Messages:
    4
    Compatible cursors

    Silly to reply to myself, but just in case others find it helpful: I've found that the "compatible cursors" trick helps a bit, here, as it does for City of Heroes/Villains:

    Go to the shortcut for Galactic Civilizations 2, right-click and select properties, and then go to the Target box. After the part in quotation marks, add the string -compatiblecursors 1

    This seems to make the mouse pointer stop flickering, but I'm still having problems with parts of the screen being blank. In particular, I can't see the stars and planets, which is a bit of a hindrance in a star/planet exploration game!
     
  3. vyam

    vyam

    Messages:
    1
    totally agree

    GalCiv 2 support is sadly the only blocking item for me purchasing Parallels 3.0. I currently have to dual boot to play, which is a pain since I really hate having to drop into WinXP just to play one of my favorite games.

    The Parallels team should focus on supporting games that have no viable OS X alternative. I realize that I *can* play certain FPS in parallels, but it's not really something that I'd want to do given the fact that I am playing it in a VM and have to deal with the performance penalties related to this. On the other hand GalCiv 2 is the type of game that *should* be supported by Parallels. It's a turn-based strategy game that has received stellar reviews in the past year and a fanantical following.

    I'm not sure if it's a DirectX 9.0c shaders issue or a simple lack of support for the game, but not having the mini-map available for the game makes the turn based game completely unplayable. Thanks in advance for any work related to this issue.
     
  4. tony.kay@gmail.com

    tony.kay@gmail.com

    Messages:
    4
    Fixing the Missing Graphics

    I managed to get Galactic Civ 2 working (all the way through Twilight of Arnor). It was a bit of a tinkering fest, so I'm not sure exactly which thing fixed it, but here are the things I tried that eventually worked:

    The following description is for twilight. Dark Avatar was working for me before I added the expansion.

    The planets, stars, planet ground tiles, and other basic graphics were missing. I had to enable hardware cursor, as others describe. This was easiest to do by editing the .ini file in the My Documents->My Games directory for the game.

    Then, I did the following:

    - I upgraded windows to the latest direct X 9c, which auto updates apparently does not do for you.

    - I turned OFF the experimental shader support in Parallels, and ran the game. This seemed to switch something internal in GalCiv that caused some things to show up. I believe this is where I could see the planets and stars, though somewhere in here I unchecked the full screen support, and that seemed to help even though I was still running it at full screen resolution.

    - Rebooted windows, and turned the experimental shaders back on.

    - At this point, it seems like all of the stuff that was missing was now visible, but now the ships were invisible!

    - I turned off the advanced ship rendering in graphics. This seemed to make the ships appear again.

    There are a few very minor glitches with the graphics now (some of the buttons are mis-sized), but there is nothing that affects the playability.
     
  5. tony.kay@gmail.com

    tony.kay@gmail.com

    Messages:
    4
    Works GREAT in Parallels 4

    I just upgraded to parallels 4, and GalCiv2 (and all expansion packs) work great! The previous version of parallels gave a "playable" experience if you really worked at fixing the configuration. The new version lets me configure it the same as I would in Windows Bootcamp.

    Notably:

    - All of the graphics glitches are gone.
    - It is much faster (playing on a gigantic map used to require me to zoom out until no 3D objects were rendered...now it is playable without having to do so)

    Wonderful! Thanks Parallels Team!
     
  6. CoyoteO

    CoyoteO

    Messages:
    2
    Glitches are not gone for me! Just upgraded to Parallels 4, saw this note, thought happiness would ensue, but sadly, when the game starts up, the mouse cursor completely vanishes. I tried editing the shortcut to add the "-compatiblecursors 1" statement, after seeing that suggestion elsewhere, but there was no effect.

    I'm using Parallels 4, Windows XP, OSX 10.5.8, on a 2x2.66 GHz Dual-Core Intel Xeon, with 9GB Memory.

    Anyone have any suggestions on how to get this working?
     
  7. tony.kay@gmail.com

    tony.kay@gmail.com

    Messages:
    4
    Tips under Parallels 4

    I admit, I am already running a copy I'd configured under P3. My config file (which is in "My Documents\My Games"\GalCiv2\Prefs.ini) contains this in the Video section:

    [Video]
    ...
    HardwareMouseCursor=1

    which should make it work. Think are similar prefs files in the expansion directories. Works fine on my macbook pro (core 2 duo) and Mac Pro (early 2009 model) quad core.
     
  8. CoyoteO

    CoyoteO

    Messages:
    2
    Upgrade to 5 fixes issues

    Thanks for your reply - but as I was about to implement, I noticed that there was an upgrade to 5.0 available, and it seems to have worked splendidly, without me having to change anything!
     
  9. markloch

    markloch

    Messages:
    2
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  10. markloch

    markloch

    Messages:
    2
    Parallels v5: galciv screen wont refresh on switch from window to fullscreen

    I can get get galciv2 running with v5, but the screen remains black if I switch from window to full screen, or if I move from full screen back to the mac desktop. Anyone have this problem? - Thanks, Mark
     

Share This Page