Gameplay in Parallels Desktop 8 with DirectX 10 and DirectX 9 games.

Discussion in 'Windows Virtual Machine' started by Andrew@Parallels, Dec 3, 2012.

  1. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Hey Gamers, we have some great news for you!

    As you might know, Parallels Desktop for Mac 8 includes experimental support for DirectX 10, Windows functionality that is related to game programming.

    We wanted to share with you some of the PC games we have tested and which we believe have acceptable playability and frames-per-second (FPS), a common measure of game performance.

    Here is the list of tested DirectX 10 and DirectX 9 games:

    Anno 2070
    Assassin Creed III
    Battlefield 3
    Bioshock 2
    Call of Duty: Black Ops II
    Civilization V
    Dirt Showdown
    F1 Race Stars
    Formula 1 2012
    Hitman: Absolution
    Need For Speed: The Run
    Sleeping Dogs
    Snipper Elite V2

    NOTE: As with a hardware PC, the Mac hardware you are using will have a significant effect on game performance. Video games require both a powerful processor and a very capable, modern video card. We did our testing and performance tuning on the high end Mac models, so you will get the best performance on the latest iMac and the MacPro with an ATI video card. Don't expect recent games to perform very well on a MacBook from several years ago.
    We also recommend that the Windows virtual machine you use to play these games be configured for 2 CPUs, and at least 2GB of RAM. Note, however, that assigning too much RAM to a virtual machine can actually slow down performance, since the Mac itself may not have access to sufficient RAM. And, of course, be sure that you are using the latest version of Parallels Desktop for Mac 8.

    If you haven’t found your game in the list above, it does not mean it won’t work in your virtual machine. Please share your experiences here in the Forum for our team and other players.
  2. Daniel.K

    Daniel.K Bit poster

    Kingdoms of Amalur Reckoning crashes upon launch. I tried Windows 7 and 8, using DX9 and DX10. Has anyone gotten Amalur to run on PD8?
  3. Andrew@Parallels

    Andrew@Parallels Parallels Team

    How does it crash, Daniel? Do you mean the installation crashes or you're able to install it but not able to run it?
  4. Daniel.K

    Daniel.K Bit poster

    Installation isn't the issue. I can play Amalur Reckoning using Boot Camp. Running my Boot Camp partition under PD8, Reckoning.exe dies a few seconds after I run it. No splash screen.
  5. dpickett

    dpickett Member

    Call of Duty Modern Warfare 2, Call of Duty Modern Warfare 3 and Call of Duty Black Ops all run under Windows 7 on a Mac Pro.
    Mass Effect and Mass Effect 2 run, although ME2 has some artifacting. ME3 won't run because Origin is required to run it, and Origin has problems in Parallels.

    For the record, the error I see when trying to launch ME3 from within Origin can be found at C:\ProgramData\EA Logs and is:

    [06:33:38]------------ Opening Log --------------
    [06:33:39]License Failure 3
    I have contacted EA/Origin customer support about this, but they do not support machines running in virtual environments.

    As a test I found a cracked copy of ME3 which launched and played fine. I also play the copy of ME3 I bought in Boot Camp, so I know the issue is Origin and not ME3. Unfortunately this means any games which are Origin exclusives won't be able to run in Parallels.

    If Parallels could fix this I would dance in joy.
    Last edited: Dec 5, 2012
  6. nikolayd

    nikolayd Bit poster

    Assassin's Creed 3

    Hi, I'm trying to run Assassin's Creed III on Parallels Desktop 8 on MBPr with 8GB RAM
    I tried allocating 2 and 4 cores to VM, tried setting RAM allocation from 2 to 4 GB, tried allocating from 512 to 1024 VRAM to the VM, both direct X9 and direct x10

    Every time i try to run the game I got around 0.5-1FPS and can't even pass the menu to check the game settings

    I also tried running in fullscreen, mac fullscreen, everything. What's the problem?
  7. Daniel.K

    Daniel.K Bit poster

    That explains why Amalur doesn't work for me. It's an Origin game. I don't get an error message in the gl_log though.
    Last edited: Dec 5, 2012
  8. dpickett

    dpickett Member

    As the Parallels team seems to be serious about gaming under Parallels, I have filed a problem ticket for the Origin issue.
  9. serv

    serv Forum Maven


    Make sure VM Configuration > Options > Optimization > Power is set to Better performance. (You'll need to stop your VM for setting to take effect.)
  10. mr_q

    mr_q Member


    SHIFT 1 and 2
    Alan Wake
    F.E.A.R. 2 and 3

    Far Cry 3 (crashes as you enter game world)
  11. JohnnyL

    JohnnyL Bit poster

    Is Counter-Strike Global Offensive compatible with Parallels 8? I have Parallels 7 and I get the error message: Your system does not meet the hardware requirements.. blah blah.. Im fairly new to Macs so maybe there is a workaround to this? I've tried use Google to find answers but had no luck :/
  12. pl1ght

    pl1ght Bit poster

    Is there a reason you wouldnt want to run CS GO through OSX version of steam?

    But to answer your question I am able to run CSGO and TF2 through parallels 8 on my 2012 MBA. I just prefer to run them both with the native OSX Steam Client.
  13. JohnnyL

    JohnnyL Bit poster

    Well for the time being, I am running it on OSX. But I'd like to run it on Windows via parallels because my gaming mouse is only supported on windows and not on mac.
  14. JDSgaming

    JDSgaming Bit poster

    Age of Conan Unchained Funcom

    I actually got Age of Conan running through Parallels Desktop 8 on my 3 year old Mac mini. It ran, but very slow. Which, I had expected.
    So, I just got one of the new iMacs with the nvidia 680 card. I migrated the vm from the old Mac mini, to the new iMac.
    After struggling with it for awhile, I discovered that it will absolutely not run under Cohesion mode. I did get it to run under full screen. But, it is still unstable. The whole VM has crashed (completely stopped and shutdown) on several occasions from any sort of zapping graphics. As in my character goes to send lightning at my foe and BOOM, virtual machine shutsdown. Oh, by the way, the OS is a preview copy of Windows 8.

    When AoC was running I saw 40 fps on the low graphical in game setting. With High graphical settings, between 14 fps and 20 fps. All bells and whistles turned on, about 8 fps. Now even at 40 fps, there was still a lag in the towns where you have more graphics to render because of all the buildings.

    AoC has been known to be laggey on even the most high end PCs, and seems to have a history of being at least slightly unstable. Be that as it may, I felt I might as well put in my 2 bits on this. Maybe, this is something that will become more stabilized as Parallels releases more Tools updates in the future.
  15. Andrew@Parallels

    Andrew@Parallels Parallels Team

    I checked the game system requirements online and it's supported on Windows XP/Vista only?
    Even you try to run it on Windows 8, please test it on the official version, not preview.

    As for the Coherence mode, we recommend to run "heavy" 3D apps either in Window or Full Screen modes.
  16. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Dear Gamers, if you find out that a certain game doesn't work in your virtual machine, please go through this easy checklist and post the answers here:

    1. Exact name and version of the game
    2. Does it suit the system requirements? At least check the RAM and if your OS is supported by the game manufacturer
    3. Exact steps to reproduce the problem (crashes on start, screen artifacts, etc.) and in which View Mode you're seeing the issue
    4. Problem report ID at the time the game seizes to work properly (hit Help->Report a Problem and post it here)

    It will help us to avoid going rounds and hopefully fix it. Thank you!

  17. KwonK9

    KwonK9 Bit poster

    I am also trying to run assassins creed 3 via Uplay from Ubisoft. I am actually able to get it going but cannot change any of the graphics setting like the quality and resolution otherwise the whole windows8 would crash. But the game is playable with its current settings. 1680x1050. Medium settings. Also, oddly the clothing on all the characters are glitchy. They are all pixelated (ill post a pic when I get home). I wonder if it has to do with the directx I have installed. My dxdiag shows dx11 but parallels only supports dx10?? How do I revert to dx10?
  18. Lefthy

    Lefthy Bit poster

    Graphical particleproblems in Dota 2

    Dear Developers,

    I am facing some graphical problems (it seems like particle problems) in Dota 2. Instead of seeing particleeffects from spells I face big black shadows/balls around them. It doesn't matter if I am running Dota 2 on Windows 8 or Windows 7.

    1. Dota 2 in the newest version via Steam. Doesn't matter which version actually. Happens since Parallels 8. In 7 everything was fine.
    2. It does suit my system requirements. I've the latest Macbook Pro 15'' from Summer 2012. As far as I am concerned everything was fine with Parallels 7 and Windows 7.
    3. You can reproduce the problem very easily. If you start a game and watch some stationary torches or cast spells or watch fights, you will experience big black shadows around these objects or spells.
    4. ProblemreportID: 20716872

    I hope you can fix this issue in one of the next updates! Thank you for your support!

  19. dg1sbg

    dg1sbg Bit poster

    Sorry, AC3 doesn't run on my MBP 2010 running Parallels 8 (latest build). AC3 downloaded all patches for the game but I get an app crash:

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: AC3SP.exe
    Application Version:
    Application Timestamp: 509d6d53
    Fault Module Name: AC3SP.exe
    Fault Module Version:
    Fault Module Timestamp: 509d6d53
    Exception Code: c0000005
    Exception Offset: 0041d57f
    OS Version: 6.1.7601.
    Locale ID: 1031
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    This happens right after hitting "play" (the screen gets changed to a blank full screen then the crash happens). What cn I do ?


  20. seanpiano

    seanpiano Bit poster

    bad bad bad

    i have a £1300 MacBook Pro 13, and had Win 8 Consumer Preview installed on PD8, it ran Command & Conquer 3 TW smoothly with the highest level of graphics enabled. Yesterday I upgraded the Win OS to Windows 8 Pro (as the Consumer preview version expires end of Jan 2013). However after the upgrade, the game start to lag BIG TIME (with all graphic effect disabled and still moves like snails...). I wonder what Microsoft or Parallel team did (or not did) to make the performance of the OS becomes such a stupid thing. It doesnt make sense!!...

Share This Page