Garmin GPS "device in use"?

Discussion in 'Windows Guest OS Discussion' started by ptomblin, Jul 19, 2008.

  1. ptomblin

    ptomblin

    Messages:
    2
    Does anybody know how to make it so I can plug my GPS in and not get into an infinite loop of Parallels asking me if I want to attach it to my guest OS, and then telling me that somebody else already has it in use? I've also tried telling it not to attach it, and then using the device menu to attach it, same result. I've also edited the configuration to attach USB devices to the Guest OS instead of asking (as suggested in another thread in this forum), but that didn't help.

    I've verified that other USB devices like thumb drives work fine, and also that the GPS works if I boot into Boot Camp.

    One strange thing: The GPS doesn't show up in the System Profiler.
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    problem is in Mac OS which treats GPS as USB storage device, try this
    unplug all USB devices, from Mac and VM
    Connect GPS
    in Applications/Utilities/Terminal

    sudo kextunload /System/Library/Extensions/IOUSBMassStorageClass.kext/
    if it fails it is on Mac, if it succeeds connect to Windows
     
  3. ptomblin

    ptomblin

    Messages:
    2
    No, it failed. Now what?
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,343
    Nothing we can do at this time it is Mac OS , if your model has explicit switch from storage mode to GPS , try to do that
     
  5. spot the blip

    spot the blip

    Messages:
    19
    ptomblin, this problem arose when mac upgraded the OS to version 10.4.10 about a year ago. Prior to that, a Garmin 296 would happily talk to Windows XP through Parallels. If you take a search, you will find a few comments; I tend to major! On 31 October last year, Xenos, one of the Parallels team posted:


    They then appeared to come up with a fix (http://kb.parallels.com/en/5053) which had a specific build for users where the USB used to connect before build 5580. The fix doesn't work. It seems to me that there is little/no interest in solving the issue. Pity really as the only reason I purchased Parallels and Windows for one specific application I needed to run with a Garmin 296/496.

    So Parallels, over to you guys. This one has been dragging on a while and your sales pitch says "Fast USB Support
    'Plug and play' your favorite Windows-only 2.0 USB devices". My Garmin 296 is still my favourite plug and play USB device and your software used to support it. Should we still hang around or should we just try another VM?
     
    Last edited: Jul 20, 2008
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
    Not sure, this is Parallels failure, perform this on Mac without Parallels Desktop, and you still will not be able to unplug device from Mac, using kextunload
     
  7. spot the blip

    spot the blip

    Messages:
    19
    My point is that, a while back, you guys said you were working on it. Are you?
     
  8. John@Parallels

    John@Parallels

    Messages:
    6,343

Share This Page