General - UVC device (camera) not working under Windows 11 ARM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by HowardH5, Apr 15, 2022.

  1. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    I have a USB microscope camera device that is recognized as an ordinary webcam usually. It works on the Mac Studio M1 Max under general applications like Photo Booth. I have the permissions under security in Mac OS and parallels set. The web camera is set to share with windows under the parallels control panel. Under Windows 11, the "General - UVC driver" is installed which is the one it should use. But I don't get an image under "manage cameras" or the generic camera app. The camera permissions are set under Windows 11 as well. The device manager shows everything is working properly with the driver. Is there anything else I can try? I don't know if it is a Windows 11 ARM issue or a parallels 17 issue as I don't own a native Windows 11 ARM device.
     
  2. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    I've tried just about everything. The device seems like it is functional but there is no video feed being passed.
     
  3. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    In general, are there any issues with generic webcams (not FaceTime ones built into the MacBook Pro and the like) working under Parallels and a Windows 11 ARM virtual machine? I tried searching but only found one report about issues with a Dell webcam. Mine doesn't even use special (device specific) drivers so I don't know what the issue is. Thanks.
     
  4. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    Can anyone help me debug this? Or else I guess I won't be purchasing Parallels 17 once my trial expires. Thanks.
     
  5. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    Is there any way to get support during the trial period?
     
  6. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    715
    I don't know. What happens when you log in on parallels.com and go to support?
     
  7. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    I sent a message via twitter. You don't have direct access to support during the trial. And no-one from Parallels is replying here. I guess you are stuck if something doesn't work during the trial period? I would think they would want to make a sale.
     
  8. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    When running the Windows 11 VM, is the camera supposed to be disabled under MacOS? I can still access it. I'm not sure if this is correct.
     
  9. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    715
    I don't think so. At least it wouldn't make sense to me to disable the camera on macOS. The whole point of a VM is that you can run multiple operating systems at the same time and each one might need camera access.
     
  10. HowardH5

    HowardH5 Bit Poster

    Messages:
    11
    Oh okay. I thought maybe the OS's would interfere with each other. I guess I am just at a loss why the image/video doesn't show up in the Windows 11 VM. The windows driver shows everything is working okay. And I have all the permissions set in both Windows 11 and MacOS but I still don't get an image under Windows 11. I reinstalled Parallel Tools but it didn't help. I only have 7 days left in the trial.
     
  11. ParallelsU969

    ParallelsU969

    Messages:
    1
    Hello
    I have the same issue, but not under Parallels but in plain vanilla WIN11. It seams the "standard" USB2.0 Cam driver is broken in Win 11. I could very by swapping back and forth with Win 10
     

Share This Page