Glitch with shared folders keeps deleting OSX Home>Pictures folder

Discussion in 'Installation and Configuration' started by dk-nms, Sep 16, 2015.

  1. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Thought I had an issue with a glitchy drive or something, but finally figured out that everytime Parallels throws a fit and decides it wants to go into the "have to restart to change shared folder settings" it manages to delete the full contents of the Pictures folder (Photos library, old iPhotos library, Adobe Lightroom projects folder, and... uh... something else.)
    Fortunately I rock Time Machine like a boss... but after the 10th time of restoring that folder and having Photos rehabilitate the files, it would be excellent have Parallels STOP deleting random folders when it can't successfully load the profile, or whatever the crap is actually going on under the hood.
     
  2. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    And each time, it seems to be preceeded by the Win7 VM being completely incapable of completing the log-in in the first place. Getting ready to run another Time Machine recovery as the clock keeps ticking on the 'Welcome' screen for W7. Grrrrreat.
     
  3. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Aaaaaand there's the inevitable "Photos must quit because the photo library has become unavailable or its data is corrupt."
    Please? Someone? Why would the W7 VM be erasing the contents of that folder?!
    AND there goes the VM logging in without a hitch on the 3rd attempt, no changes by me. (head -> desk, head -> desk)
     
  4. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Hi, in order to investigate the issue further we need a bit more technical information. Could you please generate the problem report using this KB right after the issue reproducing and reply us back with the 8-digit report number.
     
  5. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    75186760
    Initial run, while Parallels/W7 fails completely to login (second attempt... first attempt failed out with the "need to reboot to synchronize folders, and I had already hit OK before I saw your response.) I'll send another one if/when it ever DOES login successfully.
     
  6. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    75187762
    Same login attempt, but Photos just crashed with the "Photos must quit because the photo library has become unavailable or its data is corrupt." error and W7 is again telling me that "You will be logged out of the system to apply the new Shared Profile settings. When you log in again, these host computer user folders will be mapped to user folders in the virtual machine: (X's in place for all options: Desktop, Documents, Pictures, Music, Movies, Downloads."
     
  7. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    75188463
    Login "completion" (with the "You will be logged out of the system to apply the new Shared Profile settings. When you log in again, these host computer user folders will be mapped to user folders in the virtual machine: (X's in place for all options: Desktop, Documents, Pictures, Music, Movies, Downloads." error onscreen.)
    Do I try it again... or wait for you to wade through my spam attack of problem reports? (Not trying to be a jerk with those three, just figured they might reveal different issues, or the development of an issue during a 20m long failed login attempt...)
     
  8. ManojK@Parallels

    ManojK@Parallels Parallels Support

    Messages:
    367
  9. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Thanks Manoj!

    Ran the MS support cmd line as directed, no issues.

    Not sure what you want me to do with the "test virtual machine." The link appeared to be just to Modern.IE builds... is that what you had in mind, or were you thinking of me creating another W7 VM to match what I have? Just want to make sure I follow the protocol as you intend, and not waste all of our time! Thank you!
     
  10. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Shut down the VM last night (working fine), started it up today, "You will be logged out of the system to apply the new Shared Profile settings..." Contents of User>Pictures is empty... again.
    Running the System File Checker again, with the error message still up (to keep the VM from rebooting...) - Windows Resource Protection did not find any integrity violations.
    Throwing a Hail Mary and trying to reinstall Parallels Tools before allowing the restart...
    This restart and login took a LONG time too... but it did successfully log in.
    Seriously, I *assume* I'm missing something obvious... but have no idea what.
     
  11. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Here's an AMAZING new development: Created a Windows 8.1 Enterprise VM... and GUESS what just happened?! Yup, just went to start it up, and suddenly Photos had to quit because the files disappeared out from under it.
    What. The. F***?!? Seriously, have I stumped the chumps? Haven't heard back on anything since Manoj's helpful (but ultimately ineffective) suggestions from a month ago. Anyone?
     
  12. vasilyz

    vasilyz Parallels Developers

    Messages:
    84
    dk-nms, sorry for the inconvenience. Could you please assist us to investigate the problem?
    There are several questions.
    1. Do you use a domain user profile in your guest OS? A domain user profile may conflict with our Shared Profile feature. If so, then disabling Shared Profile may help to resolve difficulties with login. To disable Shared Profile, untick the VmConfig->Options->Sharing->Shared Profile checkbox.

    2. About the Photos problem. We didn't have such reports before. First of all, let's try to disable Cloud Sharing feature and look whether it helps. So, please, untick the VmConfig->Options->Sharing->Shared Cloud checkbox. It is better to do when the VM is off, otherwise you will have to reboot the VM.

    Please share your results. Thank you.
     
  13. dk-nms

    dk-nms Bit Poster

    Messages:
    16
    Hm... immediate feedback is that option one appears to have dodged the issue, at least for now. Shut down the W8.1 VM, made the change to the Shared Profile setting, rebooted it, and it logged right in, no super long login time, no random deleting of files on the Mac drives... I'll go with this for a bit, if anything comes up, I'll try option 2. Thanks for the help Vasilyz. I really appreciate it. I just kind of lose my s**t when it looks like I've permanently lost my Photos (again) and it happens over a long weekend, so the Time Machine backup has already written over the missing data repeatedly...
     
  14. ParallelsU317

    ParallelsU317 Bit Poster

    Messages:
    6
    Now, years later than the previous post in this topic, I am having similar issues. Using Windows 10 and upgraded to Parallels 15 I am getting these messages twice a week. But worst of all, every time the message appears, it deletes all my files from the 'Documents' folder. So I have two questions:
    1. How do I get my files back if I do not have a backup?
    2. How do I make sure this issue is resolved?

    Thanks!
     
  15. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Hi, could you please provide us with detailed issue description, that we will be able to reproduce it on our side.
    Also the screenshot of the message you got will be very helpful. Thanks in advance for your help.
     
  16. ParallelsU317

    ParallelsU317 Bit Poster

    Messages:
    6
    Hello Maria,
    I have been running Parallels on a 13" MacBook Pro Retina 2014 for years without issues. I was running Windows Vista.
    One month ago I migrated to a 13" MacBook Pro 2019. And updated to Windows 10 Version 1903. Only two weeks later I updated to Parallels 15.
    The first time I started Windows 10 on my new Mac the message appeared (see screenshot). I could only click "ok" and Windows would restart. Then again the message appeared, click "ok" and again a restart. This would happen about 3 or for times in a row before the message stopped appearing. After some days I realize that my files in the Mac "documents" folder were completely deleted. I first thought I made the stupidest mistake.
    During the following weeks, always after a restart due to empty battery, the message would appear again when restarting Windows and again only "ok" option followed by a restart of Windows. But now only two times in a row.
    Then I found out that, again, my documents folder was completely empty, but still had not made the connection that it could be linked to the messages I was getting.
    Until yesterday. I had opened a file that was saved in the "documents" folder in the morning. Some time later that day, after my computer restarted (again due to empty battery), the message appeared again (twice). I checked the "documents" folder and it was empty...
    Strange thing about this is that only the "documents" folder is empty and not "pictures", "desktop", "music", etc. Although they are all 'shared' with Windows.
    I seems like this happens after a Mac or Windows or Parallels update or fix. Not sure which.

    The glitch makes it impossible to continue working in Parallels if I keep on loosing my files.
    Maybe you have seen this before and can direct me where I can find the deleted files after this happens.

    Thanks!
     

    Attached Files:

  17. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Thanks a lot for the detailed description.
    I'd like to suggest you to upgrade your Parallels Desktop to the latest build 15.1.0 and then reinstall Parallels Tools.
    Then please check the issue and let me know how does it work.
    Then we will continue the issue investigation if necessary.
    Looking forward to your reply.
     
  18. ParallelsU317

    ParallelsU317 Bit Poster

    Messages:
    6
    Hello Maria,
    Update installed and tools reinstalled last Friday.
    Today all documents in folder empty again after restarting Windows after running out of battery. The same message appeared.
    This time I found out that the documents were deleted while logging on to Windows. In other words, while the message makes it appearing as if this happens after clicking 'ok', it seems that the damage is already done...
     
  19. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Could you please share the screenshot of your VM sharing settings?
     
  20. ParallelsU317

    ParallelsU317 Bit Poster

    Messages:
    6
    Like this?

    upload_2019-10-25_14-16-29.png
     

Share This Page