Gnome Shell and Cinnamon blue screen glitch issues.

Discussion in 'Linux Guest OS Discussion' started by ShahnawazS, Oct 30, 2013.

  1. ShahnawazS

    ShahnawazS Bit Poster

    Messages:
    13
    I've managed to install Fedora 19 as a new VM, and also installed the Parallels Tools on the Fedora 19 VM. I've outlined the steps I normally follow to successfully install Parallels Tools onto Fedora 19 below.

    Once the hardware acceleration kicks in, Fedora 19 runs quite smoothly. Only one (big) issue; blue glitches appear randomly when interacting with Gnome Shell.

    I have attached screen shots of how the blue glitches appear like.

    I was hoping that there would be an update that would resolve this issue. I also wondered if this is a common issue.

    I have also tested Linux Mint 15 and a similar issue appears on Cinnamon.

    Any thoughts? Disabling 3D acceleration is not an option (too slow to work with). (By the way, Fedora 19 works well on VMware Fusion 6).

    Parallels Picture 1.png Parallels Picture 3.jpg Parallels Picture 5.jpg

    (Steps for installing Parallel Tools on Fedora 19:

    - Log into your VM instance running Fedora 19.
    - Make sure that your Fedora 19 VM instance is up to date with the latest updates (if not, then run 'sudo yum update').
    - Install dkms (sudo yum install dkms). This will install all the necessary dependencies such as make, kernel source, gcc, etc. Then restart your instance of Fedora 19.
    - Once restarted, log back in and run the Parallels Tools install (either the CLI or the GUI install script will do).)
     
    Last edited: Oct 30, 2013
  2. phearus

    phearus

    Messages:
    12
    Me too - I have filled-out a "support-ticket" for this. There is still no-one assigned to fixing the issue.

    So here are my details:

    Parallels Desktop 9 - Build 9.0.23140 (Revision 935944; Friday, October 25, 2013)
    Host machine: OSX 10.9 Mavericks on MBPr15 (1st gen).
    Guests: Ubuntu 12.04 with Gnome Shell 3.4 (all unity components have been stripped-out).

    I get exactly the same "blue-screen" flickering bug.

    Screenshots:

    Activities-Applications-Flicker.png Activities-Flicker.png
     
    Last edited: Oct 30, 2013
  3. zenetti

    zenetti Bit Poster

    Messages:
    2
    Using a configuration similar to Post #2:

    Parallels Desktop 9 running on OSX 10.9 with Ubuntu 12.04 as guest OS.
    Desktop is Unity 3D or 2D, with Gnome 3D/2D as further test options.

    I also do see graphics glitches under Unity 3D (and Gnome 3D), for which a ticket has been opened yesterday. I am including the ticket description in the following. In 2D mode (Unity and Gnome), the glitches disappear.


    My problem is fully described by the following compiz bug report:
    https://bugs.launchpad.net/compiz-core/+bug/963093

    In Unity 3D mode, I do see a flickering of the upper menubar/panel (drop shadow) and launcher on the left. The graphics card has 3D enabled (using 256 MB of virtual memory) and Parallels tools are installed. My guest OS is Ubuntu 12.04 with all updates installed. The flickering effect is not seen in Unity 2D mode.

    For Parallels 7/8, in particular, the problem is mentioned in Comment #63 of the bug report:
    https://bugs.launchpad.net/compiz-core/+bug/963093/comments/63

    Comment #13 further suggests to use CCSM and enable workaround "Force full screen redraw (buffer swap) on repaint". In my case, this helps getting rid of the flicker effect, but is not recommended as extremely CPU intensive:
    https://bugs.launchpad.net/compiz-core/+bug/963093/comments/13

    Question is whether the issue is compiz related or a problem with the Parallels driver?
    Prior to installing Parallels Tools, no flickering issues were seen.
     
  4. phearus

    phearus

    Messages:
    12
    The problem cannot be compiz related as:

    1) There was previously no issue in Parallels 9 with Latest Mountain Lion.

    2) Gnome 3 does not use compiz - unity does, but as I said, I stripped out all Unity packages, including compiz.

    3) This problem does not exist in VirtualBox.

    4) No problems before installing Parallels tools (as mentioned in the above post).

    Come on Parallels - if you want us to keep paying premium prices annually for your sub-optimal product, you gotta start improving your Linux support. And, if I am going to pay for something, I will just go pay for "the other-guy's" software - who can get it right (if I don't just go with the open-source option).

    Just have a look at how Oracle's VirtualBox code works - it is open-source after-all.
     
    Last edited: Oct 31, 2013
  5. zenetti

    zenetti Bit Poster

    Messages:
    2
    I second the suspicion that, most likely, this is a issue with the Parallels graphics driver.

    After issuing the ticket, I have been experimenting with Gnome and, as outlined above, have also seen graphics glitches in Gnome 3D mode (2D is fine). For testing purposes, I have further installed the very first Ubuntu 12.04(.0) package which comes with older versions of X and compiz. However, same flickering issue with Unity panel and launcher.

    Browsing the web for flickering bugs like the ones described here (mainly on native installations), one encounters recommendations on driver update, uninstall, or reinstall. As further outlined in my first post, tweaking the rendering method to full screen redraw in CCSM (Compiz Config Settings Manager) makes the flickering go away. Unfortunately, this kind of rendering is not at all an acceptable workaround.

    I guess we have no other option than waiting for Parallels to fix the graphics driver/emulation (asap).
     
    Last edited: Oct 31, 2013
  6. ShahnawazS

    ShahnawazS Bit Poster

    Messages:
    13
    Well, Fedora 19 works pretty well on VMware. In fact the Plymouth boot appears under VMware. Plus the license for VMware allows the user to install on (I guess) up to 3 machines. Whilst it does work and has some benefits, the downside to VMware is that it is just not as smooth as Parallels. Tearing is more noticeable when moving the windows around on Ubuntu/Fedora under Vmware, whereas Parallels is smoother.

    That said, these graphical glitches in Parallels must be resolved pronto. Given that SteamOS is coming very soon this really needs to take priority to make it work well and have a competitive advantage. (I feel most users would install SteamOS on a physical machine, but for trial purposes virtual machines offer a good approach for checking it out).
     
  7. phearus

    phearus

    Messages:
    12
    OK. So this is the reply from Parallels for the "Support Ticket" I filled in:

    "Please refer to the following Knowledge Based article on "How do I install Parallels Tools in Ubuntu Virtual Machine?" and check if
    your issue is getting resolved.

    http://kb.parallels.com/en/113394

    In case you need any assistance from Parallels, please feel free to reply to this email within the next 14 days and we will contact you to continue working on the case.
    This case will be placed in the "Pending Confirmation by Customer" status.

    We appreciate your time and consideration.

    You may find more tips on tuning either Mac or Windows for speed at:

    http://kb.parallels.com/en/115645
    "

    Sigh. Of-course - blame the [Linux] users - they must be doing it wrong. Doesn't look like there is much effort going into getting this resolved - at least from this response and from this thread.
     
    Last edited: Nov 4, 2013
  8. Skip72

    Skip72 Bit Poster

    Messages:
    9
    For what it's worth, I have been using PD9 in conjunction with Debian/Cinnamon 2.0.x, compiled from sources from the linuxmint repository. I have also had the severe flashing problem, and falsely attributed it to Cinnamon. My setup has an Ivy Bridge 3570K processor with Intel HD4000 graphics and a GeForce 650 Ti card. The flicker is severe with the 650 Ti and non-existant with the Intel HD4000. I've switched back to the HD4000 until the driver gets fixed. I'm curious if this is an Nvidia-related issue, or does it also exist with AMD cards?

    --skip
     
  9. phearus

    phearus

    Messages:
    12
    This is what I replied to my "Support man" (sans politeness and courtesies):

    "Following all Knowledge Based information (links supplied by you) makes no difference / does not resolve the bugs.

    Repeat - the problems / bugs still persist."

    And this is the response:

    "I under still you are experience the same issue with your Virtual Machine.

    Please check this knowledge base article to resolve the issue.

    http://download.parallels.com/desktop/v4/docs/en/Parallels_Desktop_Users_Guide/22570.htm

    Please provide the steps when this issue reproduces.
    Please provide us Problem Report ID

    How to create a Problem Report ID

    http://kb.parallels.com/en/9058"

    So - basically he wants me to do the support-ticket thing again, just to report a bug we are all seeing with the latest Parallels-Tools / drivers, that I have already reported through this mechanism.

    Is there actually, hidden somewhere on the parallels website/s, a bug-reporting system? I'm pretty sure there isn't, but it seems to me that reporting bugs through this "support" mechanism does not work, so there must / needs to be another mechanism.

    VirtualBox is looking more and more attractive as the days roll-by without a bug-fix / resolution insight for something that it seems nearly all Parallels-Linux users are experiencing. I bet if this was a problem with how "Internet Explorer" was rendering it would be fixed in minutes.
     
    Last edited: Nov 4, 2013
  10. stewarsh

    stewarsh Bit Poster

    Messages:
    20
    I too have the same problem except under Ubuntu 12.04, 13.04, and 13.10. Trying to trace the problem it seems to be tied to Parallels use of the OpenGL and, at least for me, the discrete graphics card in my MBP. The same problem existed when running under Mountain Lion but was able to stop it by forcing the system to use the "High Performance" graphics card via the Energy Saver control panel. This no longer works in Mavricks so I can only assume that Parallels isn't properly handling the graphics card switching.

    This problem does NOT occur when Parallels tools are not installed as it seems that the tools is replacing the native OpenGL libs with it's own and those libs seems to be what's causing Gnome to crash (get the blue screen). Replacing these libs with the system standard corrects the issue but doesn't correctly enable full OpenGL support.

    Further when running Parallels and looking at Activity Monitor it doesn't seem that Parallels is using the discrete card at all so I can only assume that Parallels is failing to utilize Mavericks power control features correctly when it comes to graphics and is screwing up our VMs in the process.

    For some of us, Windows is irrelevant and we work in Linux. So I couldn't care less if Windows works right. Fix LINUX! Friends of mine report that VMWare Fusion works better. I have been using Parallels since version 3, but I WILL switch if you continue to provide such crap support for Linux.
     
    Last edited: Nov 4, 2013
  11. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi All,
    Please reproduce the issue and submit problem reports. Post your IDs here (http://kb.parallels.com/9058)
    Once I get it, we will report the issue to the development team. Thanks!


    @phearus - I asked to escalate your ticket to second line. Please avoid copy/pasting long conversations, as it makes the thread unreadable. I'd appreciate if you edit your responses and leave only necessary information.
     
  12. stewarsh

    stewarsh Bit Poster

    Messages:
    20
    Problem Report #30633427. And to recreate this, simply install a new Ubuntu Gnome OS, Login using the Gnome 3 session, install Parallels Tools, and move your mouse to to menu bar.

    I also want to note the VM performs fine until Parallels Tools is installed. Also I have had some luck restoring the libGL and libglx files that the Tools replace as part of this, so I believe the issue is there. The native libs seem to be newer and are much smaller than the Parallels version, FWIW.
     
    Last edited: Nov 5, 2013
  13. phearus

    phearus

    Messages:
    12
    Problem report #1769759: Gnome Screen Flickering Bug and Hanging Host Machine Bug.

    To recreate the flicker bug install a new Ubuntu Gnome 12.04 from the ISO, login to Gnome 3 session, install Parallels Tools, and move your mouse to to menu bar and/or enter activities panel.

    [Unrelated to this thread - but on the problem report ticket]
    To recreate hanging host machine - open Parallels Desktop 9, use linux-VM and/or close Parallels Desktop 9, sooner or later the host machine will hang up. The only way to regain responsiveness it to ALT+TAB a few times, then eventually the active application will cycle.
     
  14. ShahnawazS

    ShahnawazS Bit Poster

    Messages:
    13
    Report ID#: 30649653

    The use of Gnome Shell 3.8 and onwards on Fedora 19 (and other Linux distributions) has blue screen issues appearing when interacting with the Gnome Shell desktop. For example, accessing the Activities menu, interacting with the calendar, navigating through program icons, etc.
     
  15. Molitor E

    Molitor E

    Messages:
    2
    Parallels hasn't commented on the forum but I can confirm via my support request that they've reproduced the issue and it has been escalated.
     
  16. phearus

    phearus

    Messages:
    12
    By the time this issue is resolved, we are all going to get the email from sales@parallels.com:

    "Upgrade NOW to Parallels 10!

    * Actual support for 2.5-year-old graphics libraries!
    * Improved Linux Parallels-Tools installer that doesn't give you option to "remove" Parallels tools - but does make you install some old-and-now-depreciated 32-bit graphics libraries!
    * As a bonus - the installer makes Linux look like Windows 2000, and gives you that "Start" menu all you Linux aficionados have been gagging for!
    * Also, actual support for Ubuntu 12.04 (even though 14.04 just came-out).
    * You asked for it - we ignored you again - STILL no support for Arch Linux!
    * more Windows support and features and stuff that you don't actually want!

    Send your money NOW and upgrade to Software that works worse that the last three versions all put together!"

    I am out. Farewell Parallels. I am taking my money... oh no, wait, I can get virtualization for free with Open-Source tools.



    If you too want to abandon this sinking ship - this is what I did to get my 12.04-based machines working with VirtualBox.

    1. Look inside the Parallels ".app" application bundle, and copy-paste the parallels tools iso out-to somewhere accessible.

    2. If you have snapshots - now is the time to merge-them all back into the master HDD image (sorry!). Look this process up. It involves deleting the "mid-way" snapshots - this merges all the data back into the main HDD image. Be careful with this - you can very easily accidentally delete your most up-to date machine's state - I did on one of mine (it was late and I was not careful).

    3. Start-up your VM, mount the parallels-tools iso, then run the Parallels-Tools installer from the command-line - old-school. From here you can select "remove" parallels tools in the good-old-"old-style" installer.

    4. Doing this will completely break your desktop environment - Whoopie! For me it went to the Gnome-Fallback environment. This is cool - we can fix it.

    5. Shutdown your VM, perform the same operations on your other VMs, and close Parallels for one final time!

    6. Now you want to get the actual hard-drive image files from your Parallels VMs - these are just bundles -similar to "*.app" bundles - a folder with a file extension. After uninstalling Parallels, Finder MAY interpret them as normal folders - it may not... I cannot remember. So to be safe - get the goods out while Parallels is still installed. Inside the VM bundle is an *.HDD file - this is another bundle. Go in there, and you will find one very-large *.HDI file - if you deleted / merged your snapshots carefully - with a silly name. This is the hard-drive image. Copy / cut and paste this somewhere accessible. I renamed them to <something-appropriate>.HDD. This saves you a few clicks later-on.

    7. Uninstall Parallels. This involves more than just deleting the Parallels Desktop.app file in your Applications folder. Parallels have a tutorial amongst their wonderful "knowledge-base" of useful articles on how to do this. However this method doesn't catch all the Parallels "flotsam-and-jetsam" scattered around your system. With patience and time you will get them. Once the *.kexts are gone - the rest is just a bad-hangover.

    8. Download and install VirtualBox - they recently updated from the 3.* series to the 4.* series - VirtualBox is getting very-very good. Don't forget to download the VM extensions, and install them too.

    9. Create a new VirtualBox VM - I wont go into that here - and use the old existing *.HDI file (that you may have renamed to <something-appropriate>.HDD). What I usually do here is get to the stage of selecting the image-file, then cut-and-paste the *.HDD file into the newly-created VirtualBox VM folder - and select it from there - just good house-keeping.

    10. Tweak your settings - again, I wont go into that here, and start your VM.

    11. Virtualbox will then want to install the "VirtualBox Guest Additions." Let this happen.

    12. Now you want to fix the problems caused by the "Parallels-Tools" lobotomy. What I did was: a) first install "synaptics package manager" - this lets me see all the installed packages in a convenient GUI. Then in "synaptics package manager" I serached for "openGL". I then reordered the listed packages so the installed packages were at the top of the list, then selected tham all, and marked them for "reinstallation." I then accepted the changes and had these packages reinstall.

    13. After a reboot, everything was back to normal - everything worked as it should, and I had a virtual machine with Gnome DE, WITHOUT any flashing-blue-fit-enducing bugs.

    I am now happy. Thanks for some good (if not expensive) times, Parallels, but it is time for me to move-on. You came to me with your hand-out one-to-many times - with promises of performance and world-class support. After I coughed-up my money, time-and-time again, you happily took-it, and then repetitively kicked me in groin. I wont stand for that any more. The only regrets I have are the opportunities I gave you to improve, and all my money you are no-doubt rolling-in. So now I am saying goodbye.

    I have a new love now. And you know what? When an update is released - I don't even have to pay for it! You know what's even better? I can submit bug-reports. And one final "tour-de-force?" I can then go and fix any bug I found myself - and contribute it back upstream. FOSS FTW!

    I can now install and use Arch Linux too. Now I am happy - happier now than ever before, without you, Parallels.
     
    Last edited: Nov 9, 2013
  17. KarstenB

    KarstenB

    Messages:
    6
    I am also having this problem and am thinking about dumping parallels - i upgraded to 9 for what I just paid for 8 a few months ago because fedora 19 wouldnt work on parallels 8 at due to parallels tools not being supported, and now that I upgraded I still cant get it to work because of the blue flashing bug ???

    Is there no reply from the developers at parallels ?
     
  18. ShahnawazS

    ShahnawazS Bit Poster

    Messages:
    13
    I've installed the latest version of VirtualBox (4.3.2) and, yes, Fedora 19 runs fine with no blue glitches on screen.

    However, as always with VirtualBox, it is nowhere near as fast as Parallels.

    When you simply move the window around it moves in a jerky fashion. I have 3D enabled and have set the graphics memory to 128M. But it is still not 'buttery smooth' compared to running it under Parallels (if you ignore the blue glitches).

    I've said in my previous post, Fedora 19 under VMware does run well also. Whilst not as slow as VirtualBox, but still comparitively slow to Parallels. At least, the plymouth splash loading logo works under VMware, compared to the shoddy progress bar that you find running along the bottom of the screen.

    I understand what you're saying phearus about paying so much for Parallels and yet we get very poor support for Linux. Unless the folks at Parallels comes up with an update for version 9 (hopefully without paying any extra) I would say, for now, VMware followed by VirtualBox provides better support for Linux.

    Remember, SteamOS is just around the corner! Performance is going to be key here.

    Mind you, I'm currently using elementary OS Luna and it runs really nicely under Parallels. It doesn't have the glitches compared what we're experiencing with Fedora (only noticeable at times when switching workspaces), but runs very well under the current version of Parallels 9. Ubuntu 13.10 runs fine also, but I wouldn't say it is 'spot on'.
     
    Last edited: Nov 14, 2013
  19. KarstenB

    KarstenB

    Messages:
    6
    Still no support on this issue ?
     
  20. KarstenB

    KarstenB

    Messages:
    6
    what the hell is going on here ? can I get a refund at least since this crap doesnt work ?
     

Share This Page