Graphics artifacts / boxes with Desktop 5 and XP and 7

Discussion in 'Windows Guest OS Discussion' started by DrKarl, Nov 6, 2009.

  1. DrKarl

    DrKarl Bit Poster

    Messages:
    71
    I looked to see if anyone else has had this problem, but don't see another report...

    I upgraded from 4 to 5 today and have XP Pro SP 3 (work) as well as Win 7 RC (play) VMs.

    I get terrible graphics artifacts with each.

    With XP Pro, displaying just Excel, the spreadsheet grid sometimes does not display - minimize to dock and restore helps (Crystal mode in this case) - but then there are odd gray rectangles blocking out the spreadsheet.

    In windowed mode, Autodesk DWG Trueview - a simple 2D CAD viewer - flickers when panning, or when dragging the window. Never had any problems like that with Desktop 4.

    In the Win 7 RC VM, a 3D viewer that uses OpenGL has a little less then the lower left 1/4 of the screen occupied by a black rectangle in which crazy wireframe stuff appears.

    I have no problems on my Mac, nor did I in Desktop 4. I set both machines to 256 MB graphics memory and the box for graphics acceleration is checked. I'm running Snow Leopard 10.6.1 on an 8 core Early 2008 Mac Pro with 10 GB RAM and have 100's of GB of free disk space.

    any Ideas?

    Karl

    PS I brought up Google SketchUp in Crystal mode on the XP VM, but did not see any issues in a minute or two of testing (unlike the issues above that happened immediately).
     
  2. BeaMeUp

    BeaMeUp

    Messages:
    3
    I'm having a similar issue after just upgrading to Desktop 5. I'm on a 1.83 GHz Intel core 2 Duo MacMini with 2GB RAM. I have a 20" Acer P201W monitor hooked up DVI. Resolution 1680 x 1050. Only have 2 guests installed, Ubuntu 9.10 and Windows 7. After I boot up I keep getting a small black rectangle, 1 x 3 inches, about 2 thirds the way up and center, that will flash off and on and sometimes stay for a few seconds. Happens in both guest OS'es. I've tried changing settings, turning off 3d, with and w/out Hypervisor and it doesn't matter.

    I only noticed this in Full Screen so far. I'll have to try with Crystal, Coherence or Modality and see if it happens there, but I never use those, and not really in the mood for "beta testing".

    No problems with OS X 10.62, and didn't have that issue with Desktop 4.
     
  3. Shaddam IV

    Shaddam IV

    Messages:
    626
    I had the same issue when I'd set my VM to 2 processors. After I'd changed this so that the VM is using only 1 processor I have this issue no more.
     
  4. BeaMeUp

    BeaMeUp

    Messages:
    3
    I'm only using 1 processor. I'm thinking my Intel Graphics processor on my Mini can't handle this.
     
  5. SysOp

    SysOp

    Messages:
    1
    Graphics Artifacts on Mac Mini

    I have similar problems and have gone back to Parallels 4.

    If the VM is running in a window and the VM list is behind it, I get black rectangles that
    blink on and off the screen where it looks like it's trying to update the "thumbnail" in the
    VM list.

    I have a Mac Mini, and am using single processor in the VM.

    I never had these issues with 4.

    I'll be happy to upgrade when the problem is diagnosed and fixed.

    Thanks!
     
  6. Oil_Fan

    Oil_Fan

    Messages:
    5
    Add me to the list too. I opened a thread a couple of days ago on but haven't heard anything.

    For me it's 10.6.2, Parallels 5 and Win XP Pro SP3 on a brand new 21.5" iMac. The same VM works just fine on a new MacBook Pro so I know it's the VM itself is fine. I'm only having the issue on the iMac when using either full screen or window mode. Coherence works just fine.

    And I just tested only using 1 core instead of 2. Same video corruption. Very frustrating...
     
  7. texeter

    texeter

    Messages:
    21
    I've had the same problem which I wrote up on another thread and I've also submitted a ticket which was by and large a waste of time. They had me installing and de-installing with no result. One gets the feeling that no one in tech support reads these things and that they have call center types who work their way through a script with no real understanding. I asked questions which they didn't answer but merely went to the next line on the script.

    To be able to work you need to close or minimize any active screens behind the Parallels screen or else work in a window and not full screen.

    I also have the feeling that it has something to do with the graphics card on the Mac mini but that is just a guess.
     
  8. Techhead156

    Techhead156

    Messages:
    130
    wow.. everyone has this.. so i better do my bit. :)

    A fresh install of latest build, graphics artifacts in Vista. ok, slightly different problem, but its still video related.

    Might I add, or remind Parallels, this has always been an issue.
     
  9. Ray Tibbitts

    Ray Tibbitts Bit Poster

    Messages:
    1
    me too

    i didn't used to have this problem, but now there's black rectangles everywhere, sporadically, sometimes flickering.
     
  10. ChristopherT

    ChristopherT Bit Poster

    Messages:
    6
    I am also having issues with graphics artifacts. For example, Microsoft Sql Server Management Studio query windows when resizing the window.There are bits and pieces of what had been there before.

    I am running a Macbook Pro Core i7 15" 2010 and Windows 7 64 bit. 8GB RAM, 4GB to the VM
     
  11. Verne

    Verne Bit Poster

    Messages:
    9
    Hmmm ... I thought the problem was with my MacBook Pro 17 (Early 2010) Core i7, but maybe it's just Parallels 5.
     

Share This Page