Group Policy Client High CPU

Discussion in 'Windows Guest OS Discussion' started by lee2, Jan 27, 2020.

  1. lee2

    lee2 Bit Poster

    Messages:
    1
    I have 3 new MacBook Pro 16" laptops for my business. Each of them is running Windows 10 Pro, and part of the Windows Domain (both the Mac is added to the domain as is the Windows VM). All three are having high CPU usage, when I look at the task manager it is "Service Host: Group policy client" taking up to 100% of the CPU on all three machines. I've updated windows, I've re-run gpupdate on the windows VM's, and I've also tried some of the Parallels KB's, such as re-installing parallels tools. Nothing has made a difference to this point.
     

    Attached Files:

    HenningM1 and RandallE like this.
  2. RandallE

    RandallE Bit Poster

    Messages:
    4
    Same issue here. I've read previous threads that suggest to disable folder sharing between Mac and Windows (disable "Map Mac volumes to Windows"; disable "Share cloud folders with Windows". You will see an immediate drop in Service Host Group Policy Client CPU usage. Defeats the ability to have an integrated environment....
     
    Raymond79 likes this.
  3. shashir

    shashir Bit Poster

    Messages:
    2
    Were you able to solve this issue? I have the same issue and each time I had to kill the task.
     
  4. shashir

    shashir Bit Poster

    Messages:
    2
    @RandallE thank you, your suggestion worked.
     
  5. RandallE

    RandallE Bit Poster

    Messages:
    4
    Thanks
     
  6. ITT

    ITT

    Messages:
    1
    I have tried these suggestions but am unable to solve this issue. It completely consumes all CPU at 100% to the point where my VM is unusable.
    Any ideas on how to get this issue under control? It appeared recently and has been slowly getting worse.
    It is a domain joined VM and I am connected via IPSec VPN to my work.
    Any suggestions are appreciated.
     
  7. Raymond79

    Raymond79 Bit Poster

    Messages:
    3
    This resolved problems for me as well. Thank you.

    It may it may also be with noting that I am using a VPN like ITT.
     
    Maria@Parallels likes this.
  8. DavidB83

    DavidB83 Bit Poster

    Messages:
    1
    Like other users above, this worked for me after re-starting Parallels:
    1. Parallels configuration - "Configure"
    2. Options
    3. Sharing
    4. Share Mac
    5. Uncheck "Share cloud folders with Windows"
    6. Re-start Parallels
     
  9. AJM2

    AJM2

    Messages:
    1
    I am having the same issue with users in our company. If they log onto the VPN while in the VM, it's fine. The moment they log into the VPN on the MAC side, the VM resources are devoured. I unchecked "share cloud folders with windows" and the issue is still around. Anyone find something else out?
     
  10. RandallE

    RandallE Bit Poster

    Messages:
    4
    I would recommend running VPN software inside the VM. Keeping all apps inside the VM prevents the need to enable app sharing between the VM and the host. Doing that will cause the higher resource consumption. Parallels had not addressed this issue in any meaningful way that I am aware of.
     
  11. Raymond79

    Raymond79 Bit Poster

    Messages:
    3
    Well almost a year since the OP and problem seems to have only gotten worse. Now the only way to keep the CPU down is to check "isolate windows", defeating most of the reason I use Parallels. Looks like it's time to try other VM software again.
     
  12. RandallE

    RandallE Bit Poster

    Messages:
    4
    It's a shame that Parallels offers no helpful customer support or technical response to mitigate this issue. Completely isolating the two OS's is not a solution. Recent updates have made the issue even worse. Parallels, please post a helpful response!
     
  13. Brett_Conlon

    Brett_Conlon Bit Poster

    Messages:
    23
    Nearly another year on and this issue still here. Several months ago I had this problem and eventually found this post - thank goodness!!! After Unchecking "Share cloud folders with Windows" as described above, my problem ceased. However, in the last few weeks the Group Policy Client process has returned :(, even though this setting is still OFF. The only way I can stop the persistent process is to restart Windows, which is a real pain :mad: as I always have heaps of project windows open and need to close them all down then re-open them all back up again (adding even more wasted time). I did notice that the process seems to only re-appear right after I have joined my company's VPN (from inside Windows) so I'm now having to avoid that wherever I can, despite the business saying we should connect to the VPN daily to ensure updates are being pushed out as soon as they are available.
     

Share This Page