Has Anybody got Host Only w/Inet Sharing to Work ?!?!?!!?!....

Discussion in 'Parallels Desktop for Mac' started by Sideways, Sep 22, 2006.

  1. Sideways

    Sideways

    Messages:
    25
    Hi,
    I'm running a MacBook Pro and I have been trying (because of work issues with networking) to configure host only with internet sharing under XP SP2. I have read all the threads about this and workd through most of the advice / workarounds but it simply WILL NOT run.
    I have tried the configs and workarounds with ALL the versions of Parallels I have (which is pretty much most of them) including 1898 RC. :mad:

    I have a visible en2 under connection sharing. I have enabled personal web sharing. I have a DHCP range of 192.168.2.10 to 192.168.2.100 in the Parallels Preferences when using DHCP.All I get is a LAN icon that says limited or no connnectivity, despite numerous reboots etc and re-installing Tools each time (including the removal and re-install).

    I have also tried configuring XP with a static IP address 192.168.2.5 and then giving it a default gateway of 192.168.2.1 which is the IP address of en2, and adding in the name servers that OS/X knows about. Under this config, I get a LAN icon ok, but XP still cannot connect to the outside world. Browsers dont work and doing a simple nslookup on a web address simply reports it cant reach the DNS servers.

    I have also tried the same with a Linux 10 install and the same results.

    Both XP and Linux work fine in Bridged mode, where both are correctly assigned a different LAn address, but I cant use this in a corporate environment as the Windoze servers there take exception to it and disable both OS/X and Parallels network addresses (MAC address problem ?)

    Is there anybody with any understanding of this ? Parallels is such a great product that I really want to make this work, but it seems like getting it to work is pure chance at best.

    Thanks,

    Paul
     
    Last edited: Sep 24, 2006
  2. Sideways

    Sideways

    Messages:
    25
    A quick update to this post. By sheer chance I went into network configuration pane under system preferences and checked the port configuration. EN2 does not show in the list of port configurations. Is it supposed to and if so, anybody any iea how I add it and connect it to Parallels ?

    Thanks,

    Paul
     
  3. Sideways

    Sideways

    Messages:
    25
    Another update. I did a 'new' under the port configurations dialog of system preferences and the EN2 adaptor was in the list of available ports. I added this in and rebooted both OS/X and XP. Now when XP boots with Parallels DHCP, it gets allocated a network address. However, when I ping the en2 IP address from XP, it fails. Similarly pinging the XP IP address from OS/X fails. I tried resetting the DNS servers to match OS/X again but this didnt solve the problem.

    Grrrrrrrrrrr!!!!!!!!
     
  4. darkone

    darkone

    Messages:
    804
    no.. My machine does not show EN2 under Network port configurations in the Sysyprefs.

    I know youve probably explained it so far, but satisfy my curiosity, in OSX, open a Terminal window and paste here the output from

    ifconfig -a

    paste the whole lot here.

    also, do an ipconfig /all
    in windows XP and paste that here too..
     
  5. Fred

    Fred

    Messages:
    11
    Firewall issues with internet sharing

    Your problems with network access sound like firewall issues. A quick test may be to disable the firewall and see if it all starts working.

    If you have turned on any of the advanced options for the firewall, eg disabling UDP or stealth mode, then a lot of basic traffic may be getting dropped, such as ping, dhcp, dns. The builtin in firewall configuration gui does not discriminate between network interfaces so you cannot tell it to let traffic from the parallels network out unless the same kind of traffic can attack your Mac from the internet.

    To get basic network access for XP whilst running the firewall you need to open tcp port 3128 for windows update and enable personal web sharing fo web browsing. You also need to allow UDP traffic through to allow dhcp, dns, etc to work. If you want to block UDP traffic you will need to work out which udp ports are really required for dns, dhcp,...
     
    Last edited: Sep 22, 2006
  6. murphy

    murphy

    Messages:
    64
    If you have a router and it is assigning IP addresses in the 192.168.2.x range it will not work.
    Change the DHCP server in your router to issue IP addresses in some other subnet. I chose to use 192.168.5.x. Has worked solid for me since I did that. Host networking is using 192.168.2.x which makes it impossible to route the packets to your router because it is actually a different subnet.
     
  7. joem

    joem

    Messages:
    1,247
    The Mac OS firewall does indeed discriminate among interfaces if asked. In terminal, type man ipfw and read away. The Mac GUI won't access all the firewall features, but the firewall itself is quite sophisticated.
     
  8. MatthewR

    MatthewR

    Messages:
    45
    Turn on personal web sharing is a terrible 'solution', and I wish people would stop suggesting it. It only gets web traffic going, and only because it opens port 80 in order to allow connections to the web server you are now running. You most likely don't need to be running a web server and probably don't want to be sharing out whatever stuff the default configuration may give access to.

    There is a much better solution. In terminal, run "sudo ipfw add 2000 allow ip from any to any via en2" and supply your password when prompted. This just tells the firewall to allow all traffic for that interface, allowing full flow to/from the VM and leaving tye VM to fend for itself.
     
  9. Sideways

    Sideways

    Messages:
    25
    Thanks for all comments thus far. I've been away a day travelling, but back to the problem this evening and more news. I blew away the OS/X install totally, and re-installed and updated OS/X first. Then installed 1848 as a base, configured host only as per recommendations. Rebooted, installed 1910 over the top, rebooted, installed Tools and......no joy. :mad:
    I cant even ping the en2 interface address of 192.168.2.1 from XP. Incidentally, Paralels DHCP is still set to the default range in the 10.37 range, but the IP address allocated to XP is 192.168.2.3 ?
    HOW is Parallels doing that ? and why ?. For information, I have tried all configs with firewalls disabled. Result of ifconfig as requested are below .....

    Thanks,

    Paul

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::216:cbff:fe89:e36e%en0 prefixlen 64 scopeid 0x4
    inet 192.168.1.15 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:17:cb:54:a3:6f
    media: autoselect (1000baseT <full-duplex,flow-control>) status: active
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:18:ca:08:3d:cf
    media: autoselect (<unknown type>) status: inactive
    supported media: autoselect
    wlt1: flags=41<UP,RUNNING> mtu 1500
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:16:cb:ff:fe:4d:11:30
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::201:23ff:fe45:6789%en2 prefixlen 64 scopeid 0x8
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    ether 00:01:23:45:67:89
    media: autoselect status: active
    supported media: autoselect
     
  10. Sideways

    Sideways

    Messages:
    25
    Solved :)

    Ok,
    to close out the thread, I can report I now have both XP and SuSE Linux (10) working quite happily via Host Only Networking :D
    Final steps to solve:
    1. Backed up OS/X and re-installed completely.
    2. Installed 1848 build and configured host only.
    3. Upgraded to 1910 build and the XP install would still not work. The SuSE install started working at this point via Host Only.
    4. Did a complete re-instal of XP to a new virtual machine :(
    5. Changed the default Parallels DHCP range from 10.37.129.x to 192.168.2.5 - 255 (which is how the original Parallels set up I had was configured....)
    6. At this point XP started working with host only !

    So, a lot of work to resolve, but along the way I noticed some things I believe are incorrect in the Parallels build and would be glad of someone could comment:

    1. The default DHCP range of 10.37.1229.x as an installation default is completely bogus. As OS/X only ever configures EN2 to work in the 192.168.2.1 address, 10.37.whatever will never work. I believe this should be changed
    2. When Parallels un-installs it does not clean up correctly. It leaves network adaptor configs in a number of files in /Library Preferences/System Configuration/... which are then used as a startup configuration by OS/X. They do not get removed, even by a reboot.

    I dont think the fix is elegant and I would be pleased to hear from anyone who has better work arounds that save the work I had to do, but it does sort the problem....

    Paul
     
  11. darkone

    darkone

    Messages:
    804
    on my machine, it adds the 192 address to the interface rather than replacing the original 10.37 address. So I have my XP still have the 10.37 dhcp address and I ignore the 192. addresses completely.
     
  12. jdunn

    jdunn

    Messages:
    2
    GUI Solution

    I have gotten the Internet sharing to work using the following formula. Turn Internet sharing on using the built-in ethernet with the ethernet adapter (en2). Be sure to set your virtual os to host adapter only. You will have a conflict error at the bottom of this page.

    To keep the OS X firewall running. Create a new port. For port name choose other. For TCP prot numbers choose the following without quotes "25, 80, 110, 443, 445, 3306, 3389, 9100". This will give you access to email (pop3), web (http and https), smb shares, ip printing, mysql, and windows remote desktop. I do not have any UDP ports defined. For description I put Parallels.

    I am still having issues with ftp access using this method. I have also discovered, if you are using the internet sharing and try to upgrade Parallels, you will loose the Parallels Ethernet adapter. This will require you to uninstall Parallels, disable the sharing, and do a new install of Parallels to get the adapter back. This can be prevented by turning the internet sharing off before upgrading.
     
    Last edited: Oct 5, 2006
  13. donnie

    donnie

    Messages:
    28
    I found that rebooting immediately after a Parallels upgrade restores the Parallels adapter.
     

Share This Page