HASP driver on M1 Max Macbook w/Parallels Windows 11

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by ARGAS, Dec 1, 2021.

  1. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    722
    With Parallels 17.1.1, an option for a direct download from Microsoft was introduced when you create a new VM. That should install the retail/OEM version.
    If that doesn't work you can build an iso using uupdump.net. Look at the pinned threads in this forum for a detailed instruction.
     
  2. horaciof

    horaciof

    Messages:
    1
    Hi, from the posts I've read, we are not alone (Mac Silicone with Win 11 ARM, and no Sentinel HASP Driver), but I guess we are still not enough to get's (Thales/Sentinel) attention. I suggest that we all create a case at Thale's support site asking for the same, and hopefully later this year they can release a Driver for Win ARM. Good luck!!
     
  3. JosephS14

    JosephS14 Bit Poster

    Messages:
    2
    I am also searching for a solution for this. I contacted the software company (Hexagon) that my hasp is from, they helped me as far along the process until the licensing driver issue. Then they just stated they don't support ARM.
     
  4. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    722
    Unfortunately there's nothing you can do then. Drivers can't be emulated by Windows, so until the software company provides an ARM driver or Microsoft adds a generic driver that works, you're out of luck.
     
  5. JosephS14

    JosephS14 Bit Poster

    Messages:
    2

    Did you fail to read the rest of the thread? The issue is not my software provider, nor Microsoft. It's Thales/Sentinel. The same as everyone else here...
     
  6. VincentB8

    VincentB8 Bit Poster

    Messages:
    5
    I made it work with sentinel hasp dongle. (In use with WinDev application)
    You have to install dongle drivers on MacOS. You must AVOID to redirect USB to the Windows VM.
    Then on the windows execute this command line with administrator rights :
    netsh interface portproxy add v4tov4 listenaddress=localhost listenport=1947 connectaddress=YourMacHostName.lan connectport=1947
     
  7. VincentB8

    VincentB8 Bit Poster

    Messages:
    5
    The application (WinDev in this case) quit after ±10m. I'm looking to find why and if it's possible to fix that.
     
  8. Horacio

    Horacio Bit Poster

    Messages:
    2
    Hi VincentB8, this sounds very encouraging. Which version of drivers did you installed on the Mac end? Port 1947 is specific for Windev or it's for all the hasps?
    Thanks for your advice
     
  9. VincentB8

    VincentB8 Bit Poster

    Messages:
    5
    Version 8.31. The last one that support Hasp devices. Port 1947 is the default port of the Sentinel LDK.
    When drivers are installed, you can access the administration webpage via http://localhost:1947
    In the configuration tab, you can activate logs and consult them in access logs tab.
     
  10. MichelA5

    MichelA5 Bit Poster

    Messages:
    2
    Hello Vincent,
    I presume you are French as you use Windev ;-)
    I just invested in a Mac M1 and I'm confronted with the same problems with the Windev dongle.
    Did you manage to make Windev work correctly?
    Did you try with the new Mac OS 8.43 drivers?
    Thanks in advance
    Michel
     
  11. Andreasm24

    Andreasm24 Bit Poster

    Messages:
    1
    Hi!
    I tried this procedure from Vincent with 8.43 drivers.
    Installed Sentinel drivers for Mac.
    I can see the HASP Key is active and working on Mac.
    Installed Windev on Win11.
    Ran this command with admin rights: netsh interface portproxy add v4tov4 listenaddress=localhost listenport=1947 connectaddress=YourMacHostName.lan connectport=1947
    But it did not work for me. Faro Scene is not working ;-(
    Let us know if somebody found a solution.
    thanks!
     
  12. VincentB8

    VincentB8 Bit Poster

    Messages:
    5
    You must replace "YourMacHostName.lan" with you real Mac Host Name ;)
     
  13. MichelA5

    MichelA5 Bit Poster

    Messages:
    2
    Hi,
    I installed the 8.43 drivers and I did the manipulation suggested by Vincent and I have the same result, Windev crashes after about 10 minutes.
    @VincentB8 : did you find a solution for this crash ?
    Thanks
     
  14. VincentB8

    VincentB8 Bit Poster

    Messages:
    5
    Hi, I'm not able to go further... I hope someone will find a solution or Thales to develop an ARM driver for Windows.
     
  15. ZoranS3

    ZoranS3 Bit Poster

    Messages:
    2
    I have 2 hasp/sentinel devices. I tried as VincentB8 said. One sentinel device is working on windows 11/parallels 17 M1 without any problem. Second one is not even visible in Mac OS. On intel mac both work normaly. Any sugesstion what else to try? I see that there 8.4 release for windows but I cant find file to download.
     
  16. MDS87

    MDS87 Bit Poster

    Messages:
    3
    As this seems to be something that Sentinel/Thales needs to help with, is it safe to say upgrading to the latest version of Parallels will do nothing for us?
     
  17. ZoranS3

    ZoranS3 Bit Poster

    Messages:
    2
    Exactly. I upgraded to version 18 and nothing.
     

Share This Page