Help with "No usable default provider could be found for your system."

Discussion in 'Parallels Provider for Vagrant' started by RickS15, Jul 1, 2024.

  1. RickS15

    RickS15 Bit poster

    I'm running:
    • Parallel Desktop 19
    • MacOS 14.4.1
    • MBP M2
    I had installed Vagrant and got a succesful set up of a CentOS9 and Ubuntu 22.04 boxes. They were running great! I could get them to come up and connect, suspend them, etc.

    I started this because, for a project at work, one of the developers wants to switch from a docker development environment to a Vagrant development environment. After checking out the repo and trying to bring up the development machine (based on centos9), I'm not getting the error that parallels won't work as a provider and I need a valid provider (VirtualBox, VMWare, Hyper-V). Parallels isn't even listed as a provider?

    Specifying --provider=parallels doesn't help.

    The Vagrantfile for the repo has = "generic/centos9s" where I pulled my original ones from bento.

    The strange thing here is that I can no longer run my original Vagrant boxes and get the same error. How do I get by this? I've checked the metadata.json for the original boxes and they say "parallels".

    Very confused....
  2. RickS15

    RickS15 Bit poster

    Found the solution for my problem. When I ran the project from work, it tried to use docker and, somehow, the parallels plugin got removed. Reinstalled that and I'm back running.

Share This Page