High CPU in build 3188

Discussion in 'Parallels Desktop for Mac' started by markaddleman, Mar 25, 2007.

  1. markaddleman

    markaddleman

    Messages:
    3
    I've read a few threads regarding high CPU in previous builds. It's unclear to me whether it's been resolved in build 3188, but I'm definitely experiencing it. According to top, Parallels consumes no less than 50% CPU and often as high as 100%+.

    I've tried turning off Windows Sharing but to no avail. Any suggestions?
     
  2. waterhead37

    waterhead37 Bit Poster

    Messages:
    22
    Check to be sure that Windows is not in the middle of downloading some update or other - there seem to be quite a few at the moment. Ditto any Anti virus software. Many times AV software and anti-spyware stuff start scanning the disk as soon as the VM is booted and that can take ages depending on the size of your VM.

    You could also turn off indexing. In XP and prior builds it is pretty useless anyway.
     
  3. ricardo

    ricardo

    Messages:
    23


    Are you using Skype, by any chance? I've found that sends my CPU usage from 20% to 60%, even if Windows is only using about 1% CPU. Do you have USB enabled? Some people have reported that can cause serious processor usage increase.
     
  4. markaddleman

    markaddleman

    Messages:
    3
    I should have mentioned that the Windows Task Manager reports near zero CPU usage. This leads me to believe the CPU consumption is coming from Parallels itself.
     
  5. markaddleman

    markaddleman

    Messages:
    3
    No Skype. I pretty much only use Parallels for Yahoo Messenger and Yahoo Music. I've tried turning both of those off. That doesn't solve the problem.

    I also tried disabling USB support, but no dice with that, either.

    It's very typical for the Windows Task Manager to report 90%+ idle, but top shows Parallels using 50%+ cpu. Very odd...
     
  6. David5000

    David5000

    Messages:
    312
    By indexing, do you mean something in Windows? Where do you turn it off? (I'm using XP Pro.)

    Also, could you explain a little more why it is useless?

    Thank you,

    David
     
  7. ricardo

    ricardo

    Messages:
    23
    Something else you may want to try is avoiding Coherence, if you're using it, and disabling support altogether.


    I believe you - you'll find plenty of similar stories here on the forums. Everybody has a difference cause, but it seems USB is one of the most common suspects. Also, for those that manage to fix the problem, real CPU usage drops to a "mere" 15-20% when windows is 97%+ idle. I haven't managed to get it under 40% when using a Linux virtual os.
     
  8. Constable_Odo1

    Constable_Odo1

    Messages:
    37
    I'm using a MacBook Pro 2.33 C2D, 10.4.9 and Parallels 3188 running Windows XP Pro. Windows XP idles using from 13 to 18 percent of the processors. When Internet Explorer is running the processors bounce around 18 to 30 percent depending upon the amount of Flash graphics displayed on the page. This is when Parallels is running Full Screen view.

    When I quit Parallels the MBP processors run at 1 percent (all based on MenuMeters reading).
     
  9. angelday

    angelday

    Messages:
    11
    Hi,

    I'm running 3188 on a MBP. I don't have USB of any kind turned on. I'm experiencing this behaviour only when I drag and drop an Excel file from my Mac desktop into Excel directly. I could work this around by dragging the file first to the XP desktop, then open - save and move the file back, but it would have been such an annoyance.

    On the next occurence, I will file a report.
     
  10. ricardo

    ricardo

    Messages:
    23
    On another thread, someone reported that Coherence made significantly increased processor usage. Is this a Coherence feature?
     
  11. angelday

    angelday

    Messages:
    11
    No, I have never used coherence.
     
  12. Parabola

    Parabola

    Messages:
    17
    MActivity Monitor shows CPU at about 80-130% for Parallels (3188), but it subsides after "applying computer settings" (corp Win client mgmt) completes at login window. Windows Task Mgr jumps up around now and then, but it's not high for too loing.

    I have no Skype, but have USB & Coherence enabled and use Symantec AV Corp Ed.

    MBP 2.16 GHz/2GB (768MB for VM)/100GB 7200 RPM (20GB for VM)/10.4.9
     
    Last edited: Apr 2, 2007
  13. rhind

    rhind

    Messages:
    84
    Low usage for me.

    On both a 2.33GHz iMac C2D and 2.33GHz MacBook Pro C2D, my XP installation idles at 7-8% on both. It was more like 15-18% before I disabled sound so that uses quite a bit.

    I don't use any USB devices on it, and only tend to run Visual Studio 2005 and sometimes firefox/IE.

    Cheers

    Russell
     

Share This Page