High CPU usage on disk access since update to Mojave 10.14.4 ?

Discussion in 'Windows Virtual Machine' started by PatrickC11, Mar 27, 2019.

  1. ArtistW

    ArtistW Member

    The same here since the update to Parallels 14 and MacOS Sierra - iMac, MacOS Sierra, 3.1 GHz, 16 GB RAM, Fusion Drive.
    Windows 10 starts between 6 and 9 minutes.
    Windows user interface very very slow
    Hello ArtistW, this issue has already escalated to the Tier 2 team and our development team is still investigating this issue internally.
    That is now 6 months ago and until today no solution

    My only "bad" solution: I have now a Samsung SSD 500 GB increased, Windows.pvm copied to it and see there Windows starts in 22 sec and the entire Windows system environment runs so much better. But that can not be the solution and I want to control everything from the internal hard drive. But the error is definitely not on the installed Windows system.
  2. ChristianW8

    ChristianW8 Member

    I have the problem with the pro_disp_service at 100% already since 2 months (Mojave, 10.14.4, beta program) and I told Parallels Team about this problem but it seems that they are not able to fix it or they do not take it so serious. I wrote many complains and asked the status but they did not come back to me.
    Regarding this problem I can tell many things about it since I need to work and live every day with this problem. I have a Macbook Pro and Parallels 14.1.3 and my guest is Suse Linux and Windows and Centos. The problem with the high CPU usage happens in all of them.
    If you need to work for some time in a virtual machine and just want to get rid of the high CPU usage, then do the following on the MAC (inside a terminal):

    ps -faxvac|grep prl_disp_service

    This will show you a line like:
    0 65043 1 0 Sun10AM ?? 463:38.25 prl_disp_service S 0 0 0 4800928 31344 - 0 0.0 0.2

    The second number in this line (65043) is the job number of this program. Now you can stop the program for a while:

    sudo kill -SIGSTOP 65043

    Now you have to enter your root password from the MAC.

    After the job has been stopped (not killed), you can work with high speed since the CPU usage goes to 0%.
    If you need to
    a) make a snapshot
    b) power off or restart the virtual machine
    then you need to "wake up" the program with the following command:

    sudo kill -SIGCONT 65043

    The CPU usage will go up to 100% again.

    Please be aware, that the above commands need to be executed carefully. Any mistyping can cause the job to be killed and then you need to restart the Parallels VM
    (only this can happen, nothing worse).
  3. ChristianW8

    ChristianW8 Member

    Hi, here's a little update. I tried the suggestions and activated Apple Hypervisor but it does not help (in my case). While the system starts "friendly" after a reboot and the pro_disp_service is a 0%, right after plugging an USB device into the Computer (and selecting it in the VM), the prl_disp_service goes up to 100% (5 minutes already) and the device is still not attached to the VM.
  4. MarcelloR

    MarcelloR Member

    Same problem here. PDesktop Business 14.1.2 (45479), Windows 10 1709, Macbook Pro 2,9 GHz Intel Core i9, 32 Gb DDR4, Radeon Pro 560X 4 GB + Intel UHD Graphics 630 1536 MB.
    Everything was going well until this morning, when I confirmed the installation of macOS Mojave 10.14.4.
    After rebooting the Mac, my VM runs slowly: this applies to both the processes and the display.
    Alle the animations of the windows are extremely slow (even when minimizing a window and then restoring it).

    Switching to Apple's hypervisor and turning off adaptive hypervisor seems to help in my case. The performances are still far if compared with the previous state (macOS 10.14.3 and Parallels Hypervisor), but the VM is running in a workable way.
    Last edited: Apr 3, 2019
  5. AlekseyM2

    AlekseyM2 Member

    I also have the same issue. Just as I updated to Mojave 10.14.4, I noticed that Windows 10 in Parallels performance became noticeably slower. I just found out about the Hypervisor setting, but I did not change it - it is Parallels as before. Either I got used to slower performance or it improved, but now it is not as noticeable.
  6. IanA4

    IanA4 Bit poster

    Same issue, iMac Pro, Windows 10 Pro 1809 VM. Very slow VM disk access after macOS 10.14.14 update and high CPU activity.
  7. ChristianW8

    ChristianW8 Member

    Ok, some more update from me.
    I switched to Apple Hypervisor and yes, it helps a lot. The prl_disp_service is almost always at around 0% and the machine behaves ok. Only when I plug in an USB or make a snapshot then the service comes up for a long time with a lot of CPU usage which was not the case in older versions.
  8. HallS

    HallS Junior Member

    I'm not 100% certain that this is directly a Parallels issue after all. Yes, something in the 10.14.4 update changed something and hopefully Parallels can "deal with it" but I have shutdown Parallels entirely and still see high CPU usage (and increased fan speeds and heat) with my iMac. If Parallels/Windows isn't running, some other process, frequently Chrome, sometimes Thunderbird, takes the place of Windows 10 in the Activity Monitor.
  9. Julian1

    Julian1 Junior Member

    I also have an issue like this. The windows 10 VM is starting very slowly. When I reboot the machine (but not closing it) that goes really fast. But the startup and shutdown times are extremely long. The VM is located on an external SSD (Samsung T5).

    I noticed that adding an external drive to the VM takes very long. The name is visible in the menu and when I click on mount nothing happens for some minutes. Then, after a while, the drive is there and the message to unlock it (it uses bitlocker) pops up. (OSX has no write permission on that drive so I doubt it is a drive checking issue.)

    It seems to me something is wrong with the disc mounting system since the latest OS upgrade. I hope this can be fixed.
  10. Drew3

    Drew3 Bit poster

    I can also confirm that switching to Apple's hypervisor dramatically improves the issue.

    My question is, how does something like this slip though the cracks? Does Parallels not have a decent QA/testing system in place? I've been using it for years and this isn't the first time something like this has happened. A lot of people like myself rely on Parallels to get their work done. If I hadn't found this thread, I would have lost many more hours than I already have in terms of productivity.
  11. Same issue - Parallels is slow, very slow with Bridge/Photoshop on iMac 2017 with last Mojave version - And under Photoshop it work with a generic graphic card instead my Radeon, so it doesn't work properly with all tools - I lost 79€...
  12. KendallB

    KendallB Member

    Changing to Apple Hypervisor fixed it for me. Last time I tried the apple one it was slower, but this is at least getting me back to work ...
    SopDa likes this.
  13. AlexanderZ7

    AlexanderZ7 Bit poster

    How to switch to Apple Hypervisor on Parallels 14.1.3?

  14. HallS

    HallS Junior Member

    First, shut down Windows. Then, click "Hardware" across the top row, then "CPU and Memory", then "Advanced".
  15. @KendalB
    Thanks for your reply,
    I disabled "Adaptive hypervisor" and used the Apple hypervisor and that seems to have helped just a little (speed) but :
    - I can't read raw files under Photoshop (CS6) : they're not loaded since CameraRaw (It worked before Mojave 10.14.4 !!)
    - the touch ALT/Option don't work anymore (It worked before Mojave 10.14.4 !!)
    and I have not discover all, I think.
  16. KendallB

    KendallB Member

    It's under the CPU section.

    Attached Files:

  17. DominikE1

    DominikE1 Bit poster

    I have the same issue. I saw as more CPUs you give the VM the higher the usage on the host goes. 4 CPU -> Maximum of 400% - 2 CPU -> Maximum of 200%.
    I guess there is an issue with the fan and maybe the temperature as well. But I think it don't gets hot the fan just rotates as it would be hot, but it won't.
    On the guest machine a usage of 25% of 4 CPUs resulting in a usage of 100% on the host and that's the problem in my opinion.
  18. DennisH5

    DennisH5 Bit poster

    It would be nice if we could get some feedback from from Parallels that either:

    1) They are aware of the issues with P14 and Mojave 10.14.4 and working on fixing
    2) They still believe we're at blame, and will not look in to this any further.
    IanA4 and IgorP2 like this.
  19. Do like me : uninstall Parallels - no more issues !
  20. HallS

    HallS Junior Member

    I'm going to pay attention today but this seems to have stopped happening for me. I've changed nothing. Anyone else seeing the same ? I wonder if Apple silently did a minor update ? As I mentioned earlier in this thread, I believe it's an Apple issue, not a Parallels one. Different apps are affected so maybe Parallels can change something on their side to resolve it but I was seeing the excessive CPU activity, cooling fans running full speed (loud), and so on with Parallels shut down.

Share This Page