How can I get linux audio to work on ARM?

Discussion in 'General Questions' started by RudolfP, Dec 17, 2020.

Tags:
  1. RudolfP

    RudolfP Bit Poster

    Messages:
    2
    Following the other posts in this forum I have working ubuntu and debian installations on M1 ARM mac but I get no audio output. Any suggestions on how to address this? Does this depend on updated parallels tools to support the virtual audio hardware?
     
    cralo likes this.
  2. RudolfP

    RudolfP Bit Poster

    Messages:
    2
    To clarify: The linux virtual machines are running and have working graphical desktops. However, the virtual machines do not detect any audio hardware as a result of which there is no audio passthrough to the host. How would audio setup normally work? Would the audio drivers be installed as part of the parallels tools (which don't exist for ARM yet) or is this a limitation in the ARM versions of linux?
     
    cralo likes this.
  3. cralo

    cralo Bit Poster

    Messages:
    1
    I haven't had any luck with audio either, no soundcard is found, so neither mic nor speaker are working
     
  4. LkwdBrian

    LkwdBrian Bit Poster

    Messages:
    4
    That's my experience as well. I'm guessing that no linux audio drivers exist for the emulated sound hardware. It would be nice to get confirmation from the developer whether this is something that's coming or if this is not on the roadmap.
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hello,
    this feature has been implemented in the newest Parallels Desktop 17 version.
    Linux users can now enjoy multichannel sound support and jack presence detection with native drivers.
    Please check this link for more information.
     
  6. MarkByrn

    MarkByrn Bit Poster

    Messages:
    22
    I still have no sound with Ubuntu. Any specific instructions for Parallels 17 to get sound to work besides the obvious?
     
  7. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    183
  8. MarkByrn

    MarkByrn Bit Poster

    Messages:
    22
    That solution is only for Windows VM; I'm using Linux Ubuntu.
     
  9. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Hi
    Audio in Linux should work in Parallels 17 out of the box. Make sure that VM has Sound device in configuration and please send the problem report (menu Help -> Send technical data) if it doesn't. Post here the report number.
     

Share This Page