How to boot from IDE1:0 when no IDE0:0 HD?

Discussion in 'Installation and Configuration' started by nedkonz, Sep 8, 2007.

  1. nedkonz

    nedkonz Bit Poster

    Messages:
    6
    I have Parallels 2.5 (build 3214).

    I am trying to duplicate the configuration of an embedded computer that I've set up for a client. It`s got a BIOS that allows the choice of which HD to boot from. The (only) HD (actually, a CF card) on this machine is set up as the master on the second IDE channel and cannot be moved. So I've set up the (only) hard drive in Parallels on IDE1:0. However, since there is no IDE0:0 drive, when no CD is installed the BIOS won`t try to boot from IDE1:0. Is there some way to get the BIOS to boot from IDE1:0?

    The boot order setting in the VM editor only refers to 'hard drive', and I can't see a way to get into the BIOS for settings.

    I don't want to move the drive in Parallels to IDE0:0 because the guest operating system (a small Linux distro with a 2.4 kernel and GRUB bootloader) is set up to work with IDE1:0. Since I'm writing backup scripts that are sensitive to drive setup, it wouldn't work to move the drive.

    Is there some way that I can change the settings to allow booting from IDE1:0?
     
  2. sandro

    sandro Parallels Developers

    Messages:
    512
    hi,
    i'm afraid you'll can't to boot from 1:0 IDE due 2.x Parallels BIOS doesn't support boot from non first IDE controller. But what about follow solution: create at VM a small harddisk (as small as possible) where you can install OS loader which will be redirect OS loading process to your 1:0 IDE harddisk.
     
  3. nedkonz

    nedkonz Bit Poster

    Messages:
    6
    Still no joy: IDE1:0 not available to GRUB

    Well, I have build 5160 now, and I still can't get access to IDE1:0 to allow booting from a partition on that drive at boot time, even using the suggested method of setting up a helper drive partition on IDE0:0.

    I've set up a small HD on IDE0:0 with GRUB installed to use to boot a partition in the larger hard drive.

    When the larger hard drive is set up on IDE1:0, GRUB can't see it. When it's set up on IDE0:1, GRUB can see it.

    I have also tried this with a GRUB floppy with the same results.

    It seems as if hard drives on IDE1 aren't available to GRUB at boot time. When I boot from Linux on IDE0:0 I can see hard drives on IDE1:0 (after Linux starts).

    Is there some kind of initialization or driver that is missing here?
     

Share This Page