How to customize Full-Screen-Toggle keyboard shortcut?

Discussion in 'Installation and Configuration' started by andymcd, Sep 21, 2011.

  1. andymcd

    andymcd

    Messages:
    2
    Ctrl-Cmd-F is something I use a lot in my Linux Guest app (Emacs).

    Of the 5 "Parallels Desktop Shortcuts" 4 can be configured by double-clicking the row but not the Full-Screen-Toggle shortcut. Is there a way I can work around this because every time I hit this keyboard shortcut in Emacs (a lot!) it (obviously) toggles in and out of full screen which has now become a tad irritating...

    Thanks.
     
  2. andymcd

    andymcd

    Messages:
    2
    Ping!

    Anybody from Parallels know if this is possible...

    thanks.
     
  3. Dancoiv

    Dancoiv Bit Poster

    Messages:
    12
    I was hoping you would get a reply too. When I ran Parallels 6, I was able to change my Full Screen Toggle to be Command - Return, because ti was so much esier then hitting Ctrl - Cmd - F. For some reason, I can't get it to work with Parallels 7 anymore. I'm hoping someone has an idea how to get Full Screen Toggle to work with fewer keys again!
     
  4. JamesMc

    JamesMc Bit Poster

    Messages:
    8
    One more vote

    ping!
    I also find this astoundingly annoying. Why is that the only setting that can't be customized???
     
  5. Harry Binswanger

    Harry Binswanger

    Messages:
    37
    I suggest using AutoHotkey (a wonderful macro pgm, which works by rational scripts not aggravating GUIs). That will work if you're in the Windows virtual machine. I'm going to program it for myself now, I'll come back and report on that.
     
  6. JamesMc

    JamesMc Bit Poster

    Messages:
    8
    AutoHotKey is indeed an excellent utility.
    However, it can't possibly solve this problem. A utility inside the Windows VM cannot have an effect on Parallels program running outside the VM. (At least, not easily; I suppose anything is possible with enough monkeying around.)
     
  7. Harry Binswanger

    Harry Binswanger

    Messages:
    37
    I think you are right--so far I've been unable to get it to do what manually hitting Winkey^f does. But I'll post to the AHK forum.
     
  8. YanaYana

    YanaYana

    Messages:
    1,666
    Hi guys,

    I actually tried to change the shortcut in System preferences and here is what i've got:

    [​IMG]

    and it results to change in here:

    [​IMG]

    Maybe you may try this solution
     
  9. JamesMc

    JamesMc Bit Poster

    Messages:
    8
    Does this actually work for you?
    I can (and have) done essentially what you describe. Although the defined key shortcuts appear in the Parallels menus (as you show), I can't get Parallels to actually execute any menu commands that way. I've tried many variations of key combinations, but the Parallels always just passes the key strokes through to the VM.
     
  10. YanaYana

    YanaYana

    Messages:
    1,666
    Hm you are absolutely right.. actually i've found out this issue has been already reported to development team and they are working on the fix. So this is matter of time.
     
  11. AlekseyM

    AlekseyM Product Expert

    Messages:
    210
    I really hope this gets fixed. So annoying. I can't stand it!!
     
  12. Harry Binswanger

    Harry Binswanger

    Messages:
    37
    You said it. Why should putting the Mac to sleep change things at all upon waking it up?
     

Share This Page