How to recover files from VM Windows 11 - (expired winloader.efi)

Discussion in 'Windows Virtual Machine' started by JorgenS1, Feb 16, 2024.

  1. JorgenS1

    JorgenS1 Bit poster

    Hi all!

    I'm in a bit of a pickle here, and need urgent assistance. Really hope you guys have some good advice, greatly appreciated!

    Macbook Pro M1
    Running Parallels 18
    Windows 11 Insider Preview (only thing that worked three years ago)

    The issue:
    Windows updates kept giving me blue-screen errors after updating, so I paused updates for a while. Unfortunately, this has resulted in the Windows booting in Recovery mode with the following message:

    "A component of the operating system has expired

    Error code: 0xc0000605"

    You'll need to use recovery tools. If you don't have any installation media etc.."

    This, as I've learned, can happen if you don't update your Windows build. Now, I've tried to scour the internet for help, and I've found several suggestions, but nothing has brought me past the "blue screen of recovery."

    What I've tried:
    - Bootable USB-stick. So far, been unable to boot from the USB in Parallels, even if I've changed boot order in Parallels, UEFI etc. Not sure why this doesn't work(?).
    - Changed the date of my Mac to 6 months back to see if the Windows BIOS would backtrack as well and appear as "not expired" (Not successful)
    - Boot Parallels Mounter to access files without turning on the VM. Can't get the Mounter to work, not sure why.

    What I need help with:
    All I really need is to access one folder so I can copy and download this to my Mac and my new VM. Don't care about the settings or software, only one folder with a bunch of folders/files.

    - Is there an easy way to access the files or folders without starting the VM?
    - Can I reinstall Windows over my expired version, yet keep the existing files in Parallels?
    - Other suggestions?

    Attached Files:

  2. JorgenS1

    JorgenS1 Bit poster

    Managed to mount the HDD to another VM and got access to my files this way.

    Issue has been RESOLVED. Thread can be deleted.
  3. DK_2

    DK_2 Bit poster

    Hello, I have same problem now. And I need my emergency data immediately.
    Could you please explain in detail how the problem was solved? That is so important for us.
  4. JorgenS1

    JorgenS1 Bit poster

    Here's a step-by-step on how I worked around it:

    1. Create a second Virtual Machine
    2. Install Windows 11 (or same windows version as you used)
    3. In the second VM, go to Configure - Hardware, and at the bottom, there's a +- sign. Add the harddrive from your first virtual machine
    4. When you boot up your second VM, you should then have access to all the files from your first VM.

    Also see this guide if you're stuck.

    Let me know if anything is unclear here.
  5. DK_2

    DK_2 Bit poster

    Thank you so much. Problem solved.
  6. FrancoisP4


    Help! I am having the same problem (trying to recover files from a Windows 11 VM that won't start anymore), followed the KB article instructions, but the new hard drive image only shows a Windows 11.hdd folder on the left and is not accessible.

    What to do?

Share This Page