How to: Resolve trouble between Parallels and Windows under Boot Camp

Discussion in 'Windows Virtual Machine' started by bulletproof, Sep 8, 2007.

  1. jimcoyle

    jimcoyle Hunter

    Strangely, the problem seemed to clear up on its own. Thanks for your attention, though.
  2. Yeolegood

    Yeolegood Member

    In case Windows requires activation under Boot Camp, please follow these steps:

    Make sure that your Paralles Desktop build is up to date.
    Open Boot Camp VM Configuration
    Open Hard Disk 1 (Boot Camp)
    Choose the 'Advanced' tab
    Choose 'Clear' option
    Restart the MAC
  3. PieroF

    PieroF Bit poster

    My Solution to multiple Activation WXP requests

    Let me add my Solution to the multiple Activation requests by Windows XP when Parallels runs the Boot Camp partition.

    I don't know if my solution is general enough for the many cases I read about; anyhow, using the suggestions I read in various forums (including this very good post) I could activate WXP a second time without needing a new product key.

    Situation: I installed Boot Camp on a brand new Macbook with Leopard, installed a new Windows XP Professional license (BTW: bundled with Parallels), I activated that license via Internet: no problem, everything worked as expected.

    Problem: I installed Parallels 3.0 and created a Virtual Machine using the Boot Camp partition: immediately a new Activation request appeared for WXP while Parallels was installing Parallels Tools.
    The real problem is that when I tried to Activate via Internet this second time, I got the message that I needed a new product key for WXP because of "Significant Hardware Changes".

    My solution: I simply changed the MAC address used by the (virtual) en0 Network Adapter in Parallels to match exactly the MAC address of the physical network adapter in the Macbook.
    1. read the MAC address: from System Preferences/Ethernet/Ethernet (Tiger) or from System Preferences/Ethernet/Advanced/Ethernet (Leopard); or you can issue ipconfig /all in the DOS command prompt of WXP when active in Boot Camp (ignore MAC addresses that are not for Ethernet LAN).
    2. write that MAC address into Configuration/Network Adapter/Advanced in Paralles for the en0 network
    3. restart the same VM requiring activation (note: you do not need to create a new VM!): the Activation request appears again for WXP, but this time when you try the activation on Internet, this is accepted and no new product key is requested! (no "Significant Hardware Changes" this time).

    For sure the Activation system for WXP checks the main LAN MAC address to determine whether there is a Significant Hardware Change; I'm pretty sure however that this is not the only check. But for cases similar to mine, where the only problem is using the same WXP installation, on the same hardware, but switching between Boot Camp and Parallels, this solution works.


    Note: I still have a problem, but I think it is not related with the activation of WXP: the very first time I started the Parallels VM I tried to immediately activate WXP (without success) and I somehow corrupted the Parallels Tools installation process. Now whenever I run that VM (even after the proper activation of WXP) the message "... wait for Parallels tools installation to complete ..." or similar appears during the system boot, and then disappears, even if I'm sure the Parallels Tools are already installed now. Not a real problem, but annoying.
    Does anybody have a fix ?
  4. ahato360

    ahato360 Bit poster

    I had Boot Camp installed before I installed Parallels 4.0, both have Windows XP Professional SP2. I don't have any of the problems described. Windows on both versions work fine. There's no problem in boot camp after installing the parallels tools.

    However, when I try to open a program called WoW Model Viewer (WMV for short), there's a message that comes up saying:

    "\\.psf\Home\Desktop\WoWModelViewer_0\WoWModelViewer.exe -- This application has failed to start because the configuration is incorrect. Re-installing the application may fix this problem."

    Is this because the folder containing the program was originally on the Boot Camp partition and I tried bringing that into parallels?

    The "_0" on the end of the folder name is me re-installing it, as said in that error message. WMV runs fine in Boot Camp. WMV also requires data folders from the WoW game client which I have on my windows and mac portion.
  5. Issachar L

    Issachar L Bit poster

    Thank you so much for such a comprehensive guide. It really saved me from going to VMWARE from PD as I'm considering which VM product I should go for.
  6. Paul Bensel

    Paul Bensel Bit poster

    Windows XP ( I loathe Vista, and haven't checked it's activation/reactivation requirements) checks several categories of hardware for changes. When enough accumulate, it triggers a reactivation.
    Two easy categories that often change: Memory (RAM) and network adapter physical address (MAC address). As mentioned by a poster above, if you make sure the Parallels first adapter matches the MAC address of your real physical network adapter, you remove a change from what Windows will detect. Almost by definition, it's going to detect a RAM change (Since you're going to install it via bootcamp first, it gets all the system ram identified... so unless you have scads of extra ram for addressing, you're not going to be able to get the what, 3GB for PAE max that Windows will recognize? Thus, it thinks you're changing the RAM from 3 or 4 GB to 2, or 1, or whatever you allow the VM settings to allow overhead for the OSX to still run, as opposed to BootCamp getting all RAM for Windows).

    I worded that poorly, but I'm tired and feverish. :) At any rate, categories I remember are RAM, processor, network adapter MAC. Maybe video card, probably not. If at least two off that list change since initial activation, it'll want a reactivate, I think.
  7. William Geck

    William Geck Member

    Using bootcamp

    I purchased my MAC+parallels a while back, and have been using it without bootcamp. I am thinking of reinstalling OSX with bootcamp, then installing and install Parallels 4 with the bootcamp install. Windows XP sp3 has, of course, been activated using the non-bootcamp install.

    Are there any guides/pointers for doing this? Would I need to re-activate windows, since the MAC address would change to the Macs address, rather than the Parallels one? And how would this effect the network settings when running both mac and xp over parallels (at the same time).

    Are there any drawbacks to using Parallels with a Bootcamp partition?
  8. Rastikan

    Rastikan Junior Member

    Hi there PieroF,

    You said that your solution was to: "change the MAC address used by the (virtual) en0 Network Adapter in Parallels to match exactly the MAC address of the physical network adapter in the Macbook"

    Isn't that causing some network problems that both OSX and Virtual XP both share a network car dwith same HW addr ?
  9. JonathanC

    JonathanC Bit poster

    BootCamp + Windows 7 Activation

    Anyone running a Windows 7 RC1 Boot Camp partition and having activation issues...I know I am.....If I get another 64 bit activation code will that stop windows 7 from wanting to re activate when I access the partition through Parallels?
  10. Geoff Reed

    Geoff Reed Junior Member

    i tried installing parallels into a win 7 partition and it totally messed up the install to the point it wouldn't boot and I couldn't get it repaired.
  11. piv

    piv Bit poster

  12. MerrickB

    MerrickB Bit poster

    I'm new to this forum, can't find this problem in the thread, and I hope someone can help. I have a new model imac that has had no problems whatsoever. I had just purchased Parallels 4.0 and had set it up to use Boot Camp with Snow Leopard. It had run flawlessly for about 3 weeks until about a week ago. Then, I awoke one day to a message saying Parallels had recovered from critical error. It gave a long error message (which unfortunately, I didn't record) and sent it to Nova. Ever since then, when I run Parallels in either windows or coherance mode, it is incredibly slow, to the point I thought it was freezing. It will literally take 5 minutes to load MS Word. The only thing I could find was that when I looked at CPU usage, it was consistantly at 100%. Even loading the drivers at boot up took forever, although I would never get a BSOD. I thought it was Symatntec Internet Security and removed it. I saw no change. I uninstalled Parallels and reinstalled the latest version without any change. If I reboot in to Boot Camp, it works just fine, with CPU utilization at about 40%. I'm finding it hard to find any answers anywhere-if anyone can help, I would appreciate it.
  13. arbi

    arbi Bit poster

    The above was quoted from 2 years ago on THIS thread. I would like to know if this recommendation is still valid in current versions of Parallels Desktop and Boot Camp with Windows 7.
  14. KPOM

    KPOM Member

    So far it seems like it is OK. I did have to re-activate Windows 7 (using the 800 number because I had already re-activated it under Fusion 3), but it seems to work OK and so far it doesn't seem Boot Camp has lost its activation, either. I'll keep you posted if I get the dreaded "3 days to activate" error message either from Boot Camp or Parallels.
  15. Jason Tanner

    Jason Tanner Bit poster

    Windows 7 Activation Under Bootcamp & Parallels ?


    I'm just about to to try setting up a new bootcamp install of Windows 7 under Snow Leopard followed by a creating a VM in Parallels 5 that runs from that bootcamp install.

    From the previous poster it seems that this is possible and I shouldn't need to keep re-activating when I switch between bootcamp/parallels.

    Can anyone else confirm this works?

    Are there any gotchas that I should look out for ?

    Given the age of this thread I'm kind of assuming the information in the first post is out of date and doesn't apply to Windows 7 so would appreciate any tips.

  16. Krib

    Krib Bit poster

    For me, what to watch out for is that it doesn't work. When I try to create a new VM under Parallels using my existing Boot Camp install of Windows 7, the VM never gets past Startup Repair. A ticket with Support has confirmed that the Parallells team is unable (or unwilling) to get this working right now:

    It's too bad, because I purchased Parallels solely to virtualize my existing Boot Camp install. I have no desire to waste disk space and double my workflow by creating YET ANOTHER install of Windows 7.
  17. I-che

    I-che Pro

  18. pastori

    pastori Bit poster

    Boot Camp & Microsoft Office 2007 Activation in Windows 7

    I am running Windows 7 with Boot Camp and Parallels 5. Windows 7 activated with no problems, but I'm having a problem with Microsoft Office 2007 and activation. If I activate it in Boot Camp, then it requires that I reactivate in Parallels, but then that deactivates it in Boot Camp. Likewise, when I activate it in Boot Camp it deactivates it in Parallels. Is anyone else having a problem with Office 2007, and is there any fix for this problem?
  19. I-che

    I-che Pro

    pastori, it might be necessary to contact Microsoft regarding activation issue. Activation of many Microsoft products is bound to specific hardware configuration, which is different in Boot Camp and virtual environment.
  20. OdoW

    OdoW Bit poster

    Wrong colours

    I updated Parallels 4 with a working Bootcamp-Installation with XP (all SP and updates) to 5 (Testinstallation). Fireing XP from the BC has had many problems: missing systemdisk, BSOD (stop), booting into the secured system. I achieved to get around all those problems except one: In a no-admin-account XP always recognizes a new hardware (the LCD-panel connected to of my laptop). Even when I installed it within an admin-account.

    I cannot really feel a difference in speed playing Sacred 2 Ice&Blood.
    But I have difficulties with the colours: In Sacred 2 sometimes blue disappears leaving a yellow-green scenerie with black rivers and creeks.

    Looks like I'm not really get an improvement from investing 49,99 Euro. Anybody who has experience in downgrading? The parallel-tools are installed.

Share This Page