How to unlock VT-x on my Mac Mini

Discussion in 'Parallels Desktop for Mac' started by Andrew @ Parallels, May 4, 2006.

  1. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    VT-x feature is supported in both Mac Mini Core Solo and Mac Mini Core Duo. Sometimes VT-x could be locked by firmware.

    To unlock VT-x do the following:

    1. Put your Mac Mini into the sleep mode.
    2. Wake up your Mac Mini from the sleep mode.

    VT-x is unlocked now and you are able to run Parallels Workstation in VT-x mode. After cold reboot you should repeat these steps again.

    To check VT-x mode for running VM please go to menu Parallels Workstation->About Parallels Workstation and check Virtualization mode. It should be Intel VT-x.
    Last edited: Jun 15, 2006
  2. haikusw


    The first time. The about box does say Intel VT-x, but I still get the warning dialog saying that VT-x is available but locked and so software vt will be used instead.

    I restarted and then put it to sleep and then launched parallels again and it seems to have worked.
    (perhaps I had the I had the vtx-check kernel extension probably still installed?)

    Not sure it'll keep working since it seems potentially flaky, but is working now which is great. Thanks!
  3. Ollie


    Andrew. Did you find this workaround yourself, or was it given bij Apple tech support? If it's the latter, do you know if it gets fixed in a later fw revision?
  4. mattham


    Ollie - I think you will find that this was discovered by a lot of too'ing & fro'ing by alot of Mac Mini users (myself Included) in this forum - As an aditional Note - I found that letting my Mini go to sleep (set sleep time to 1 min or something) rather than just hitting the power button more effective, although I've never fully tested my theory. Just sometimes when I put it to sleep the Vtx has problems but it seems to always work when I let it sleep by itself.

    Matt :)
  5. dsmac


  6. pwith


    Sorry for sounding stupid but what is the VT-x feature?

    I have a Mac Mini dual core and Parallels runs fine but when it (Parallels) is installed the Mac Mini refuses to fall asleep regardless of whether Parallels is running or not running at all.

    Spent an hour with Applecare today trying to get to the bottom of why my Mini refused to go to sleep. I could make it go to sleep but I like setting it to go to sleep automatically by setting the timer in System Preferences / Energy saver.

    Any suggestions appreciated.



Share This Page