HOWTO parallels workstation on UBUNTU INTREPID IBEX(linux HOST)

Discussion in 'Installation and Configuration in Windows and Linux' started by terlmann, Dec 20, 2008.

  1. terlmann

    terlmann Junior Member

    HOWTO parallels workstation on UBUNTU

    =============HOWTO Install Parallels Workstation 2.0 on Ubuntu=============
    ==================Updated howto version 1.2 with all commands=================
    Kernel version no longer matters.
    Step 1:

    Download the following file to the working directory and double-click on it.
    Step 2:
    #builds files

    Step 3:
    Run parallels with
    Set VM acceleration to "normal".
    #Parallels will complain about "rtc" , ignore this, it is because ubuntu
    doesn't have the realtime timer that parallels wants.

    if Parallels says "Cannot access hypervisor!"

    Issue the following command from a tty if at all possible:
    #then rerun parallels using sudo parallels. This issue may persist. Attempt to execute this command set repeatedly, and restart first. This issue has not yet been resolved.
    Last edited: Jan 19, 2009
  2. karthikbalaji

    karthikbalaji Bit poster

    Hey thanks a lot. This worked seemlessly though I did not understand what these new modified files do.

  3. mdlueck

    mdlueck Member

    One question, why do you sudo parallels instead of running it with your normal permissions? Otherwise looks exciting! Thank you very much for coming up with this!
  4. terlmann

    terlmann Junior Member


    My system rarely manages to get the hypervisor and the interface communicating.
    Since the hypervisor runs as root(kernel), I felt that the interface might as well do it also, which may incidentally
    give a slight speed boost.
    In addition, running your interface with sudo will allow your activation key to be saved into the system account, as apposed to the user account. If you decide to delete the user, the system still has the key.
  5. mdlueck

    mdlueck Member

    Thank you terlmann for the explaniation. I am currently loading a system with 8.10 and will try out your steps.
  6. Robertjm

    Robertjm Member

    quick_stop command not found

    This is really odd.

    I was able to get Parallels working yesterday just fine. However, when I tried to start it this morning I got the "Cannot start Hypervisor" error message.

    When I tried you fix for it, my system told me it couldn't find quick_stop
    I tried searching for quick_stop, but it's apparently nowhere on my system.


  7. terlmann

    terlmann Junior Member


    Sorry, the correct commands are drivers_stop and drivers_start. Howto updated.
  8. mdlueck

    mdlueck Member

    I happened to download a copy of the entire HTML file that was here. Someone has edited the original top post removing all references to the OP's customization to get Parallels to work with Ubuntu 8.10.

    As-is now, it is not possible for parallels-config to successfully compile on Ubuntu 8.10.

    See the following screenscrape:

    Do you accept terms of license agreement ? (Y/N)

    Compiling Parallels Workstation 2.2 drivers...

    Can not compile and/or link drivers. Read /usr/lib/parallels/doc/INSTALL
    and follow instructions specified in this document.

    Compilation log is available at /usr/lib/parallels/comp.log.19352.error

    *** At which point I copied the supplied file and then... ***

    userid@host:~/parallels-vm$ sudo parallels-config

    Compiling Parallels Workstation 2.2 drivers...
    Drivers have been compiled successfully.
    Installing drivers...
    Starting drivers...
    Loading Parallels Workstation 2.2 hypervisor ...
    Loading Parallels Workstation 2.2 vm-main ...
    Loading Parallels Workstation 2.2 vm-bridge ...
    Loading Parallels Workstation 2.2 vmvirtualnic ...
    Parallels Workstation has been successfully configured

    Now you can run Parallels Workstation 2.2
    Issue parallels command.

    Also, the OP's origional version of the post made reference to copying a file: prlnet.c via
    sudo cp prlnet.c /usr/lib/parallels/drivers/drv_net/linux/prlnet.c
    Such a directory does not exist.


    Anyway, I tried booting a Windows 2000 VM.

    1) Complaint that it could not find the /dev/rtc device
    2) Keyboard input goes to the Linux command window I started Parallels with (via sudo), does the same when I start it via the program icon as my own ID. Fortunately mouse works, so I am able to shutdown the VM gracefully.

    Any suggestions in either of these areas? Thanks!
  9. terlmann

    terlmann Junior Member


    Mdluech, that someone is me.
    I am OP and I updated my howto after taking the time to make a proper deb.

    As-IS, it is possible for the config to work.
    COMPLETELY REMOVE stock parallels and install my .deb.
    There is no need to copy the prlnet file, it is already included in my .deb.
    The included deb in my post has no license agreement, it was designed to work in deb-conf,
    but I'm a horrible coder and couldn't finish it.
    Anyway if someone could it would be far better to accept the license ONCE on install than 50 million times
    while trying to update kernel drivers.

    the /dev/rtc device is REAL_TIME_CLOCK and it doesn't exist
    unless you download a special kernel. I don't recommend trying.

    Your second complaint concerning keyboard input, well bud, I can't help you there
    it's probably the graphics card or drivers you are using.Also check to make sure
    you and root both are part of the graphics group that allows full card access.
  10. mdlueck

    mdlueck Member

    OK, thanks for pointing out those things.

    I have purged the previous version of Parallels and tried installing via your package. I get the following upon trying to install:

    $ sudo dpkg -i Parallels-2.2.2334_2-lin-en-parallels.deb
    [sudo] password for userid:
    (Reading database ... 152100 files and directories currently installed.)
    Unpacking parallels (from Parallels-2.2.2334_2-lin-en-parallels.deb) ...

    question could not be asked
    try 'dpkg-reconfigure debconf' to select a frontend other than noninteractive

    dpkg: error processing Parallels-2.2.2334_2-lin-en-parallels.deb (--install):
    subprocess pre-installation script returned error exit status 2
    Errors were encountered while processing:

    So what else do I need to tweak to get this to install.

  11. mdlueck

    mdlueck Member

    Greetings terlmann

    Thanks for the hard work... I think I will reload my 8.10 workstation back to 8.04. At least 8.04 is an LTS release... buys me time to convert to VirtualBox OSE I guess.
  12. Impact

    Impact Bit poster

    Hi, I am new to parallels workstation and Ubuntu but no matter what I do I just get the Hypervisor error. I have followed all instructions (except I asumend "tty" is terminal). Everything else works wonderfully in Ubunu 9.4! Do I just need to go back to Ubuntu 7.4?

    Is there any help with this problem? Why can't we just turn off Hypervisor?

    I am very dissapointed that there isn't more support from the Parallels team and support emails not answered, even after purchasing two keys and the intention of getting another 10 keys!

    Can anyone help?
  13. NikkyC

    NikkyC Bit poster

    So I decided to go through the steps this afternoon, and it really didn't take as long as expected. Perhaps that was because I had a previous install (albeit one that didn't work).

    I was so happy to see Parallels launch. HOWEVER, when I restarted my virtual machine it just sat there telling me to please wait and has been sitting on zero for a LOOONNNNGGGG time. Normally I'd kill the process and relaunch, but I'm a little nervous to do that with it being my virtual machine with all sorts of stuff I'd hate to lose.

    Did you experience this too>?


Share This Page