HUGE keyboard issue in parallels

Discussion in 'Installation and Configuration' started by BoE, Jan 3, 2010.

  1. BoE

    BoE

    Messages:
    12
    I REALLY need a fix for this! It's the most anoying problem I've faced so far!

    When i sit down and write in word 2007 using parallels desktop 5, all of the sudden a huge amount of the keys suddenly change function. AND IT HAPPENS OFTEN!!! like erery 5 mins, and then the problem goes away for some time and functions normally for another small amount of time! Completely Destroys my use of parallels.

    Example:

    rigt-key: Makes the window fill out the right half of the screen
    left: Makes the window fill out the left half of the screen
    up: Makes the window fill out the whole screen
    e: is suddenly a shortcut to some folder or my desktop (something like that)
    l: logs you out of windows
    v: shortcut to the "run"-function in windows-start menu
    spacebar: all windows fades to some kind weird mode.
    cmd: opens the start-menu

    AND A LOT OF OTHER EXAMPLES!

    So when i sit there using word2007 and I'm writing something, then suddenly in the middle of a sentence, the keyboard functions change and I can't write the words I wan't to write because the keys don't work (at least not as they should!)
     
  2. Shaddam IV

    Shaddam IV

    Messages:
    626
    Yeah... I've had that... in particular after I've tried invoking "Flip 3D" by hitting ctrl-tab. (I've mapped ctrl to the Windows key). That doesn't work very well. Avoid ctrl-tab. Use alt-tab instead.
     
  3. PatrickJ

    PatrickJ Bit Poster

    Messages:
    94
    All of those key correspond to hitting the Windows key on windows. (Command and Windows key, named differently, but are both the same key).

    http://www.buessert.de/Trs-80/GermanTRS80/PC_GermanKeyboard_large.gif

    On a Mac, the keys are aligned:
    Control, Alt, Command/Windows

    On a PC, the keys are aligned:
    Control, Windows/Command, Alt

    So basically, you just need to swap how you think about the Alt and the Command/Win key when under Windows. You need to either relearn your fingering for hitting these keys, or you can remap them inside the Parallels VM configuration. Personally, I just got used to repositioning my fingers - I prefer the printed key to match the function.

    Hope this helps!


    PS: Starting in Win 7, Win+right/left/up/down do everything from aligning the current window to sides of the screen, minimize, etc. Also, Win+E brings up Explorer window, Win+R will bring up the Run dialog, Win key by itself opens the start menu, etc. All of these are perfectly normal Windows operations.
     
  4. BoE

    BoE

    Messages:
    12
    Thats not the problem Patrick J.

    I know about how the keys work in windows. All of the example i've mentioned is for sure, driver related!!!!

    I don't pres cmd+"something" I ONLY PRES "something". That means for example that the R-key is suddenly the shortcut for run even though the only key I press is R. Also sometimes some of the keys don't have any functionality at all! I can press B or V and nothing happens!

    ALSO, I promise you, that when the only key I press is L, the system is NOT supposed to log me out of my account! AND when I work natively with W7 with bootcamp nothing like this has NEVER happened!

    Do you know what I mean or aren't I clear enough in describing the issue?

    Thank you for the reply though!!! :)
     
  5. neilio

    neilio Bit Poster

    Messages:
    41
    I just ran across this issue as well and had to uninstall Parallels to get my keyboard back. Most of the keyboard was completely non-functional, even if Parallels itself wasn't running -- even at the OS X login screen.

    Interestingly, on my MBP this is *only* on the internal keyboard. Using an external keyboard works fine.
     
  6. SandraW

    SandraW

    Messages:
    1
    You are crystal clear, BoE, and I have had the same problem driving me nuts and putting a serious dent in my productivity.

    This happened to me in Parallels 3 as well, but much more frequently since I've upgraded to Parallels 5. I've never had to uninstall to get my keyboard back as neilio mentioned. I hit command-clear and the normal keyboard functionality returns - if everso briefly. I cannot figure what triggers the keyboard function to flip out.

    I am seriously disappointed w/the upgrade, to say the least.

    Any insight on how to resolve this problem would be much appreciated!!
     
  7. porsillo

    porsillo

    Messages:
    1
    Has anyone found a solution to the r = run dialog?

    I just started to run into this. It seems to be related to restoring key board settings. That was using v4 I switched to v5 (the v5 installer removes the v4 installation) and the problem still happens.

    The interesting thing for me is that the problem occurs when I connect from the virtual win XP using windows remote connection to another computer. The virtual windows works ok but the remote one it wonkie.

    This all used to work.
     
  8. LiliyaP

    LiliyaP

    Messages:
    1
    I've been having this problem since the very beginning when I started using Parallels 5. I have been going back and forth with their tech support for quite some time now, but no solution has been found. It's pretty annoying when it happens. If anyone finds a solution, PLEASE DO let us know.
     
  9. Dude_Sweet

    Dude_Sweet Bit Poster

    Messages:
    5
    I can't believe this hasn't been resolved yet. I am having the same issue.

    I have restarted my virtual machine and it sometimes goes away, yet it always comes back again eventually.

    "R" is a very common letter in the english language.

    I have found pressing SHIFT + R will keep the Run dialog from appearing, but may not be suitable for all situations.

    Gotta love these "forums" that are hosted through a companies website, but nobody from the company looks at and nobody responds to.
     
  10. Dude_Sweet

    Dude_Sweet Bit Poster

    Messages:
    5
    Pressing command + clear (on an external keyboard) seems to stop this from happening.
     

Share This Page