I have working RS-232 serial...

Discussion in 'Parallels Desktop for Mac' started by eudyptes, Apr 22, 2006.

  1. abey


    Hi all. I've had mixed success with SerialClient trying to connect to custom electronics we have at our lab. Thanks for that anyways, Eudyptes!

    Now, can some Parallels guy (tacit_one?) tell me why we need such an external program in the first place. IMHO, there should be this list of Mac serial interface right into Parallels GUI for setting up COM port, instead of this awkward socket thing. Is that a planned feature of Parallels? If yes: any ETA? If not: it should! :)

    TIA, abey
  2. loughkb@yahoo.com


    This is a band aid for the problem that provides a partially useful solution for a few users. However, for some of us, we need more than just serial data flow. I have software that uses the individual pins on a serial port for controlling PTT on radios, and communications software that needs pin control to power the communications interface.

    We still need direct support for serial adapters to allow windows to use the adapter directly. And support for usb sound interfaces.

    I work at Sweetwater, and we have many customers that would benifit from parallels if they could use their USB audio gear with windows software directly.
  3. don montalvo

    don montalvo

    ditto...serial and usb2 are needed to give clients ok...

    ditto...i have clients ranging from fortune 100 companies to ad agencies, a/v houses and service bureaus...they're all waiting for the go-ahead to buy intel boxes for folks who don't do graphics production work but who need to run osx and windows at the same time. parallels is maturing nicely - but i wish usb functionality was 100% (parallels still only offers usb1.1 and partial communication with some devices like garmin gps). that would be enough to ok a considerable number of licences.

  4. loughkb@yahoo.com


    I can't get the serial client to run anyway.. Has anyone gotten it to work with a keyspan device? When I hit connect, it flashes and switches back to "connect". If I hit it again, it crashes with this info:

    Date/Time: 2006-10-05 16:40:07.551 -0400
    OS Version: 10.4.8 (Build 8L2127)
    Report Version: 4

    Command: SerialClient
    Path: /Volumes/SerialClient/SerialClient.app/Contents/MacOS/SerialClient
    Parent: WindowServer [64]

    Version: ??? (0.10 (beta))

    PID: 1043
    Thread: 1

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000021

    Thread 0:
    0 libSystem.B.dylib 0x90009857 mach_msg_trap + 7
    1 com.apple.CoreFoundation 0x9082869a CFRunLoopRunSpecific + 2014
    2 com.apple.CoreFoundation 0x90827eb5 CFRunLoopRunInMode + 61
    3 com.apple.HIToolbox 0x92dcdb90 RunCurrentEventLoopInMode + 285
    4 com.apple.HIToolbox 0x92dcd297 ReceiveNextEventCommon + 385
    5 com.apple.HIToolbox 0x92dcd0ee BlockUntilNextEventMatchingListInMode + 81
    6 com.apple.AppKit 0x9326f465 _DPSNextEvent + 572
    7 com.apple.AppKit 0x9326f056 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 137
    8 com.apple.AppKit 0x93268ddb -[NSApplication run] + 512
    9 com.apple.AppKit 0x9325cd2f NSApplicationMain + 573
    10 com.eudyptes.SerialClient 0x00002392 _start + 216
    11 com.eudyptes.SerialClient 0x000022b9 start + 41
  5. hendersons


    This is exactly what I needed !!! I'm using a GlobalSat BT-359 (great bluetooth GPS device, BTW) and now I can use it fully within DeLorme's Street Atlas and Microsoft's Streets & Trips. I've just tried both, running in PDM on my MacBook, and they work!! Better than on my Dell laptop.

    This advance is truly newsworthy - to me a very enabling technology. Thanks for the great tool.

    ps For me, "Connect" would not connect unless I already had PDM configured and running. Maybe worth mentioning in the Readme if this is normal.
  6. skylar3141


    serial client works great w keyspan 19hs!

    thanks very much for putting this cool little app together! it was exactly what i needed and this whole process would have been worthess with out this ability. it would seem like something that should be part of the vm software.

    does anyone know, is it possible to connct dirrectly to the usb interface via the vm in windows for a usb serial adaptor? i tried this many times with no sucess before using the serial client.

  7. SteveDemy


    Elite flight simulator

    Thanks for this excellent work. It has worked to connect through a Keyspan 19W serial interface to an Elite flight simulator system. FWIW I was able to break this functionality by instaling Nokia PC Suite. So if you can't get it working, look for installed software that might compete for a COM port.
    Last edited: Oct 15, 2006
  8. Rich White

    Rich White

    Where I work I have always needed the same thing, PTT on data radios, hardware flow control for external voice modems, PLC programming, programming of our own equipment etc.
    If you are in the same boat and really really NEED reliable serial ports that provide support for all the hardware pins, think about using an Ethernet-to-Serial adapter. They work great under Parallels, Virtual PC, etc. since Ethernet support has always been a priority for any emulator. The only downside (other than cost) is that they aren't very portable - although there are some new ones on the market that are much smaller than my old Moxa NPort Express.

    Better USB support in Parallels is definitely a must, but I will still keep using my Ethernet-Serial. I have seen too many problems on "real" PCs related to USB-Serial device drivers and would rather stay away from them for work-related use. They should be fine, however, for stuff like GPS devices with DeLorme software (don't get me started with DeLorme - why don't they just make a Mac OS X version of Street Atlas?).
  9. padamo

    padamo Bit Poster

    Product ID Pass-Through

    What we need is a generic way to tell the Mac to disregard devices with given product ID's so that the USB driver leaves them alone and allows them to be grabbed by the PC.

    I originally got a chip debugger/emulator to work by following some instructions in post the advised how to remove support from the Mac drivers for what I assume were Human Interface devices. This allowed one variant of my chip debugger to work, but when I went to the second debugger type, it still gets captured by the Mac OS.
  10. jsolderitsch


    I am trying to get the serialsetup program to work with a 19HS Keyspan as well and cannot succeed.

    I am trying to do something a little odd -- set up a ppp connection over the usb serial link from my Parallels VM to a real serial port on a real PC.

    I have an "incoming" network connection on the real PC and I created a direct connect network connection in Parallels.

    I have done this for two VMWare images in a PC lab successfully.

    I have serialsetup running and connected. I have logging enabled. When I try to connect my direct connection in Parallels, I see the following in serial setup's log:

    CLIENTCLIENTCLIENTSERVER~·}#·!}!} } }4}"}&} } } } }%}&1·}=·}'}"}(}"·v~~·}#·!}!} } 6}"}&} } } } }%}&8·=·}'}"}(}"}-}#}&}1}$}&N}3}7}!.·D·,NH%··&·Q·}3}/} } } } }7}$} 4··~~·}#·!}$} } #}1}$}&N}3}7}!.·D·,NH%}··&·Q·}3}/} } } } }7}$} 4··~~·}#·!}"} } }4}"}&} } } } }%}&1·}=·}'}"}(}"n}?~~·}#·!}!}!} }7}"}&} } } } }%}&8·=·}'}"}(}"}-}#}&·`~~·}#·!}"}!} }7}"}&} } } } }%}&8·=·}'}"}(}"}-}#}&··~~·)········~~·)········~~·)········~~···~···!·······(·······-··~································L~~·!··················~~·!···.·!···(···-································Dg~~·}#·!}%}$} }08·=·} <·t} } }~ ·}} #}·'!·}~%}#} }01·}=·} <·t} } } } <·~~·}#·!}&}$} }08·=·} <·t} } } } &=~~·}#·!}&}#} }01·}=·} <·t} } } } }=}^~

    The CLIENTCLIENTCLIENTSERVER string is actually expected behavior for PPP negotiation with a WINDOWS XP PPP server. But the connection never completes -- I see, in Parallels, a 733 error that supposedly means the PPP negotiations failed.

    I am beginning to think my Keyspan adapter is broken. I have tried with hardware flow control enabled and disabled on the client (Parallels) and server (real PC) with no difference.

    I have located a "Modem" LOG file on the real PC associated with the serial port and it shows that there is an initial negotiation and that momentarily a connection is established. But it ultimately fails to make a complete connection.

    Anyone have experience with a serial PPP connection between 2 PCs? This ought to work!
  11. jsolderitsch


    To follow up my own post.

    I got this situation resolved by changing the setup of the Window's incoming connection's tcp/ip protocol config to specify its own IP address range rather than using DHCP for the addresses.

    It turned out that I could not make a connection using 2 real PCs until I found and changed the DHCP setting to static IPs. My IT guys tell me that trying to have the incoming connection use DHCP to grab addresses was not expected behavior (although the PC defaults to this setting).

    In any case, once I changed the incoming connection's config, I repeated my connection attempt and things worked from Parallels.

    I was also able to use pppd from OS X to make a serial ppp connection as well without Parallels involved at all.
  12. mikejaer


    My Keyspan USB-Serial works but slowly, very slowly.
    I use it to transfer settinglist to my humax sat-reciever

    is that normal, tat it works so slowly ??
  13. cgpdfm

    cgpdfm Bit Poster

    I have several IOGEAR USB adapters for my radio gear. I mainly need DTR control, to power the radio data interface. I hope this is addressed soon (if it hasn't already, as they are constantly providing updates...). My main reason for getting Parallels is a replacement for VPC, which I use for contest logging apps. Either it should recognize an OS-X serial port (the VM sees a COM port - I guess SerialClient works that way, but doesn't support the discretes like DTR), or directly support the USB device.

    The latter would be more difficult, since I can't unload the driver in OS-X - I have 3 USB serial adapters. Let's put it this way - I would like to be able to use one device in Parallels at the same time as I'm using the other 2 in OS-X

    Edit: if DTR is asserted the entire time SerialClient is running (i.e. the port remains open), that would work for the radio data interface. Obviously, it won't for PTT or other uses requiring discrete control.
    Last edited: Nov 20, 2006
  14. Jkirk3279



    This is great !

    I was about to post a related question.

    I have a MBPro, 2Ghz, and it has an Expresscard slot. I want to direct-drive the serial port for our CNC machine at work.

    The software that generates the HPGL files uses a Parallel port dongle, so I was wondering if the VM approach would work...

    I suppose that Boot Camp might have a better shot at using the Expresscard slot to run a serial port card.

    I'm not quite sure if there would be a problem running a parallel port dongle with a USB to parallel converter, I seem to recall there might be issues if the converter isn't truely bi-directional.

    Any opinions?
  15. cgpdfm

    cgpdfm Bit Poster

    Keyspan 19HS and DTR

    I've had success with SerialClient, Keyspan 19HS, and DTR powered ICOM CI-V interface.

    Selected "Keyspan1" as com, and enabled Hardware flow control. I haven't put a 'scope on DTR, but I'm assuming it will stay asserted as long as connected to the socket.

    Parallels running Windows 2000. Using default COM port settings [in WIndows]. Apps used: "HAM Radio Deluxe" and N3FJP Log(s).

    I created a simple Automator workflow to launch SerielClient, with the Keyspan config. file, then launch Parallels (suspended with N3FJP app). COM port automatically reconnects with ICOM, after suspend restore is complete (as long as I remember to hit "Connect" in SerialClient).

    Thanks for the work on SerialClient.

    But, I hope Parallels gets an integrated solution.
  16. MarkHolbrook


    Has anyone tried the Keyspan adapter with 3120 or any of the builds that seem to support USB better?
  17. drval


    Yes, I get intermittent access, for instance, the third test (using the KeySpan Assistant) will fail fairly consistently.
  18. slobob


    I have an express card serial adaptor. In fact this is the main reason I bought the Mac book PRO instsead of the regular Macbook. I thought that the ability to use the expansion slot would be an advantage. As it turns out, the Express card shows up on the USB bus! So in essence, it's just a big fat USB port. What a waste af time and reastate on the chassis.
  19. DrSchurger

    DrSchurger Bit Poster

    Excellent results!!!

    I am very pleased to say that I have been able to get my serial adaptor working with no problems other than trying to get the driver to work (install the driver first, then make sure it's pointing to the right COM port).

    I picked up a serial adaptor by Port Authority. It was about $15 cheaper than the Keyspan, and is a short one piece cable. Very handy, and nice, esp since the drivers are for Window's only. But it doesn't seem to be a problem to run thru to Windows. The Radio Shack model never worked, but there are problems with it and XP SP2 apparently.

    The next step is getting my 2nd USB device working with it as well.
  20. MarkHolbrook


    I'm on to 3150 now and the Keyspan sort of works. Usually it's ok right after I first connect it. But if my Win program closes the port then re-open pretty much always fails.

    Wish this wasn't so.


Share This Page