I lose mouse buttons and keyboard

Discussion in 'Installation and Configuration' started by Architect, Jul 21, 2011.

  1. Architect

    Architect

    Messages:
    4
    I run Lion and latest PD6. When I start vm with Win7 and start working, after 3-5 minutes my MacBookPro keyboard stops responding, the same with click on touchpad and magicmouce. However the system keeps on working fine and I can drag mouse cursor using both touchpad and mouse. But there is not way to get keyboard or button back to life, so all is left to turn of macbook completely. I made many tests, it happens right in few minutes after I start my Win7 machin in PD6! It never happened with PD5! Frankly speaking, I had the same issue many months ago before Lion, that's why I kept on using PD5. Please help ASAP.
     
  2. Architect

    Architect

    Messages:
    4
    I'd like to summarize
    I turn on Parallels Desktop, start my virtual machine with Windows Seven and I can do nothing inside Windows, just keep on browsing Internet in Safari.. but after some 5 minutes my mouse buttons, keyboard and touchpad will stop responding. However I am still able to move cursor using both mouse and touchpad, and system keeps on working, but I cannot control anything anymore... That happens globally to the whole system, so my only way out is to press the hardware power button on my macbook and hold it until system shuts down..
     
    Last edited: Jul 21, 2011
  3. alev

    alev Parallels Developers

    Messages:
    432
    Hi,

    Unfortunately I do not have solution for your problem.

    Could you please enable Troubleshooting log (Parallels Desktop->Preferences, Advanced Tab -> Troubleshooting - Use detailed log messages), reproduce issue and send Problem Report (Help->Report a problem), post ID here. I will pass the information to developers.

    I could also recommend to disable Smart Mouse (Stopped VM Configuration -> Options -> Advanced -> SmartMouse:Off). Not sure if it could help, but it is worth to try.
     
  4. Frank_C

    Frank_C

    Messages:
    1
    Keyboard mouse issues as well

    Parallels 6 Build 6.0.11994
    Mac OS X Lion 10.7 (11A511)
    27-inch, Late 2009 2.8 GHz Intel Core i7 8 GB 1067 MHz DDR3
    Bluetooth KeyBd and Mouse (std. apple issue with machine)

    Windows 7 VM will not respond to Keyboard and Mouse. Can not login.
    However selecting Devices>Keyboard>>Ctl+Alt+Del will select the login prompt as normal.
    However can not progress farther as ...
    Mouse will not click user button.
    Keyboard will not input text for password.

    Help. Am dead in water at work.

    Frank C.
     
  5. Architect

    Architect

    Messages:
    4
    But in my situation I also lose keyboard in Mac OS and mouse buttons
     
  6. Architect

    Architect

    Messages:
    4
    I will try VMWARE, if it doesn't work in Lion, I will have to reinstall Snow Leo.. because of Parallels freezing my system!
     
  7. skrymir

    skrymir

    Messages:
    1
    Got the same problem (lost mouse and keyboard). It would be nice to get helped out of that trouble.
     
  8. Pott

    Pott Bit Poster

    Messages:
    1
    Same problem - PD6 and lion and loss of left mouse button

    I have the same problem -- just showed up today. I've been running lion for about a week and it's been working great. Ran my WinXP session in PD6 today (normally works flawlessly). It was working as expected while I messed around. I left it for around 20 minutes, came back and my left mouse button no longer works. The right mouse button does what the left one used to (for menu's, but doesn't actually push buttons or activate windows for moving them around and stuff).

    What's more, this carries over to the Mac side - the left mouse button doesn't do anything there either. Shutting down PD6 doesn't fit it either - have to reboot the entire machine to get it to come back.

    This doesn't happen if I don't start PD6, so it's likely there's some gremlin in there.

    Anything I can do to help diagnose this? It's happened 3 times today and I'd really appreciate a fix.

    -Pete
     
  9. ChristianP

    ChristianP

    Messages:
    1
    I have been experiencing the same issue as the original post. When I try to use parallels 6 to access by Windows 7, bootcamp partition I lose all use of my keyboard in both parallels and mac osx. I am using a 2009 27" iMac (2.66 GHz core i5) with 12 GB ram with an Apple Bluetooth keyboard and a Microsoft Bluetooth mouse. I have noticed that at first parallels will work normally, but it seems to break when I try to attach my XBox 360 controller to parallels. The last time I tried to use parallels I did not try to connect the controller, but I did open the devices menu option, from right-clicking the dock icon, however I did not connect or change any of the devices, and it still froze the keyboard. After this happens if I open the Mac's Bluetooth menu to disconnect the keyboard, it will lock up the Bluetooth menu as well. Also once this happens I have to do a hard reset, hold power button, to close down the Mac. Simply closing parallels is not enough and trying to shut down through the Apple menu will cause the system to get stuck on the gray shutting down screen. I was not experiencing any of these problems before I upgraded to lion. Also I run parallels in spaces #3. I hope this information will help someone figure out the cause and a fix for this issue, because at this point the software is unusable.
     
  10. cvelezv

    cvelezv

    Messages:
    8
    Only loose the keyboard on the OS X side

    My problem is different, after starting the VM (windows) eventually I loose the keyboard on the MAC side, it keeps working on the Windows VM, if I open the keyboard viewer (MAC side) I can see the keystrokes being made, but no output is externalized to the MAC side, sometimes the keyboard returns, but other times I have to stop the VM and reboot to gain back the control of the keyboard.Please advise if a fix is available for this problem. This is for Parallels 7.0.15104 Revision 778994
     

Share This Page