IIS Site Root in Shared Folder

Discussion in 'Windows Guest OS Discussion' started by fruvos, Sep 11, 2006.

  1. fruvos

    fruvos

    Messages:
    2
    I'm running Parallels on my MacBook, and have been delighted with its performance. However, there is one thing which I would like to get working if possible.

    I'm a web developer, and from time to time I have to develop using IIS and ASP. I've configured IIS on my XP installation within Parallels and under the default values it works great. However, since I develop in Dreamweaver within the OSX environment and test using http://192.168.0.6/sitename on IIS of my Parallels windows machine (where 192.168.0.6 is its bridges IP and sitename is a subfolder of the default c:\inetpub\wwwroot, it would be really benificial if I could configure the home directory of IIS to be \\.psf\webroot where webroot is a shared folder configured in Parallels to point to a folder on my OSX filseystem.

    Whilst I can browse to the files in question on the shared directory, when I configure the home directory of IIS it doesn't work, throwing a Bad Request error.

    Is there any way I can do this? Why is IIS not liking the home directory being configured as a Parallels shared directory? If I can get this working then I can simply save my files in dreamweaver and immediately preview them in my browser using IIS on the Parallels machine.

    Any suggestions / thoughts will be greatly appreciated.

    Thanks in advance.
     
  2. David Corrales

    David Corrales

    Messages:
    189
    Why don't you try mounting that folder as a static drive letter? For example, mount it to Z: then you can easily access it as if it was a regular folder :)
     
  3. fruvos

    fruvos

    Messages:
    2
    I've tried this already, having mapped the shared drive to w:\

    However, when I try to open index.htm, whish is in w:\ I get a 404 error. Dunno why, so opinions duly appreciated.
     
  4. David Corrales

    David Corrales

    Messages:
    189
    Why don't you set up a regular folder inside your guest computer as a shared one. Then just access the files via the regular ubuntu Network Servers. Kinda doing the same thing but backwards... IIS might like that better.
     
  5. tgrogan

    tgrogan

    Messages:
    255
    Why don't you post this question to the mac forum where it should be posted? This forum is for posting solutions - not for posting problems!
     
  6. David Corrales

    David Corrales

    Messages:
    189
    Well I guess that's what moderators are for... I rather just help with what I can :rolleyes:
     
  7. tgrogan

    tgrogan

    Messages:
    255
    WADR - No problems with your efforts, but there have been some really useful posts to this forum that have helped me and it is difficult separating the inappropriate posts from the useful ones when people are too lazy to post to the proper forum. The description is very plain but too many people just post first without thinking how they effect the usefullness of the forum to other people.

    Parallels is a very small company, sometimes they need help with moderating too...
     
  8. David Corrales

    David Corrales

    Messages:
    189
    Maybe they could assign some voluntary moderators with limited access. Maybe only move posts or remove ofensive language.
     
  9. jrotondo

    jrotondo

    Messages:
    14
    Y'know, for folks using the search function to find a solution to their problem, they don't really care if the thread is posted in the "right" forum. All I know is that your comment killed a thread that I was also interested in an answer to.

    Please leave the administration of the forum to the Parallels moderators. You're detracting, not contributing to the community.
     
  10. reuben

    reuben

    Messages:
    2
    I too am having difficulties getting this to work. No matter if I mount the shared site root folder (which resides on my host Mac) as \\.psf\share or as a mapped network drive or even thru \\mymac\sharename (an smb share).. i can see the folders in the IIS admin for the website, but any HTTP request to the site results in a 401.1 "Unauthorized: Logon Failed" error..

    would love to figure this out..
     
  11. reuben

    reuben

    Messages:
    2
    oh, i should mention that if I mount the webroot as a drive, if I click the "Browse" button in the "Home Directory" tab of the IIS default website config and navigate to the mapped drive, the "OK" button is greyed out no matter what (including all subdirs therein).

    blarg
     
  12. lgriffin

    lgriffin

    Messages:
    7
    Hi for what it's worth i have a solution that has fixed this issue for me. I hope this helps someone because this was very frustrating for me.Let's say all your websites are stored in 'clients' in your os x home folder, and you want to share your clients folder with parallels:

    Problem:
    If you select the share Parallels created for you, e.g. //.psf/clients and use that as your shared folder in IIS, you'll get all kinds of permissions issues.


    1.) Turn on bridged networking.
    2.) Goto os x's preferences and turn on file sharing, select that clients folder and turn on SMB sharing for that folder
    3.) Go back to parallels, My Computer, My Network Places
    4.) You'll see the shares you created, navigate to that clients folder and copy the address
    5.) Paste that address into IIS
    6.) Go back to parallels. Hit the start button / run / type 'cmd' to bring up a command prompt. When it comes up type 'ipconfig'. Note the IP address.
    7.) Back to os x, safari: type in that address. That should work!


    Make sure the account you 'connect as' is matched up to the account in os x's preferences sharing.
     
    Last edited: Nov 29, 2007
  13. alargent

    alargent

    Messages:
    17
    lgriffin,

    Can you tell me what the address looks like that you're pasting into IIS? When I look in "My Network Places", I see my shared folder from OS X called something like "\\Mac12345asdfasdf\mysharedfolder\", but using that doesn't seem to work for me.

    I've also tried the full IP address of my Mac, like "\\192.168.1.1\mysharedfolder", but that's not working either.

    Thanks much.
     
  14. lgriffin

    lgriffin

    Messages:
    7
    Not Usable

    Hi just a follow up post.

    Yes the method i posted above works, however the problem is that IIS or Samba will cache the .NET pages and let's say you make a change in dreamweaver in Leopard, then refresh firefox on the guest OS, you won't see that change. I tried everything six ways to sunday to get around this problem. If anyone has a concrete answer i will pay you, lol, because i don't think there is one. Currently i'm storing my files on the guest os.
     
  15. rafudu

    rafudu

    Messages:
    5
    Chmod

    Hi!
    I was having this issue, and I solved just by running chmod -R 777 <sitefolder> and pointing IIS to the shared folder.

    Then, map the IP in /etc/hosts and you'll be fine.

    Good luck!
     
  16. lgriffin

    lgriffin

    Messages:
    7
    instructions?

    Can u post detailed instructions please!
     
  17. Upton O'Good

    Upton O'Good

    Messages:
    55
    Why not set up your asp application directory as a WebDav directory? It should be under Web Service Extensions in IIS Manager. I think you can open a WebDav directory in Dreamweaver. You can also mount them in the Finder.
     
  18. Upton O'Good

    Upton O'Good

    Messages:
    55
    Why would Mac users be the right people to ask about IIS and Windows permissions???

    Friggin' listmom wannabes.
     
  19. lgriffin

    lgriffin

    Messages:
    7
    WebDav?

    I believe that is only in IIS6? However we are talking about IIS 5.1 on XP here.
     
  20. rafudu

    rafudu

    Messages:
    5
    Now i'm getting:
    "HTTP 401.3 - Access denied by ACL on resource
    Internet Information Services"

    The weird is that i can acces the site once. If I click refresh, I get that error. It only happens with .asp files, .html load ok. I've already chmod 777 my mac folder

    Thanks!
     

Share This Page