[in progress] OpenGL 3 Support (list of app titles and their status inside)

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by Docent, Apr 27, 2017.

Tags:
  1. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    No there is no OpenGL 3.2 implementation for Parallels 13, they have been working on it since seven years to no avail. It appears their leadership does not know how to or does not understand it. VMWare Fusion is the way to go if you have a new install option instead of Parallels. Here is what they confusingly state, but if you read between the lines it is a fudge and not full implementation of what is by now OpenGL 4.x, so even 3.2 is already 10 years old:
    "We continue working on OpenGL 3.0 support. The first results could already be seen in an update for Parallels Desktop 12, where we added support for such games as Rage, Wolfenstein: The New Order, and Wolfenstein: The Old Blood. Now we've added support for DIALux evo and Northgard."
     
  2. Docent

    Docent Bit Poster

    Messages:
    19
    Ha Ha Ha Ha. I ask for support Corpus 4.0 from version 5. I just need good working OpenGL 2, not even 3.0. Problem is I think that too many users of Parallels are idiots who look for each new version and don't see only cosmetics change and preperation of Paralles to working next OSX versions. Easier for developer is move button from top to down, from this card to this card then start real programing and add OpenGL. Now we have situation that bigger competitor VMWare has it now is new version and works quite well - and now they realize that "oh my " we are 2 years ahed of them, we must do some programing. I give them last change that in parallels 14 will be support of newes OpenGL. If not I stop to be stupid idiot user who pay for cosmetics.
     
  3. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    Agreed. the bigger issue is, that VMWare comes in at the same price as Parallels and is now run by Dell, so going forward better outlook than Parallels no matter what. You have to do a new install anyway so why not go with a reliable and responsive VMWare. The only save would be if Parallels in version 14 would offer OpenGL 4.2+ ahead of VMWare and so for legacy systems it is more convenient to just upgrade. But yeah, it is a shame.
     
  4. alev

    alev Parallels Developers

    Messages:
    331
  5. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    The blog is misleading at best. The reality is that 13 only does a selective job of supporting some apps that use OpenGL 3.2, not a full on OpenGL 3.2 support. In addition the link to the thread for apps that are desired is dead - Error 404. Classic. The worst is though, there is no explanation given why VMWare is able to support OpenGL 4.x and Parallels since ten years is stuck in 2.x mode. If it is merely about writing a library of matching the calls, a dll of sorts, this probably should have been accomplished in the past ten years. This is really pathetic for a $80 mass product where a competitor at same price offers a solution.
     
  6. PeterT7

    PeterT7 Bit Poster

    Messages:
    1
    Just purchased a new version of Sketch 2017 (for over $800) and it will not work in parallels in windows. It says it must have open GL3 or above but parallels can only give me open GL 2.1
    I cannot understand why open GL 3 (or more) is such an issue with Parrallells.
    I have been reading the posts of many others who have also complained.
    I think it time for a change that we all vote with our feet!
    NOT HAPPY!!!
     
  7. CharlB

    CharlB Bit Poster

    Messages:
    7
    The VTK 7.1 library also requires a 3.2 context, and so example VTK-based apps crash on startup in the latest Parallels. I urgently need this to work for a VTK-based software we are developing for a customer on Windows. I logged this as a bug with Parallels, and got a response which says that they've put it on their list. Perhaps if more people logged specific bugs with their OpenGL 3.2 applications, this would help expedite the process?

    "Hello Charl,

    Your request has been passed directly to the Secondline Technical Support.

    Thank you for providing us with the instructions regarding reproduction of the issue.

    We were able to reproduce the virtual machine crash upon using VTK 7.1 based application.

    We have escalated the issue you reported to the Engineering Team and they are working to address it in one of the future builds of Parallels Desktop for Mac.

    To enable automatic updates, from the Parallels Desktop Menu, select Preferences > General > Download Updates Automatically.

    While we do not have ETA for the fix, it has been prioritized appropriately and you can track the changes in the product at http://kb.parallels.com/en/124262

    Current support ticket will be marked as 'Resolved'. But do not worry, we will create a new ticket based on this one where all further work on the issue will be continued,
    wherein our Support Team works directly with the Parallels Development Team. So the current ticket is marked as 'Resolved' in order to avoid ticket duplication."
     
  8. CharlB

    CharlB Bit Poster

    Messages:
    7
  9. CharlB

    CharlB Bit Poster

    Messages:
    7
    Parallels tech support just replied to my question as to when they expected to ship OpenGL 3.2 support. Here is an extract from the answer:

    "I'm afraid OpenGL 3.2 implementation is very unlikely to happen in Parallels Desktop in the near future. Nevertheless, the Development team noted and VTK 7.1 applications in their checklist per your initial contact. Let me know if you will get additional questions."

    So they might solve the specific issue of VTK-based apps, but general OpenGL 3.2 support is going to take a while still.
     
  10. drchevalier

    drchevalier Bit Poster

    Messages:
    3
    Per your request, I am requesting OpenGL 3.3 support as it is required for On1PhotoRAW2018. The application will not even launch without this support
     
  11. magriner

    magriner Bit Poster

    Messages:
    2
    Parallels, I know you requested my request for supported apps using OpenGL3+, however, I simply wanted to comment letting you know that your lack of foresight and planning lost you a long-time supporter today. It is beyond me why you haven't built this into your latest release, as the demand statistics alone should've queued your business strategy analysts to put this in the front of your build pipeline!

    You guys dropped the ball and will lose the game to VMW quickly as more and more of your professional-based, and consumer-based for that matter, customers experience your lack support and planning. I put my name on the line for you, while pre-phase implementing a software solution within a BILLION dollar organization, of which I work for, only to find out you can't/won't support a mainstream, necessary, and seemingly simple OpenGL build! Thank goodness VMW is around to save the day for me! Good riddance!

    You did do one thing well - The refund was quick...
     

    Attached Files:

  12. MikeFromMesa

    MikeFromMesa Bit Poster

    Messages:
    60
    I am requesting OpenGL 3.3 support as it is required for Topaz Studio. Without that support the application will not even install, and it is the base for all of the new Topaz plugin functionality.
     
  13. FernandoL2

    FernandoL2 Bit Poster

    Messages:
    1
    Autodesk ReCap say it´s OpenGL 2.0 and not OpenGL 3.1

    I used Parallels 13 PRO

    Thnak´s
     
  14. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
  15. Specimen

    Specimen Product Expert

    Messages:
    3,256
  16. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    Neither of which is currently fully supported or will be supported by Parallels.
     
  17. Specimen

    Specimen Product Expert

    Messages:
    3,256
    Or will be? Can you explain how you know this?
     
  18. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    Please refer to the statements by Parallels Support earlier in this thread for clarification of their position.

    This topic has been around since many years with no effort to cure from Parallels. The current Fusion 10 version provides no barrier for change over as a *.pvm can simply be imported, while the cost is the same as Parallels "Upgrade" from an earlier version. This means there probably is, outside from legacy installations, no adherence anymore to Parallels and anybody who was put in front of a choice already walked away, hence no incentive either for Parallels to keep up any longer. This in return is good for VMWare.
     
  19. Specimen

    Specimen Product Expert

    Messages:
    3,256
    Ah, ok, just speculation.
     
  20. MichaelR14

    MichaelR14 Bit Poster

    Messages:
    16
    Sadly indeed pure speculation that Parallels will ever fully support OpenGL higher than the currrent 2.2. Espescially, since they stated in their own wirds that they won't go beyond what is there, and that there are fundamental technical issues that they haven't resolved since many years. Too bad.
     

Share This Page