increase screen resolution of Ubuntu install on Mac Pro

Discussion in 'Parallels Desktop for Mac' started by bbanks, Sep 28, 2006.

  1. bbanks

    bbanks

    Messages:
    2
    I'm having a ton of difficulty increasing the screen resolution of my Ubuntu Dapper install above the basic 1024x768 default.

    I have already spent some time researching and trying to fix this-- have already made the recommended changes to my xorg.conf file, and added the same resolution settings to my Parallels VM config. This advice is recommended in a few locations (including elsewhere on this forum), but doesn't work for me. I can't get the Ubuntu VM to show an option for a resolution above 1024x768, despite adding addl settings to the xorg.conf file and the VM's Video config settings.

    The Ubuntu Dapper install is apparently fine in every other way i've tested. The version of Parallels i'm using, build 1898, from Sep 17 2006 has fixed all the stability problems that I was having a few weeks ago.

    Possibly relevant stats about my system:
    Mac Pro (Intel)
    Apple 23" Widescreen Display, native resolution 1920x1200
    Running VirtueDesktops

    I've tried many different common resolution settings between the default 1024x768 up to the 1920x1200 native res. Nothing but 1024x768 no matter what i do.

    Dapper install is a fresh one doing an install from the LiveCD iso image to the VM's hard disk. I haven't mucked around with any settings besides those changes to the xorg.conf file that are recommended elsewhere. And the net effect of those changes is 0 so far.

    Would much appreciate any help. In particular, I wonder if somehow VirtueDesktops is causing a problem? Has anybody else out there got an Ubuntu or other Linux install working at a higher resolution while using VirtueDesktops? Any other tips on getting this resolution increased?

    Thanks in advance,
    Brad Banks
     
    Last edited: Sep 28, 2006
  2. bbanks

    bbanks

    Messages:
    2
    update on virtue desktops

    To test whether VirtueDesktops could be part of the problem, I tried shutting down VirtueDesktops and then running the Ubuntu VM. There was no change at all in the behavior, only the same default resolutions show up in the Screen Resolutions menu.

    So it doesn't seem to have anything to do with VirtueDesktops.

    Though I would still like to hear confirmation that someone has got Parallels and VDesktops working together with an Ubuntu install at an increased resolution.

    Anybody got any advice for me here?

    -Brad
     
  3. mykmelez

    mykmelez

    Messages:
    29
    I have Parallels and VirtueDesktops working together with Ubuntu running at 1440x900 on my MacBook Pro laptop. To make it work, I first switched to that resolution in the Mac OS Display preferences (it was at 1280x800 by default).

    Then I added that resolution (and also 1280x800) to my xorg.conf file:

    Finally, I enabled custom resolutions in the VM configuration and added 1440x900 (and also 1280x800) as custom resolutions. After restarting Ubuntu, everything worked fine. Ubuntu even displays correctly on my external Dell 2005FPW LCD monitor.

    I have three VirtueDesktops, one for Mac OS X, one for the Ubuntu VM, and one for a Windows VM (with the VMs running in full screen mode on their respective desktops).
     
  4. donnie

    donnie

    Messages:
    28
    I futzed for hours trying various combinations in xorg.conf and Parallels vm custom resolutions to achieve the native 1680x1050 on my 20" iMac. The closest I could get even using the above suggestion was 1440x900. Finally, with only 1680x1050 in custom resolutions I reran 'sudo dpkg-reconfigure xserver-xorg' without the -phigh option and allowed it to both auto-detect monitor and attempt communication with the video card. I accepted all the resulting defaults rather than hard-coding any more random options. The xorg.conf it produced now works for me. It chose slightly different sync and refresh than I had before:

    HorizSync 28-84
    VertRefresh 43-60

    And it uses this Modes line for each color depth:

    Modes "1680x1050" "1024x768" "800x600" "640x480"

    Interestingly, the Ubuntu screen resolution preferences window now lists several other resolutions that are not now in xorg.conf and are not in my Parallels custom resolutions. Also, edgey eft (if you've tried the beta) breaks usplash on my screen. Futzing with vga= options on the kernel line in /boot/grub/menu.lst partially restores it.
     
  5. mykmelez

    mykmelez

    Messages:
    29
    D'oh! I completely forgot to mention that I had to modify my sync lines as well. Per this article, they are now:

    HorizSync 28-64
    VertRefresh 43-87

    Different displays will require different values, however.
     

Share This Page