"Install Parallels Tools" ---> nothing happens

Discussion in 'Installation and Configuration of Parallels Desktop' started by Stokestack, Jun 21, 2007.

  1. Stokestack

    Stokestack Bit poster

    Hi all. I installed Parallels Workstation build 4128 and launched XP in the VM and then went up to the menu and selected "Install Parallels Tools". The result is absolutely nothing. This was the same problem in build 3188. If I go back to the menu, it says "Cancel Parallels Tools installation."

    This is on a Mac Pro with no BootCamp.

    Any ideas?

  2. dkp

    dkp Forum Maven

    This happened to me on several updates and upgrades. I stopped the tools installation and stopped the vm and quit Parallels, restarted it, restarted the vm, and the tools installed ok. Sometimes it took more than once, sometimes I had to do it manually.

    Something else that will happen when the tools do install is that Windows will start popping up windows saying it's found new hardware. I've always ignored them
  3. Stokestack

    Stokestack Bit poster

    last straw

    Thanks for your response.

    I just tried restarting/reinstalling four times. No dice whatsoever. And that's not counting the far more numerous attempts under 3188.

    Without the tools, Parallels is just pointless. You can't have shared folders, and since there's no Firewire support, I can't even install software under Windows unless I burn it to a disc first.

    Parallels was a nice idea, but it is just way too unreliable to be taken seriously, and the persistent problems aren't getting resolved in new builds. I sympathize with a small company trying to produce a complicated product, but I'm done dicking around with it. I'm going to look at VMWare, and if that sucks too then it's back to two monitors and a real Windows machine.

  4. Stokestack

    Stokestack Bit poster

    Wait a minute... FOUND THE PROBLEM.

    I think I just discovered the problem with the tools installation.

    I happened to open Explorer and noticed a new drive called "Parallels Tools" in the treeview. Sure enough, I could run the setup from there and install Parallels Tools, and they now work.

    HERE'S THE PROBLEM: Parallels is creating a virtual disk that contains an autorun.inf file, and relying on Autorun to start the installation. THAT APPROACH IS DOOMED. Any knowledgeable Windows user turns Autorun off. Not only is it incredibly annoying to be badgered with a pop-up every time you plug a drive in (because Autorun ignores your "do nothing" and "always do this" choices), but it's also the means Sony and others use to install rootkits and other crapware.

    So, SWSoft, you need to find another means of installing this stuff, or you need to raise a dialog box that tells the user how to manually do so!
    Last edited: Jun 21, 2007
  5. geowits

    geowits Junior Member

    Thank you - I've been trying to install/uninstall Tools for a week now. Your solution worked just fine. I had been getting the message "VGA or better is required by this program". I have now upgraded to 10.4.10, 3214, and the Tools that are compatible with 3214. This forum is great - I've found solutions to almost all my problems here.
  6. Stokestack

    Stokestack Bit poster


    Glad it worked for you. It eliminated the "VGA adapter" and "PCI bridge device" detections on my system too.

    I was in the process of uninstalling Parallels for good when I found this solution. If these guys want to stay afloat as a company, they're going to have to step up the support by addressing at least these big, obvious problems. Otherwise, people will abandon the product and spread the ill word.
  7. rudovskypaul

    rudovskypaul Bit poster


    thanks..it worked like a charm!
  8. bubbadm

    bubbadm Bit poster

    Activation Key seems invalid!

    I am trying to install 3.0 and when I enter the activation key it seems to be invalid. Well I have tried different combinations of things, it is not the O vs 0 (zero) or I vs 1. I do have two question marks in my serial number--first time I ever saw anything like that. Tried uninstalling and reinstalling--nada! Not getting impressed with this application upgrade or support from this company. :mad:
  9. dkp

    dkp Forum Maven

    Are you using a key you received after purchasing 3.0? If so, are you upgrading from 2.5 and if that is also true do you have your key from 2.5? Both will be needed for an upgrade.
  10. Fortune500

    Fortune500 Member

    For us infrequent windows users can you give us a picture of that tree view?

  11. youngpaul

    youngpaul Bit poster

    I haven't been able to find a "Parallels Tools" drive/directory in the tree view. And if I "install parallels tools", anything I attempt to start after that locks up the system (Windows, not the Mac)....
  12. rudovskypaul

    rudovskypaul Bit poster


    Young Paul--

    Hit "Start" button
    Type "Explorer" in box and click OK
    On left side...open "My Computer"

    you should then see "Parallel Tools Setup Disk (D:)"....open that

    dbl click on PRL Tools setup.exe

    Old Paul
  13. isaac1955

    isaac1955 Bit poster

    Parallel Tools problem - a solution

    I was getting error messages about syntax errors in files when trying to upgrade Parallel Tools. The above was very useful in finding a solution though I had to do some extra things to get it to work, using Windows XP:

    1. In windows, go to Control Panel and from Add/Remove Programs remove Parallel Tools. It will probably ask you to restart to complete the action

    2. Back in Windows, go to My Computer, C Drive, Program Files folder, and if there is still a Parallels Tool folder there (Windows doesn't clean up after itself very well) delete it

    3. Quit Windows. From the Parallels Tool menu bar in OSX, go to Actions and then click Prepare Parallel Tools Upgrade. Wait for a confirmation message to appear

    4. Log back into Windows. Go to My Computer and find your CD-ROM drive - Drive D probably. Right click on it and then select Explore. Find the Tools set-up.exe file and double click it. In my case then installation worked.

    Hope this helps someone. It's a bit fiddly but it is worth it - Coherence is just mind-blowing.

  14. Digitalbrit

    Digitalbrit Bit poster

    Hi all, this post seems closely related to my current problem - its a Parallel tools install issue but with Vista.

    I'm installing Vista on Parallels v3 build 4128 and all goes well until the Parallel tools installation stage. It says to click 'install this driver software anyway', but when I select this I get the message 'Windows can't verify the publisher of this driver software'. I have mailed tech support but assume it will take a vew days for them to get back.

    Vista 'looks' to be running behind this error screen, but I'm not confident what to do next. Do I select the other option 'don't install this driver software' despite the Parallel tools messaging telling me to do otherwise? Do I somehow quit what I am doing and try and find the 'Parallel tools setup disk' and try and install it from there.

    Any advice from you seasoned Parallers would be massively appreciated.

  15. Digitalbrit

    Digitalbrit Bit poster

    Have you seen this posting saying to replace ? with 0's.

    Any good?
  16. youngpaul

    youngpaul Bit poster


    No, there is no drive visible from explorer, and no prtools.exe to double click. Thanks anyway.
  17. waldo647

    waldo647 Junior Member

    Hi all,

    OK - another hassle on updating Parallels!

    Why don't they just incorporate the Tools so we don't have these problems?!

    So here's what happening:
    - vmtools.iso is connected but grayed out
    - got initial messages about new hardware
    - it tries to install the Tools each time when I restart Windows, but it's not able to find or mount the VMtools.iso
    - do NOT see the pmtools volume in Explorer!
    - trying to add/remove Parallels Tools generates message:
    "Parallels Tools require that your Windows is running under Virtual Machine.
    The installation will be stopped."

    Any other suggestions? I really don't want to downgrade, but I have limited time to solve this stuff and I need to get my Windows running.

    - Chris
    Last edited: Jul 5, 2007
  18. waldo647

    waldo647 Junior Member

    Parallels Tools installer resolved

    OK, gave this some more thought, and tried to reason through this...

    (1) connect to vmtools.iso was greyed out, so essentially it was unavailable to Parallels, and hence the Install Parallels Tools command wasn't working.

    (2) did this image actually exist on computer? Searched for it and found it in the /Library/Parallels/Tools folder (note this is the big Library, not your User/Library).

    (3) I tried the open the disk image inside of Windows and that didn't seem to work, but I could open it on the Mac side. When it opens, it's called PRLTOOLS with a folder of items inside.

    (4) I created a folder on my H drive (in Webfolder) -- but you should be able to do this in My Documents, too -- with the same name (PRLTOOLS) and dragged into it the contents of the opened image on the Mac side.

    (5) per earlier posts, I was then able to run the PrlTools.exe (which is part of the contents) and this opened the Parallels Tools installer - and it completely successfully.

    Why the vmtools.iso image was greyed out, and unavailable in the Windows Explorer (perhaps for the same reason), is not clear to me. Permissions maybe? (I tried repairing permissions on the Mac side, as well as reinstalling Parallels 3.0, and neither helped.) But I was able to run PrlTools.exe which was the key file.

    Hope this helps,
    - Chris
  19. billw

    billw Junior Member

    Another Option

    The vmtools.iso is connected as a CDROM. I was having the same issue, but the options posted did not work for me.

    1) Stop the parallels vm.
    2) Edit|Virtual Machine ...
    3) CDROM <-- mine was connected to IDE 0:1Bill and I changed it to 1:1
    4) Press OK
    5) Restart VM
    6) I recieved lots of messages telling me about a new IDE device.
    7) I was then able to see the Parallels Tools in Explorer
    8) I have run the Parallels Tools

    Unfornately for me, this has not fixed my problem. I am still unable to get to my Mac folders. I still get the "//.PSF/macfolders" is unaccessible error, but I got past the first issue.

  20. spezio

    spezio Bit poster

    Here's another solution, because none of these worked for me.

    Windows wasn't actually recognizing the //s cd when I was trying to set up parallels tools. In OS X I found the vmtools.iso (Library/parallels/tools/) and emailed it to myself.

    Then I went to my XP in //s and downloaded and expanded it. Then just opened Prltools.exe and it FINALLY loaded fine. It only took me all day to figure it out!


Share This Page