Java web launcher not functioning through Parallels

Discussion in 'Parallels Remote Application Server' started by TechO1, Oct 16, 2019.

  1. TechO1

    TechO1 Bit Poster

    Messages:
    2
    Hi,

    We have an issue that started intermittent but has since grown to impact almost all of our users. There is a website we use that runs off several Java weblaunch applets. When clicking the applet link, the Java start up window appears. If functioning normally, this window quickly disappears and launches the applet. This works when launching the website locally (without parallels) and on the Parallels TS server. When launching it via the client, however, the Java start up window stays for much longer, then closes without launching the web applet. It behaves this way when launched from IE, from Chrome, and from downloading the jnlp file and launching it directly. We have also had this issue through multiple updates of Java. The odd thing is that it seems client machine specific. A single user can have the issue on their laptop, but then try it again on another laptop and it works fine. There does not seem to be any setting or OS version differences that affect this. Any ideas?

    Side note : We also have several chrome and IE links published with arguments that forward the browser to a specific web page when opened. These work fine in the client, but when run via HTML5, they just sit there without forwarding. Could be related.

    Jon
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @TechO1, please check the HTML5 Restrictions in the Gateway Properties. Allow embedding of Parallels Html5 Client into other web pages is to be enabled.
     
  3. TechO1

    TechO1 Bit Poster

    Messages:
    2
    Hi,

    Enabled embedding, but both issues remain. Any other suggestions?

    Thanks,

    Jon
     

Share This Page