Kali 2016 can't install Parallels Tools.

Discussion in 'Linux Guest OS Discussion' started by Thare, Feb 21, 2016.

  1. Thare

    Thare Bit Poster

    Messages:
    4
    When I install Parallels Tools in the newest Kali(2016),there is a error ...
    11.1.2 (32408)
     

    Attached Files:

    • 001.jpg
      001.jpg
      File size:
      92.3 KB
      Views:
      148
    Last edited: Feb 23, 2016
    Paul Rehak likes this.
  2. marat_t

    marat_t Kilo Poster

    Messages:
    288
    Hi,
    Try to install this packets manually.
     
  3. Thare

    Thare Bit Poster

    Messages:
    4
    Thanks.
    The problem is that the default source.list is empty.It worked after I add the source to it.
     
    YashO likes this.
  4. marat_t

    marat_t Kilo Poster

    Messages:
    288
    that makes sense. thanks for sharing =)
     
  5. JonE2

    JonE2 Bit Poster

    Messages:
    1
    Hi

    Please coul you talk me through the installation of the packets process ?

    Thanks

    Jon
     
  6. MauricioB1

    MauricioB1 Bit Poster

    Messages:
    2
    Hi ,
    I found a way to install parallel tools.

    I did install Kali 2016.1 on Parallels 11, in the moment to install parallel tools, I got the same problem.
    Trying to get the headers manually throws an error: Unable to locate the package linux-headers-4.3.0-kali1-amd64.
    After some troubleshooting, I found the way
    0) Verify that the repositories for kali are correct:
    >more /etc/apt/sources.list
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://http.kali.org/kali kali-rolling main contrib non-free

    1) >apt-get clean
    2) >apt-get update
    3) >apt-get upgrade -y
    4) >apt-get dist-upgrade -y
    5) restart
    ---- you should be upgraded to 4.4.0 or higher (use '>uname -r' to confirm)
    6) install the parallel tools by running the installer

    regards
    Mauricio

    please check the original post here:
    https://kalitut.blogspot.com.au/201...t-repositories.html?showComment=1456659118060
     
  7. NinadD

    NinadD Bit Poster

    Messages:
    1
    I am getting error asking to install linux-headers-4.3.0 and printer-driver-postscript-hp (ref S3)
    However I have already install printer-driver-postscript-hp (refer screen shot s4)
    I cant find linux-headers-4.3.0 .. and instead I have linux-headers-4.4.0 available (Refer screen shot s5)
    And linux-headers-4.4.0 is already installed. (refer Screen shot s6)
    Still I am getting error (screen shot s1) ..
     

    Attached Files:

    • s3.png
      s3.png
      File size:
      79.3 KB
      Views:
      57
    • s4.png
      s4.png
      File size:
      446.6 KB
      Views:
      61
    • s5.png
      s5.png
      File size:
      634.4 KB
      Views:
      54
    • s6.png
      s6.png
      File size:
      336.9 KB
      Views:
      55
    Last edited: Apr 26, 2016
  8. Thare

    Thare Bit Poster

    Messages:
    4
    you can find the answer in #6
     
  9. Thare

    Thare Bit Poster

    Messages:
    4
    u r right
     
  10. PascalP1

    PascalP1 Bit Poster

    Messages:
    2
    Tried all solutions in the net including #6.
    But here is the solution that worked for me:
    Just copy the whole content of the Parallels installer "CD" to your Desktop or any other directory and than do:
    $ ./install
    Thats it.
     
  11. RICKN1

    RICKN1

    Messages:
    1
    So far, not working for me. Wish that Kali would be included as one of the install options.
     
  12. Missonnier

    Missonnier Bit Poster

    Messages:
    3
    Hi,
    I follow all the explanation (repo, update, copy CD HDD, chmod, ...) but during the download, an error occurred.
    Please see under the log.
    Thanks.
     

    Attached Files:

  13. avantikathakur

    avantikathakur Bit Poster

    Messages:
    1
    Try this one steps:
    Open up a Terminal window in Kali and run the following commands
    cd /media/cdrom0
    cp -r install installer/ kmods/ tools/ version /tmp
    cd /tmp
    ./install
     
  14. Missonnier

    Missonnier Bit Poster

    Messages:
    3
    Thanks. I tried it, but doesn't work... Same issue... (see file attached)
    Anything else ?
    Thanks
     

    Attached Files:

  15. harkants

    harkants Bit Poster

    Messages:
    2
    what I did to get installation of the Parallels Tools -
    Copied the contents of Parallels tools CD to a folder on Desktop - changed the permissions of 'install, 'install-gui' and one more file (i dont remember which was it) - then I could run the installation.
    Later I installed some packages as suggested by the installer.
    I did the update, upgrade and dist-upgrade
    But still the installer keeps asking me to install 'printer-driver-postscript-hp' which actually is already installed and reinstalled it many times. when the installer tries to install it by itself it returns some error - error in installing parallels tools please look up the log file --.
    Please help me
     
    Last edited: Sep 16, 2016
  16. Missonnier

    Missonnier Bit Poster

    Messages:
    3
    Ok thanks, i tried it too...
    I've got a problem during downloading after prompt : "Some component needed for Paralleles Tools installation are missing on your system. Do you want to download theses component automatically?"
    I choose "Next" (Yes), then, download begins... then error.
    An idea ?
     
  17. NicolaA1

    NicolaA1 Bit Poster

    Messages:
    2
    Hi, i have the same issue.
    I did what suggested in #6, but it keeps asking me to install printer-driver-postscript-hp.
    Here is the log file.
    Help, please!

     
  18. NicolaA1

    NicolaA1 Bit Poster

    Messages:
    2
  19. PaulCW

    PaulCW Bit Poster

    Messages:
    4
  20. OscarG1

    OscarG1

    Messages:
    1
    I am having this same issue. I have verified that the printer-driver-postscript-hp is installed, yet the installation still says it is missing
     

Share This Page