KB890859 - over and over again

Discussion in 'Parallels Desktop for Mac' started by cjsutton, Dec 22, 2006.

  1. cjsutton


    Just upgraded from beta 1 to beta 2, using Boot Camp. Followed the instructions, everything works fine, except for one slight problem:

    When my Boot Camp VM is running in Parallels, Automatic Updates pops up and tells me that I need to install KB890859 (I already had it installed). I accepted the first time, and after rebooting, it pops up again and tells me I need the patch.

    I followed instructions on another website (basically uninstalling and reinstalling the patch - manually, duh) and it basically broke Parallels Tools. During the uninstall, it warned me it would remove a bunch of recently installed devices, most of which looked like the Parallels virtual hardware. I accepted this, finished the uninstall and reinstall, then reinstalled Parallels tools, and it's all working again.

    However, after the next reboot, guess what? Automatic Updates is telling me I need to install KB890859!

    Does the new Parallels Tools or some piece of the Boot Camp "hook" overwrite or change one of the files related to this patch? It doesn't seem to come up when I boot natively into Boot Camp.

    Thanks in advance!
  2. cjsutton


    Fixed it

    Booted the VM into Parallels using the "Diagnostic Startup" option in MSCONFIG - then reinstalled the patch again, this time it seems to have taken.
  3. theFATangel


    Last edited: Dec 30, 2006
  4. MysticalOS


    What's interesting is it was NEVER a problem in boot camp before letting parallels boot boot camp. for many months never had a problem, so if one of the files got replaced by parallels is only explanation to it appearing over and over again now...this pudate was applied in my config before EVER running parallels and it was applied successfully. now, it asks for it every boot up...I may try that fix mensioned here later but what is gonna keep parallels from breaking it again? cause like i said my install WAS correct prior to parallels...so there is a bug to be searched out here.
  5. cjsutton


    I agree. I just installed Beta 3, and guess what? The patch is again asking to be reinstalled ad infinitum. This time, the "boot into diagnostic mode" trick doesn't fix it.

    I'm also getting the problem where Parallels keeps telling me it's installing Parallels tools, every time I boot up my Boot Camp VM.

    Help! :)
  6. mackworth


    I downloaded the patch from MS(not through automatic update, through the web), then booted into diagnostic mode and installed it. Worked fine.
    Last edited: Jan 3, 2007
  7. chrisdressler


    Install patch with "/o" switch

    You can also download the patch from http://download.microsoft.com (as mentioned above), searching for it by KB number. Then, from the Run command in the Start menu, you can launch the patch you downloaded, but run it with the /o switch (that is "oh", not zero).

    So an example would be: KBXXXXX.exe /o

    What is happening is that some of the drivers and associated .dll's and other files installed by the Boot Camp drivers CD aren't signed, so they aren't replaced correctly with some of these patches, so the patch doesn't correctly get applied and Windows Update gets into a loop with it.

    If you install the patch manually with the "/o" switch, that should take care of your problem.
  8. maverick808


    I've tried both installing in diagnostic mode and using the /o switch. So far, neither have worked and I still keep seeing the update.
  9. nmdaltp


    I tried multiple methods (some of them almost destroyed my Bootcamp VM) without success. And finally I found an easy way to get rid of the notification. When the update shows, go to the custom install selection then check the box of "don't remind me again". so far so good. I haven't been reminded for over one week now.
  10. Tom Savel

    Tom Savel

    Hi all...

    I'm using beta3.....

    I'm also getting the problem where Parallels keeps telling me it's installing Parallels tools, every time I boot up my Boot Camp VM.

    Thanks for the advice on how to turn off that pesky update... ahhh.....feels better.

    Oh, running that install with /o didn't seem to make a difference for me.

    Nice to know I'm not the only one with this issue. :)


  11. luomat

    luomat Kilo Poster

    happening with RC1

    FWIW... I'm seeing this with XP Pro running inside Parallels RC1
  12. mlh78750


    Me too!!

    I am having the same problem. I get the notice about installing the tools each time, and forever it wants to install this update. I am also running RC1. This is a Bootcamp partition that I am booting under RC1.
    Last edited: Jan 29, 2007
  13. snipes


    Same problem here with RC1. If I boot the partition with Boot Camp I don't continually see this notification. It's only when booting in Parallels that it wants to install it each time.
  14. SoftCoder


    I think MysticalOS is right

    First, hi all, I'm new to these forums (and Parallels)...

    I'm having the same problem with a clean install of XP SP2 in Boot Camp, then using it in parallels. I agree completely with MysticalOS, the behaviour I see is completely consistent with Parallels overwriting some file that KB89085 updates. It doesn't prompt for the update unless I have run parallels since the last time I updated. Also, Parallels always tells me to wait so it can install its tools.

    This looks like a bug that would have to be fixed by the Parallels team. It doesn't look like we're having any luck fixing it ourselves.

Share This Page