Keep connect and disconnect when tried to connect my Android phone to Windows 10

Discussion in 'Parallels Mobile Device Management' started by ZhenchengF, Oct 23, 2021.

  1. ZhenchengF

    ZhenchengF Bit Poster

    Messages:
    3
    System Version: macOS Big Sur 11.6 (20G165)
    Paralles Desktop Version: Version 17.1.0 (51516)

    When I use Paralles Version 16, the USB doesn't work too.

    And I upgraded to Version 17. The Android phone can connect to my Mac without problem. But when I tried to connect it to Paralles Windows 10, my phone will keep connect and immediately disconnect.

    I tried to reinstall Paralles, didn't work.

    I think the problem is Paralles, because even when Windows 10 was starting, it started keep connect and disconnect.

    Is there anyone can solve this problem?
     
  2. JavaC

    JavaC

    Messages:
    1
    Me and 2 colleagues have had this issue for quite some time.
    We cannot detect the device in windows properly no matter what we try. Everything works fine in MacOS (i can properly debug apps in MacOS and ADB commands work fine). Depending on what mix i use of USB connection mode and usb debugging ON/OFF, the phones will behave differently though.
    - With usb debugging enabled and mode set to MTP, device will stop flickering (disconnect -> reconnect loop) in the parallel Device -> USB menu but wont be available in the device manager or other menus.
    - With usb debugging enabled and mode set to PTP, device will flicker (disconnect -> reconnect loop) in the parallel Device -> USB menu and wont show in the device manager at all.
    - With usb debugging enabled and mode set to "charge only", device will not flicker but will show as totally unrecognized in windows (windows will not be able to detect hardware IDs at all but will see the device, although claiming it is unknown/bugged)
    - Doing the same things with ADB disabled will yield very similar results, mostly, with occasional differences (charge only wont show the device at all)

    At first i thought it was a device/cable/port/usb hub issue so i tried 5 different cables, including usb-c to usb-c directly into the hub, usb A to usb-c through a usb hub (in both USB 2.0 and 3.0 ports).
    I tested with 3 devices:
    - Ulephone Note 11P (Android 11)
    - Pixel 4a (Android 11)
    - Pixel 1 XL (Android 9)
    My computer:
    Macbook Pro 16inch 2019, Core i9
    MacOS Monterey 12.2.1
    issue was present in every updates of MacOS 12 (from 12.0 to 12.2.1) and also many MacOS 11 updates.
     
  3. rrtt_2323

    rrtt_2323 Bit Poster

    Messages:
    6
    me too!
    macos Monterey 12.4
    This bug for a long time.....
    Before I installed version 12, to avoid this bug.
    But under the new system, version 12 cannot be installed.
    I'm in a hurry. It's Interfering with my work.
     
  4. EvertW3

    EvertW3 Bit Poster

    Messages:
    1
    I can confirm these issues. I am developing Xamarin apps using Visual Studio 2022. Natively on my Mac (using VS 2022 for Mac) I can connect and debug to an Android Phone but inside Windows 10 it keeps on connecting and disconnecting. Also re-tried it using a freshly installed Windows 11 maching running VS 2022, but same problems. And yes I tried several Android phones/cables (USB-C and the legacy ones).

    Strange thing is an iPhone does not suffer from the same connect/disconnection problems.

    I am running Visual Studio 17.2.5 (retried it too with the previeuw version 17.3.x) with everything updated to the latest version as of date of writing. Tested it on an Intel Mac Mini 2018, 32 Gb.

    And I finally re-tested it using VMWare Fusion and I can confirm the same setup works here.
     
  5. rrtt_2323

    rrtt_2323 Bit Poster

    Messages:
    6
    I bought a Windows computer. It's time to say goodbye to Parallels.
     
    EvertW3 likes this.

Share This Page