Keyboard in Big Sur guest does not work after suspend/resume

Discussion in 'Mac OS X Guest OS Discussion' started by GarthS, Sep 1, 2021.

  1. GarthS

    GarthS Bit Poster

    Messages:
    12
    There are a couple of other posts sniffing around this or similar issues, but they're mostly reviving years-old threads. Also, in my case, the behavior doesn't occur with Windows 10 or Linux guests.

    The problem: In Big Sur guest OSes, the keyboard works normally for VMs that are freshly booted. However, suspending and then resuming a VM results in the keyboard not working. No keypress events are propagated to the VM. I see this 100% of the time and the effect occurs in multiple VMs. The Big Sur version is 11.5.2; that is also the host OS.

    Unlike some other reports, my trackpad continues to work normally after resuming.

    I submitted a technical data report as well.
     
  2. DwightB

    DwightB Bit Poster

    Messages:
    8
    I am also having this problem. The host OS in my case is Catalina, otherwise the rest is the same. After a suspend/resume, the keyboard does not work. It works fine after a restart or shutdown/start.

    Does not seem that anyone is interested in this thread. Have you had any luck solving the problem?
     
  3. GarthS

    GarthS Bit Poster

    Messages:
    12
    If this query is directed at me (the OP), no, I have not. Well, OK, I have, but the solution is "Don't use macOS guests under Parallels for now."
     
  4. PaulM62

    PaulM62 Bit Poster

    Messages:
    1
    Have exact same problem in Big Sur. Catalina and other VMs always work fine.
     
  5. KevinS99

    KevinS99 Bit Poster

    Messages:
    1
    I am having this issue too, and only way to resolve so far is restart the VM. Relaunching Parallels does not help.
     
  6. ThomasTankmar

    ThomasTankmar Bit Poster

    Messages:
    9
    I have the same issue. Have tried:
    - Update to macOS Monterey Beta 8
    - Re-install Parallels Tools
    - Perform a fresh install of macOS Big Sur 11.6
    But same problem. Keyboard is not working after suspend/resume, and only solution so far is to restart the VM.
     
  7. Mr. C.

    Mr. C. Bit Poster

    Messages:
    50
    Same issue here w/Big Sur. Parallels lack of response or solution here is disturbing.
     
  8. PaulW11

    PaulW11

    Messages:
    1
    Big Sur and Monterey both have this problem for me.
     
  9. Tender

    Tender Bit Poster

    Messages:
    2
    Same issue with Big Sur guest VM on Big Sur. Both 11.6
     
  10. ShadowVA

    ShadowVA Bit Poster

    Messages:
    5
    I am seeing this issue 100% of the time running Parallels 17.0.1 and macOS 11.6 in both the host and VM. Rebooting the VM is the only way to solve the issue.
     
  11. Tender

    Tender Bit Poster

    Messages:
    2
    Just curious, anyone using an external keyboard that is also experiencing the issue? Using mechanical keyboard through a dock that connects to the MacBook. The laptop lid is closed, external displays. The keyboard goes dead inside the guest VM.
     
  12. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    36
  13. Just_me

    Just_me

    Messages:
    2
    I'm having the same issue on a 2018 Mac mini with macOS 11.6 and Parallels 17.0.1, VM running the latest Monterey beta. Keyboard stops working in the guest VM after resuming, the only way to make it work again is to restart the VM.

    Tried selecting "Optimize for games" for keyboard in Parallels preferences, but it does not fix the issue.
     
  14. Just_me

    Just_me

    Messages:
    2
    ...aaaand I've just got an update to Parallels 17.1.0 (51516), it solved the keyboard issue! So, if anyone is having the same problem, and when the moderator sobers up and "approves" my both posts (apparently I look like a robot, happens all the time, bleep bleep), just check for updates and install the latest version of Parallles Desktop.
     
  15. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    18
    Hello, we are happy to hear that your issue has been fixed with your latest update. Thanks, Parallels Team.
     

Share This Page