Keyboard issues

Discussion in 'Parallels Desktop for Mac' started by jelockwood, Apr 11, 2006.

  1. jelockwood

    jelockwood

    Messages:
    9
    F8 does not work in beta2. This is actually listed as a known issue but the suggested workaround is to use Fn F8 (Function and F8). Unfortunately this will not work on a desktop Mac (such as the iMac or Mac mini) as the desktop Apple keyboard does not have a Fn (Function) key (the MacBook Pro does).

    The following keys do not map correctly between a Mac and the client Windows XP.

    Typed on Mac Result in Windows
    @ "
    " @
    ~ ¬ (equivalent of Option L on a Mac)

    Note: this is with a UK keyboard plugged in to the Mac and UK keyboard layout defined in Windows.

    While the @ and " are swapped and are an error, and both Virtual PC and Timbuktu can make the same error, the above list is somewhat impressive for its shortness. Timbuktu (by Netopia) has a much longer list of incorrect mappings (between a Mac and PC when controlling the opposite operating system), this is despite my having reported this to Netopia several times going all the way back to 2000 [Grrrrr!!! :mad: ]

    Also as mentioned elsewhere, keyboard repeating does not work either.
     
  2. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Thanks for reporting! We are working on thease issues already and number of fixes will be included into nearest update.
     
  3. bcjenkins

    bcjenkins

    Messages:
    23
    The decimal key on the numeric keypad is not working for me within the XP OS. I am running a MBP, and using a Logitech S530 setup.

    Brandon
     
  4. steve3

    steve3

    Messages:
    32
    I have the same decimal issue as bcjenkins, using Win2K, a 1.83ghz iMac and a MS 4000 ergo keyboard.
     
  5. andwi

    andwi

    Messages:
    10
    I have a swedish MBP and normally use the US kb layout (you just have to avoid looking at the keys.) I can't get a vertical bar (or backslash) regardless how I try. With the US keyboard layout I get []; in the right places but the \ key produce < instead. If I switch to the swedish keyboard layout I get åäö and so on, but the ' key still produce < and option-7 doesn't work. I run a Fedora client now, but had the same problem when I first tried ubuntu. (Couldn't get Fedora 5 to work until I tried with 256M ram instead of more.)
     
  6. denbee

    denbee

    Messages:
    5
    When filling in forms or trying to login the "d,e,r,u,f,l,f & m" keys act like shortcut keys. I can't login to this forum using paralles.:confused:
     
  7. bcjenkins

    bcjenkins

    Messages:
    23
    Installed Beta 3.. Still no decimal on the keypad.

    Thanks

    Brandon
     
  8. dhjdhj

    dhjdhj

    Messages:
    220
    I noticed that the DELETE key doesn't work inside the VM.
    D



     
  9. tolaini

    tolaini

    Messages:
    17
    Beta3, still "\" not working on italian keyboard, and "<" gives "\".
     
  10. andwi

    andwi

    Messages:
    10
    Lucky you. I still get <> when I expect \|. I have a Swedish MBP, US keyboard layout in MacOSX and US keyboard layout in Fedora Core Linux. Changing the MacOS kb layout doesn't seem to change the behavor in Fedora. If I switch to the swedish kb in Fedora I get swedish characters on most keys, but still <> on the '* key (same key that produce \| on us kb).
     
  11. csimfu

    csimfu

    Messages:
    1
    xmodmap is your friend

    same issues for me on my MBP with \ and |.

    A workaround...

    xmodmap -e "keycode 94 = backslash bar"
     
  12. brian

    brian

    Messages:
    10
    Thanks for the fix. Trying to use Linux and code without | or \ is a real killer.
     
  13. pcunix

    pcunix

    Messages:
    17
    US keyboard MacBook Pro with Beta 3

    | (pipe) still generates > in Linux (any Linux) but is OK in Windows.
     
  14. ballanty@sfu.ca

    ballanty@sfu.ca

    Messages:
    1
    Just reporting "\" "|" key (one is shifted other) on MBP just don't seem to work for me.
    I've check the forums but no one else seems to have the same problem. I'm using
    the standard US Keyboard (tried Canadian as well).
     
  15. PCMacGuy

    PCMacGuy

    Messages:
    10
    Same problem too. Decimal point doesn't work
     
  16. vamp07

    vamp07

    Messages:
    86
    On Beta I think the key repeat may be too aggressive. I sometimes hear a double click when I just press the key once. I also mentioned this before but the program should take over all function keys while it owns input. I'm thinking of keys F9-F12 which come preassigned by apple.
     
  17. jaysoffian

    jaysoffian

    Messages:
    2
    To fix the console, use loadkeys. For RHEL (and probably Fedora):

    cd /etc/sysconfig/console
    dumpkeys > default.kmap
    echo "keycode 86 = backslash bar" >> default.kmap
    loadkeys default.kmap

    That should persist across reboots. Note that this only fixes the console. You still need to use xmodmap to fix things up under X.

    Also, I'm not sure the reason for the differing keycode. To find out what the keycode is for your system, run "showkey" then press the backslash/bar key on your keyboard. showkey will say something like:

    keycode 86 press
    keycode 86 release

    Press and release the key a few times just to make sure. It's that keycode that you want to use in the echo line. You'll have to wait 10 seconds w/o typing anything for showkey to exit.

    j.
     
    Last edited: Apr 18, 2006

Share This Page