Latest Clean Drive has problems!

Discussion in 'Parallels Toolbox for Mac' started by Don Awalt, Oct 9, 2023.

  1. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    I am using the new version that just got updated, Version 6.6.0 (4851). I have not tried Clean Drive for about a month. Today, in several attempts, two problems surfaced:
    1) To finish the scan takes about 2 minutes now. I have a very fast MacBook Pro, it used to take maybe 10 seconds.
    2) When Clean Drive finished, if I bring it up again, after another 2 minute scan, it shows the Trash Can was not cleared even though I was sure to have the check box checked. I verified by bringing up the trash can that it was not cleared. I verified there were no issues of files being 'stuck' in the Trash Can, as I was able to manually use the MacOS 'Empty Trash can' command to clear it completely.
    Could this be a MacOS Sonoma problem? I am on MacOS 14.0 (Sonoma).
     
  2. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    570
    Hello,
    For us to further investigate the issue, kindly generate a technical report right after reproducing the issue again as outlined in https://kb.parallels.com/en/124107 and provide us with the report ID.
    Thank you.
     
  3. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    Thanks @Pramesh Boodadoo, I just tried Clean Drive again, and found an additional problem (#3 below). This is the text of what I sent; I timed it this time as well. The report ID is #439446594.
    1) To finish the scan today took 2 minutes 25 seconds now. I have a very fast MacBook Pro, it used to take maybe 10 seconds. It's been this slow since the last update.
    2) In the past, with Trash selected it said it cleared it out, but it did not.
    3) Today when trying it again, it would not let me select to clear the Trash Can - it was grayed out, showing 0 GB in it (so of course it would not let me select to clear it as Clean Drive thought it was already clear). However, there was 106.7 MB in the Trash Can. I just now cleared it manually, completely - there were no locked files or permissions problems with files in the Trash Can.
     
  4. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    502
    hi @Don Awalt ,
    I suppose the issue might be related to the fact Parallels Toolbox doesn't have Full disk access permissions due to the upgrade of macOS to Sonoma.
    As a preliminary step, kindly quit Parallels Toolbox, then open System Settings > Privacy & Security > Full disk Access > make sure Parallels Toolbox is selected. Then check again.
     
  5. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    Thanks @Mikhail Ushakov for the reply. I quit Toolbox and verified Full Disk Access was set. I ran Toolbox and tried Clean Drive again, same behavior (#1 and #3). I noticed one other thing this time though, when it first came up, it had a storage value for Trash (and some other ones, but they went away quickly). But then it turned them all to 0 GB and disabled them/turned gray. That all happened very very fast, well under a second.
     
  6. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    FYI this problem still exists in 6.6.1
     
  7. GINOV

    GINOV

    Messages:
    1
    Same problem with Toolbox 6.6.1... Terribly slow with my M2 Macbook and Sonoma...
     
  8. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    502
    Hello!
    Could you generate a technical report right after reproducing the issue as outlined in https://kb.parallels.com/en/124107 and provide us with the report ID, please?
     
  9. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    @Mikhail Ushakov done! Report ID 442511956. This was the problem description I entered:

    Clean Drive takes a very long time - this time, it took 2 minutes 51 seconds to get to the point of being able to press the button to clean. This is on a MacBook Pro M2 Max with 96GB memory, a very fast computer. When Clean Drive is run, the summary window immediately shows Trash file size, but the Log File and Cache file lines had 'spinning beach balls' for the 2 min 51 sec. The file sizes for these 2 categories were not large once finally calculated - log files 0.75 GB, cache file 2.93 GB. All the other categories were 0 GB, which it showed right away.
     
  10. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    456
    Hello @Don Awalt,

    Thank you for the provided technical report.

    Please note that we have forwarded the information to our development team for further investigation.

    Once we have an update from them, we will let you know.

    Thanks
     
  11. Pandu

    Pandu Bit poster

    Messages:
    4
    Hello, I have a related problem. I tried using Clean Drive today after a few months. Clean drive works till the point of estimating files to be deleted. When the 'Clean Up' button is clicked it does not proceed to clean up. Instead there is an error window pop-up. The pop up keeps appearing even after I have force-quit Clean Drive. I have attached a screen-shot of the error message here.
    FYI, I have checked the system preferences and confirmed that Clean Drive has full disk access.
    My system is a Powerbook M1 Pro, running MacOS Monterey 12.7.1. Parallels Toolbox says my version is up-to-date with the latest updates.
     

    Attached Files:

  12. Don Awalt

    Don Awalt Hunter

    Messages:
    134
    Is there any update on the problems of the original post? When can we expect an update, this is unbelievably slow to use now.
     
    MircoV1 likes this.
  13. MircoV1

    MircoV1 Bit poster

    Messages:
    4
    I have the same problem ! Any update ? Is there a fix about it ? Thanks in advance...
     
  14. Pandu

    Pandu Bit poster

    Messages:
    4
    My problem has disappeared. I didn't do anything. Perhaps the software was updated, but whatever the change my Parallels works fine now. My current OS version is Monterey 12.7.2 and Cleandrive is 6.6.1
     
  15. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    331
    To aid us in troubleshooting this further, please collect a technical report while the issue is being reproduced (click the Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in reply to this post.
     
  16. MircoV1

    MircoV1 Bit poster

    Messages:
    4
    The ID is 451726771
    Regards
     
  17. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    331
    Please note that a new version of Parallels Toolbox has been released (6.6.2).

    Kindly update your application by following the steps provided below and attempt to reproduce the issue:

    Click the Parallels Toolbox icon (See screenshot) > Settings (Gear) icon > Check for updates
     
  18. MircoV1

    MircoV1 Bit poster

    Messages:
    4
    I just updated it to the last version this morning but the issue is the same !
    Do you need a new Report ?
     

Share This Page