Link inside shared folders

Discussion in 'Linux Guest OS Discussion' started by Andreas_B., Mar 15, 2013.

  1. Andreas_B.

    Andreas_B.

    Messages:
    2
    I use an UBUNTU 12.04 as guest system with the parallels Desktop 8.0, tools installed and everything works fine, but...I can not create a hardlink to files inside my shared folders.
    (Source and target are both inside my shared folders!)

    Something like

    ln /media/psf/Home/test/pifffile /media/psf/Home/test/paffile

    will create an error saying that the operation is not allowed.

    if I do the same from a console on my host (Mountain Lion) the command:

    ln test/piffile test/paffile

    works fine in my homedir.

    The shared folder "test" and the files inside have full access rights, is this a problem of the prl_fs? Any advice would be welcome.
     
    Last edited: Mar 15, 2013
  2. ParallelsU2

    ParallelsU2

    Messages:
    1
    Ran into this particular silly issue myself. Looks like prl_fs just doesn't support making hardlinks. This should be a minimal change to actually support such a thing -- a simple callout to the link(2) system call on the host system would be trivial to support. Can we get this at some point?
     
  3. Pavel3

    Pavel3 Bit Poster

    Messages:
    3
    Also faced with this issue myself, when tried to execute build inside docker image with shared folders. Are there any workarounds? If not, then will this be supported some time in the future? Thanks!
     
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,694
    Hi, please let us know did you test this option with the latest version of Parallels Desktop (11.1.3-32521)?
    Also to investigate this issue further with our Development team please generate the problem report using this KB and reply us back with the report 8-digit ID number.
    We're looking forward to your reply and will be glad to help.
     
  5. Pavel3

    Pavel3 Bit Poster

    Messages:
    3
    Hi, thanks for your reply!
    Currently I'm using the latest version of Parallels Desktop for Mac (11.1.3-32521), but as a workaround with NFS share instead of prl_fs share.
    NFS share works ok, and initially I was confused with that, and thought that hard link issue was resolved in latest version, but later I decided to create clean docker-machine with the default prl_fs share and tried to mount test folder. Problem still exist.
    I created a problem report 91126554 for this issue.

    Hope this problem will be fixed soon. Thanks!
     
  6. KenM4

    KenM4

    Messages:
    1
    I see the same problems on Parallels Desktop 14 for Mac (14.0.0 45124). I want to hear the update.
     
  7. LeonardoS1

    LeonardoS1

    Messages:
    1
    Same issue here
    Parallels for Mac Version 17.1.1 (51537)

    If it is not possible to fix at all, some kind of warning could be displayed or something.
     
  8. Krysalisco

    Krysalisco Bit Poster

    Messages:
    4
    I encountered this problem while trying to create a docker image with shared folders. Are there any solutions? If not, will it be supported for some time in the future? Thank you very much!
     

Share This Page